aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2001-03-13 23:20:57 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2001-03-13 23:20:57 +0000
commit5b8fe0427bc1cf2b1a46c982b8fe47eb2ec304ae (patch)
tree04d12728b29b594b1c21a84a391d5bdd41b861fd
parentf3d0fad83a07b85bc6787ca7d26d5f59172eccd6 (diff)
downloadports-5b8fe0427bc1cf2b1a46c982b8fe47eb2ec304ae.tar.gz
ports-5b8fe0427bc1cf2b1a46c982b8fe47eb2ec304ae.zip
Notes
-rw-r--r--net/FlowScan/Makefile30
-rw-r--r--net/FlowScan/distinfo1
-rw-r--r--net/FlowScan/pkg-comment1
-rw-r--r--net/FlowScan/pkg-descr9
-rw-r--r--net/FlowScan/pkg-plist12
-rw-r--r--net/Makefile1
6 files changed, 54 insertions, 0 deletions
diff --git a/net/FlowScan/Makefile b/net/FlowScan/Makefile
new file mode 100644
index 000000000000..c18e371cbe06
--- /dev/null
+++ b/net/FlowScan/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: FlowScan
+# Date created: Di 13 Mär 2001 08:23:55 CET
+# Whom: andreas@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= FlowScan
+PORTVERSION= 1.006
+CATEGORIES= net
+MASTER_SITES= http://net.doit.wisc.edu/~plonka/FlowScan/
+
+MAINTAINER= andreas@freebsd.org
+
+BUILD_DEPENDS= ksh:${PORTSDIR}/shells/pdksh \
+ rrdtool:${PORTSDIR}/net/rrdtool \
+ cflowd:${PORTSDIR}/net/cflowd \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Boulder/Stream.pm:${PORTSDIR}/converter/p5-Boulder \
+ ${LOCALBASE}/lib/perl5/site_perl/${{PERL_VER}/ConfigReader/DirectiveStyle.pm:${PORTSDIR}/devel/p5-ConfigReader \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Table.pm:${PORTSDIR}/www/p5-HTML-Table \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Cflow.pm:${PORTSDIR}/net/p5-Cflow
+
+CFLOWD_FLOWSCAN_PATCH= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}/var/flows
+
+pre-install:
+ ${MKDIR} -p ${PREFIX}/var/flows/bin
+
+.include <bsd.port.mk>
diff --git a/net/FlowScan/distinfo b/net/FlowScan/distinfo
new file mode 100644
index 000000000000..bbc3e808e600
--- /dev/null
+++ b/net/FlowScan/distinfo
@@ -0,0 +1 @@
+MD5 (FlowScan-1.006.tar.gz) = 3c687ae0ffab82dadeb4086f122bcee5
diff --git a/net/FlowScan/pkg-comment b/net/FlowScan/pkg-comment
new file mode 100644
index 000000000000..03f19c6cf123
--- /dev/null
+++ b/net/FlowScan/pkg-comment
@@ -0,0 +1 @@
+processes IP flows recorded in cflowd-format raw flow files
diff --git a/net/FlowScan/pkg-descr b/net/FlowScan/pkg-descr
new file mode 100644
index 000000000000..2a87f160ced5
--- /dev/null
+++ b/net/FlowScan/pkg-descr
@@ -0,0 +1,9 @@
+FlowScan is a tool to monitor and graph flow information from
+Cisco and Riverstone routers in near real-time.
+
+Amonst many other things, FlowScan can measure and graph traffic
+for applications such as Napster.
+
+A sample of what FlowScan can do is at: http://wwwstats.net.wisc.edu
+
+WWW: http://net.doit.wisc.edu/~plonka/FlowScan/
diff --git a/net/FlowScan/pkg-plist b/net/FlowScan/pkg-plist
new file mode 100644
index 000000000000..f4ed43780744
--- /dev/null
+++ b/net/FlowScan/pkg-plist
@@ -0,0 +1,12 @@
+var/flows/bin/flowscan
+var/flows/bin/FlowScan.pm
+var/flows/bin/CampusIO.pm
+var/flows/bin/SubNetIO.pm
+var/flows/bin/locker
+var/flows/bin/add_ds.pl
+var/flows/bin/add_txrx
+var/flows/bin/event2vrule
+var/flows/bin/ip2hostname
+@dirrm var/flows/bin
+@dirrm var/flows
+@dirrm var
diff --git a/net/Makefile b/net/Makefile
index 863c66d930d4..d2f005e77e60 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -3,6 +3,7 @@
SUBDIR += 44bsd-rdist
SUBDIR += 6tunnel
+ SUBDIR += FlowScan
SUBDIR += NeTraMet
SUBDIR += SSLtelnet
SUBDIR += adasockets