aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-19 01:33:42 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-19 01:33:42 +0000
commit5c6f51f8b9971eb31a66d5b1ea298f51f361d12d (patch)
tree9b3688e90456959d9c206c4445c77c02c020d61d
parent40e159bd90fd2eca63b761bf1b924aba1786d4c3 (diff)
Notes
-rw-r--r--biology/nab/Makefile8
-rw-r--r--games/nil/Makefile8
-rw-r--r--misc/nserver/Makefile8
-rw-r--r--net/netmap/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/biology/nab/Makefile b/biology/nab/Makefile
index 95a223dc4cbb..d308bccff7de 100644
--- a/biology/nab/Makefile
+++ b/biology/nab/Makefile
@@ -34,6 +34,12 @@ LIBRARIES= cifparse.a libnab.a libsym.a
INCS= defreal.h nab.h nabcode.h nabtypes.h
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not install on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${CP} ${FILESDIR}/config.h ${WRKSRC}
@@ -96,4 +102,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/nil/Makefile b/games/nil/Makefile
index 5458de835662..bd563d95f3ed 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -22,6 +22,12 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_SDL= mixer sdl
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-patch:
@${FIND} ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
${XARGS} ${REINPLACE_CMD} -e 's|"SDL/|"|g ; s|<SDL/|<|g'
@@ -40,4 +46,4 @@ post-install:
@${ECHO_MSG} "See ${PREFIX}/share/nil/README for usage instructions."
@${ECHO_MSG} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/nserver/Makefile b/misc/nserver/Makefile
index a2e52fe619e8..e90735f9c903 100644
--- a/misc/nserver/Makefile
+++ b/misc/nserver/Makefile
@@ -25,6 +25,12 @@ PLIST_FILES+= share/doc/nserver/README
PLIST_DIRS= share/doc/nserver
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-patch:
@${REINPLACE_CMD} -e "s|-O2|${CFLAGS}|g; \
s|ttyS3|cuaa0|g; \
@@ -39,4 +45,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/netmap/Makefile b/net/netmap/Makefile
index e067bdcd25ed..d986e59dd422 100644
--- a/net/netmap/Makefile
+++ b/net/netmap/Makefile
@@ -20,8 +20,14 @@ RUN_DEPENDS= dotty:${PORTSDIR}/graphics/graphviz
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/makelist/makelist ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/netmap/netmap ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>