aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-04-27 06:01:54 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-04-27 06:01:54 +0000
commit6a687a94550084a99ed233fb857b82af5dd5b0a1 (patch)
treef1fb2dc1a17ed25e0c191593046ff487f5db15da
parentfa879418db829cfc3fe19a6fb584e6d1bfc2ce86 (diff)
Notes
-rw-r--r--x11-themes/gnome-art/Makefile9
-rw-r--r--x11-themes/gnome-art/files/gnome-art.desktop.in10
-rw-r--r--x11-themes/gnome-art/pkg-plist2
-rw-r--r--x11-themes/gnome-splashscreen-manager/Makefile9
-rw-r--r--x11-themes/gnome-splashscreen-manager/files/gnome-splashscreen-manager.desktop.in11
-rw-r--r--x11-themes/gnome-splashscreen-manager/pkg-plist2
6 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/gnome-art/Makefile b/x11-themes/gnome-art/Makefile
index 00e65f10ddf6..43b20a86d37f 100644
--- a/x11-themes/gnome-art/Makefile
+++ b/x11-themes/gnome-art/Makefile
@@ -19,11 +19,20 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTNAME}
USE_RUBY= yes
USE_REINPLACE= yes
USE_RUBY_SETUP= yes
+GNOMEART_ICON= ${DATADIR}/glade/pixmaps/gnome-graphics.png
post-patch:
+ @${SED} -e 's|%%COMMENT%%|${COMMENT}|; \
+ s|%%GNOMEART_ICON%%|${GNOMEART_ICON}|' \
+ < ${FILESDIR}/gnome-art.desktop.in \
+ > ${WRKDIR}/gnome-art.desktop
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
${WRKSRC}/lib/gnome-art/ui/main_window.rb \
${WRKSRC}/lib/gnome-art/ui/download_dialog.rb
@${FIND} ${WRKSRC} -name '*.bak' -delete
+post-install:
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKDIR}/gnome-art.desktop ${PREFIX}/share/applications
+
.include <bsd.port.mk>
diff --git a/x11-themes/gnome-art/files/gnome-art.desktop.in b/x11-themes/gnome-art/files/gnome-art.desktop.in
new file mode 100644
index 000000000000..1f2cb75f7c52
--- /dev/null
+++ b/x11-themes/gnome-art/files/gnome-art.desktop.in
@@ -0,0 +1,10 @@
+# $FreeBSD
+[Desktop Entry]
+Encoding=UTF-8
+Name=Theme Downloader
+Comment=%%COMMENT%%
+Icon=%%GNOMEART_ICON%%
+Exec=gnome-art
+Terminal=false
+Type=Application
+Categories=Application;Settings;AdvancedSettings;
diff --git a/x11-themes/gnome-art/pkg-plist b/x11-themes/gnome-art/pkg-plist
index 75ba65070422..5f962d52da6d 100644
--- a/x11-themes/gnome-art/pkg-plist
+++ b/x11-themes/gnome-art/pkg-plist
@@ -10,9 +10,11 @@ bin/gnome-art
%%RUBY_SITELIBDIR%%/gnome-art/gnome_art.rb
%%RUBY_SITELIBDIR%%/gnome-art/ui/main_window.rb
%%RUBY_SITELIBDIR%%/gnome-art/ui/download_dialog.rb
+share/applications/gnome-art.desktop
@dirrm %%RUBY_SITELIBDIR%%/gnome-art/ui
@dirrm %%RUBY_SITELIBDIR%%/gnome-art
@dirrm %%DATADIR%%/glade/pixmaps
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%
+@unexec rmdir %D/share/applications 2>/dev/null || true
diff --git a/x11-themes/gnome-splashscreen-manager/Makefile b/x11-themes/gnome-splashscreen-manager/Makefile
index 787b37b0c4f2..693e16b2f325 100644
--- a/x11-themes/gnome-splashscreen-manager/Makefile
+++ b/x11-themes/gnome-splashscreen-manager/Makefile
@@ -25,8 +25,13 @@ USE_RUBY= yes
USE_REINPLACE= yes
USE_RUBY_SETUP= yes
GSPLASH= ${X11BASE}/share/gnome/pixmaps/splash
+SPLASH_ICON= ${DATADIR}/glade/gnome-graphics.png
post-patch:
+ @${SED} -e 's|%%COMMENT%%|${COMMENT}|; \
+ s|%%SPLASH_ICON%%|${SPLASH_ICON}|' \
+ < ${FILESDIR}/gnome-splashscreen-manager.desktop.in \
+ > ${WRKDIR}/gnome-splashscreen-manager.desktop
cd ${WRKSRC}/lib/gnome-splashscreen-manager/ && \
for file in `${FIND} ${GSPLASH} -type f` ; do \
${SED} -e 's|%%SPLASHSCREENS%%|\\n<splash_screen>\\n\\t<name>%%F%%</name>\\n\\t<filename>%%F%%</filename>\\n\\t<description>...</description>\\n\\t<author>?</author>\\n\\t<license>unknown</license>\\n</splash_screen>\\n%%SPLASHSCREENS%%|' \
@@ -39,4 +44,8 @@ post-patch:
${WRKSRC}/lib/gnome-splashscreen-manager/ui/main_window.rb
@${FIND} ${WRKSRC} -name '*.bak' -delete
+post-install:
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKDIR}/gnome-splashscreen-manager.desktop ${PREFIX}/share/applications
+
.include <bsd.port.mk>
diff --git a/x11-themes/gnome-splashscreen-manager/files/gnome-splashscreen-manager.desktop.in b/x11-themes/gnome-splashscreen-manager/files/gnome-splashscreen-manager.desktop.in
new file mode 100644
index 000000000000..255db928ca21
--- /dev/null
+++ b/x11-themes/gnome-splashscreen-manager/files/gnome-splashscreen-manager.desktop.in
@@ -0,0 +1,11 @@
+# $FreeBSD
+[Desktop Entry]
+Encoding=UTF-8
+Name=Gnome Splash Screen Manager
+Comment=%%COMMENT%%
+Icon=%%SPLASH_ICON%%
+Exec=gnome-splashscreen-manager
+Terminal=false
+Type=Application
+Categories=GNOME;Application;Settings;AdvancedSettings;
+OnlyShowIn=GNOME;
diff --git a/x11-themes/gnome-splashscreen-manager/pkg-plist b/x11-themes/gnome-splashscreen-manager/pkg-plist
index d0f3f9c7c57f..812ea627450c 100644
--- a/x11-themes/gnome-splashscreen-manager/pkg-plist
+++ b/x11-themes/gnome-splashscreen-manager/pkg-plist
@@ -6,7 +6,9 @@ bin/gnome-splashscreen-manager
%%RUBY_SITELIBDIR%%/gnome-splashscreen-manager/config.rb
%%RUBY_SITELIBDIR%%/gnome-splashscreen-manager/splash_screens.rb
%%RUBY_SITELIBDIR%%/gnome-splashscreen-manager/ui/main_window.rb
+share/applications/gnome-splashscreen-manager.desktop
@dirrm %%RUBY_SITELIBDIR%%/gnome-splashscreen-manager/ui
@dirrm %%RUBY_SITELIBDIR%%/gnome-splashscreen-manager
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
+@unexec rmdir %D/share/applications 2>/dev/null || true