aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-01-14 13:26:55 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-01-14 13:26:55 +0000
commit6ae81701d89cd4be0858697583a3c8eb17abb795 (patch)
tree36861168870d7bb26f4190bf36793c427451cfda
parentd93d129cdf400faef88924babfa9afb29ac1c1b0 (diff)
downloadports-6ae81701d89cd4be0858697583a3c8eb17abb795.tar.gz
ports-6ae81701d89cd4be0858697583a3c8eb17abb795.zip
Notes
-rw-r--r--math/atlas-devel/Makefile7
-rw-r--r--math/atlas/Makefile7
2 files changed, 8 insertions, 6 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index 1f68f171ba4d..eb219bd3fcc7 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -25,6 +25,7 @@ NO_PACKAGE= Optimizes for the local machine, so a package is not generally usefu
CONFLICTS= elmer-mathlibs-1*
USE_BZIP2= yes
+USE_GMAKE= yes
WRKSRC= ${WRKDIR}/ATLAS
USE_LDCONFIG= yes
@@ -34,7 +35,7 @@ NOT_FOR_ARCHS= alpha
#to compile the ATLAS kernel we use gcc3. See ATLAS/INSTALL.txt for details.
WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
FC= gfortran42
F77= gfortran42
.if ${OSVERSION} > 700000
@@ -61,9 +62,9 @@ FFLAGS+= -pipe -O2 -ffast-math
.endif
.endif
.if defined(WITH_STATICLIB)
-PLIST_SUB+= WITH_STATICLIB=""
+PLIST_SUB+= WITH_STATICLIB=""
.else
-PLIST_SUB+= WITH_STATICLIB="@comment "
+PLIST_SUB+= WITH_STATICLIB="@comment "
.endif
post-extract:
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index ef0c4a0380cb..eb95c77c7742 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -25,6 +25,7 @@ NO_PACKAGE= Optimizes for the local machine, so a package is not generally usefu
CONFLICTS= elmer-mathlibs-1*
USE_BZIP2= yes
+USE_GMAKE= yes
WRKSRC= ${WRKDIR}/ATLAS
USE_LDCONFIG= yes
@@ -32,7 +33,7 @@ USE_LDCONFIG= yes
#to compile the ATLAS kernel we use gcc3. See ATLAS/INSTALL.txt for details.
WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
FC= gfortran42
F77= gfortran42
.if ${OSVERSION} > 700000
@@ -96,9 +97,9 @@ EXTRA_PATCHES+= ${FILESDIR}/timing_tolerance-patch
.endif
.if defined(WITH_STATICLIB)
-PLIST_SUB+= WITH_STATICLIB=""
+PLIST_SUB+= WITH_STATICLIB=""
.else
-PLIST_SUB+= WITH_STATICLIB="@comment "
+PLIST_SUB+= WITH_STATICLIB="@comment "
.endif
pre-configure: