aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-05-11 12:36:52 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-05-11 12:36:52 +0000
commit7466f3d747b68fba27a3ebfbd330da35f15fe09c (patch)
tree2fa328d9456f1fcfcdc887d2b864752a86d51f9e
parentb9e8e9b771669739b315082c52fca22eda504a7c (diff)
downloadports-7466f3d747b68fba27a3ebfbd330da35f15fe09c.tar.gz
ports-7466f3d747b68fba27a3ebfbd330da35f15fe09c.zip
Notes
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/attica/Makefile30
-rw-r--r--x11-toolkits/attica/distinfo3
-rw-r--r--x11-toolkits/attica/pkg-descr10
-rw-r--r--x11-toolkits/attica/pkg-plist27
5 files changed, 71 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 31b20c4c0763..f1afb85d70c6 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -7,6 +7,7 @@
SUBDIR += SoXt
SUBDIR += Xaw3d
SUBDIR += XawPlus
+ SUBDIR += attica
SUBDIR += bakery
SUBDIR += blt
SUBDIR += bwidget
diff --git a/x11-toolkits/attica/Makefile b/x11-toolkits/attica/Makefile
new file mode 100644
index 000000000000..126c516cc77c
--- /dev/null
+++ b/x11-toolkits/attica/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: attica
+# Date created: 2009-12-05
+# Whom: fluffy
+#
+# $FreeBSD$
+
+PORTNAME= attica
+PORTVERSION= 0.1.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/attica/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Collaboration Services API library
+
+USE_QT_VER= 4
+QT_COMPONENTS= dbus network moc_build uic_build rcc_build qmake_build
+USE_BZIP2= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ ${MKDIR} ${WRKSRC}
+ ${REINPLACE_CMD} -e \
+ 's,$${LIB_DESTINATION}/pkgconfig,libdata/pkgconfig,' \
+ ${WRKSRC}/lib/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/attica/distinfo b/x11-toolkits/attica/distinfo
new file mode 100644
index 000000000000..65272ca3a1ab
--- /dev/null
+++ b/x11-toolkits/attica/distinfo
@@ -0,0 +1,3 @@
+MD5 (attica-0.1.2.tar.bz2) = 8b4207dbc0a826d422632bdb9c50d51a
+SHA256 (attica-0.1.2.tar.bz2) = b0577c20615e2491841fe0206568fa587e5f9f36690423b5a5cd7d0c2f7c6726
+SIZE (attica-0.1.2.tar.bz2) = 30137
diff --git a/x11-toolkits/attica/pkg-descr b/x11-toolkits/attica/pkg-descr
new file mode 100644
index 000000000000..1e74a17ec9ba
--- /dev/null
+++ b/x11-toolkits/attica/pkg-descr
@@ -0,0 +1,10 @@
+Attica is a Qt library that implements the Open Collaboration Services API version 1.4.
+The REST API is defined here:
+
+http://www.freedesktop.org/wiki/Specifications/open-collaboration-services
+
+It grants easy access to the services such as querying information about persons and contents.
+The library is used in KNewStuff3 as content provider.
+In order to integrate with KDE's Plasma Desktop, a platform plugin exists in kdebase.
+
+WWW: http://strigi.sourceforge.net/
diff --git a/x11-toolkits/attica/pkg-plist b/x11-toolkits/attica/pkg-plist
new file mode 100644
index 000000000000..0833b5344e2a
--- /dev/null
+++ b/x11-toolkits/attica/pkg-plist
@@ -0,0 +1,27 @@
+include/attica/accountbalance.h
+include/attica/activity.h
+include/attica/atticabasejob.h
+include/attica/atticaclient_export.h
+include/attica/category.h
+include/attica/content.h
+include/attica/downloaddescription.h
+include/attica/downloaditem.h
+include/attica/event.h
+include/attica/folder.h
+include/attica/getjob.h
+include/attica/itemjob.h
+include/attica/knowledgebaseentry.h
+include/attica/listjob.h
+include/attica/message.h
+include/attica/metadata.h
+include/attica/person.h
+include/attica/platformdependent.h
+include/attica/postjob.h
+include/attica/provider.h
+include/attica/providermanager.h
+include/attica/version.h
+lib/libattica.so
+lib/libattica.so.0
+lib/libattica.so.0.1.2
+libdata/pkgconfig/libattica.pc
+@dirrmtry include/attica