aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-08 19:00:20 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-08 19:00:20 +0000
commit79e438a6a523176258c2e9ca8fad94d3d41683c1 (patch)
tree9a33f6b774317bd90bf4e0ab4f16ca4c530120ec
parentdd045ae32e650905ba7e5edfb5f64fe78ba01e38 (diff)
downloadports-79e438a6a523176258c2e9ca8fad94d3d41683c1.tar.gz
ports-79e438a6a523176258c2e9ca8fad94d3d41683c1.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/pam_ldap/Makefile44
-rw-r--r--security/pam_ldap/distinfo1
-rw-r--r--security/pam_ldap/files/patch-aa25
-rw-r--r--security/pam_ldap/files/patch-ab11
-rw-r--r--security/pam_ldap/files/patch-ac26
-rw-r--r--security/pam_ldap/pkg-comment1
-rw-r--r--security/pam_ldap/pkg-descr3
-rw-r--r--security/pam_ldap/pkg-plist2
9 files changed, 114 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 00f2a3b92026..f2eba6142eff 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -117,6 +117,7 @@
SUBDIR += pam-mysql
SUBDIR += pam-pgsql
SUBDIR += pam_krb5
+ SUBDIR += pam_ldap
SUBDIR += pam_ssh
SUBDIR += pgp
SUBDIR += pgp5
diff --git a/security/pam_ldap/Makefile b/security/pam_ldap/Makefile
new file mode 100644
index 000000000000..982765ea1726
--- /dev/null
+++ b/security/pam_ldap/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pam_ldap
+# Date created: 26 May 2001
+# Whom: Joe Clarke <marcus@marcuscom.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_ldap
+PORTVERSION= 1.1.3
+CATEGORIES= security net
+MASTER_SITES= http://www.padl.com/download/ \
+ ftp://ftp.padl.com/pub/
+DISTNAME= pam_ldap
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= marcus@marcuscom.com
+
+.if defined(WITH_LDAP_V3)
+LIB_DEPENDS= ldap.2:${PORTSDIR}/net/openldap2 \
+ lber.2:${PORTSDIR}/net/openldap2
+.else
+LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap \
+ lber.1:${PORTSDIR}/net/openldap
+.endif
+
+USE_AUTOCONF= yes
+CONFIGURE_ARGS= --with-ldap-lib=openldap \
+ --with-ldap-dir=${LOCALBASE}
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
+
+post-install:
+ @${ECHO} "================================================================================"
+ @${ECHO} "Copy/move/symlink ${PREFIX}/etc/pam_ldap/ldap.conf.dist to"
+ @${ECHO} "${PREFIX}/etc/pam_ldap/ldap.conf to be able to use it."
+ @${ECHO} "Add lines like the following to /etc/pam.conf"
+ @${ECHO} "to get things going:"
+ @${ECHO} ""
+ @${ECHO} "login auth sufficient ${PREFIX}/lib/pam_ldap.so"
+ @${ECHO} "================================================================================"
+
+.include <bsd.port.mk>
diff --git a/security/pam_ldap/distinfo b/security/pam_ldap/distinfo
new file mode 100644
index 000000000000..92e641ef41bb
--- /dev/null
+++ b/security/pam_ldap/distinfo
@@ -0,0 +1 @@
+MD5 (pam_ldap.tgz) = 9eaa7032079e4edb16e222873feab297
diff --git a/security/pam_ldap/files/patch-aa b/security/pam_ldap/files/patch-aa
new file mode 100644
index 000000000000..4f2c107bd3b3
--- /dev/null
+++ b/security/pam_ldap/files/patch-aa
@@ -0,0 +1,25 @@
+--- Makefile.in.orig Sat May 26 16:07:21 2001
++++ Makefile.in Sat May 26 17:09:57 2001
+@@ -380,17 +380,15 @@
+
+ install-exec-local: pam_ldap.so
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(libdir)/security
+-@EXTENSION_SO_TRUE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so
+-@EXTENSION_SO_FALSE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so.1
+-@EXTENSION_SO_FALSE@ -rm -f $(DESTDIR)$(libdir)/security/pam_ldap.so
+-@EXTENSION_SO_FALSE@ -ln -s $(DESTDIR)$(libdir)/security/pam_ldap.so.1 $(DESTDIR)$(libdir)/security/pam_ldap.so
++ $(mkinstalldirs) $(DESTDIR)$(libdir)
++@EXTENSION_SO_TRUE@ $(INSTALL_PROGRAM) -o root -g wheel pam_ldap.so $(DESTDIR)$(libdir)/pam_ldap.so
++@EXTENSION_SO_FALSE@ $(INSTALL_PROGRAM) -o root -g wheel pam_ldap.so $(DESTDIR)$(libdir)/pam_ldap.so
+
+ install-data-local:
+ @$(NORMAL_INSTALL)
+- @if test ! -f $(DESTDIR)$(sysconfdir)/ldap.conf; then \
++ @if test ! -f $(DESTDIR)$(sysconfdir)/ldap.conf.dist; then \
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir); \
+- $(INSTALL_DATA) -o root -g root $(srcdir)/ldap.conf $(DESTDIR)$(sysconfdir)/ldap.conf; \
++ $(INSTALL_DATA) -o root -g wheel $(srcdir)/ldap.conf $(DESTDIR)$(sysconfdir)/ldap.conf.dist; \
+ fi
+
+ uninstall-local:
diff --git a/security/pam_ldap/files/patch-ab b/security/pam_ldap/files/patch-ab
new file mode 100644
index 000000000000..efef94926927
--- /dev/null
+++ b/security/pam_ldap/files/patch-ab
@@ -0,0 +1,11 @@
+--- pam_ldap.c.orig Sat May 26 16:06:17 2001
++++ pam_ldap.c Sat May 26 16:07:05 2001
+@@ -551,7 +551,7 @@
+
+ /* configuration file location is configurable; default /etc/ldap.conf */
+ if (configFile == NULL)
+- configFile = "/etc/ldap.conf";
++ configFile = "/usr/local/etc/pam_ldap/ldap.conf";
+
+ fp = fopen (configFile, "r");
+
diff --git a/security/pam_ldap/files/patch-ac b/security/pam_ldap/files/patch-ac
new file mode 100644
index 000000000000..a6f005309b40
--- /dev/null
+++ b/security/pam_ldap/files/patch-ac
@@ -0,0 +1,26 @@
+--- Makefile.am.orig Sat May 26 17:13:48 2001
++++ Makefile.am Sat May 26 17:20:03 2001
+@@ -8,20 +8,13 @@
+
+ install-exec-local: pam_ldap.so
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(libdir)/security
+-if EXTENSION_SO
+- $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so
+-else
+- $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so.1
+- -rm -f $(DESTDIR)$(libdir)/security/pam_ldap.so
+- -ln -s $(DESTDIR)$(libdir)/security/pam_ldap.so.1 $(DESTDIR)$(libdir)/security/pam_ldap.so
+-endif
++ $(INSTALL_PROGRAM) -o root -g wheel pam_ldap.so $(DESTDIR)$(libdir)/pam_ldap.so
+
+ install-data-local:
+ @$(NORMAL_INSTALL)
+- @if test ! -f $(DESTDIR)$(sysconfdir)/ldap.conf; then \
++ @if test ! -f $(DESTDIR)$(sysconfdir)/ldap.conf.dist; then \
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir); \
+- $(INSTALL_DATA) -o root -g root $(srcdir)/ldap.conf $(DESTDIR)$(sysconfdir)/ldap.conf; \
++ $(INSTALL_DATA) -o root -g wheel $(srcdir)/ldap.conf $(DESTDIR)$(sysconfdir)/ldap.conf.dist; \
+ fi
+
+ uninstall-local:
diff --git a/security/pam_ldap/pkg-comment b/security/pam_ldap/pkg-comment
new file mode 100644
index 000000000000..654e033f672c
--- /dev/null
+++ b/security/pam_ldap/pkg-comment
@@ -0,0 +1 @@
+A pam module for authenticating with LDAP
diff --git a/security/pam_ldap/pkg-descr b/security/pam_ldap/pkg-descr
new file mode 100644
index 000000000000..a85fe2eb78c8
--- /dev/null
+++ b/security/pam_ldap/pkg-descr
@@ -0,0 +1,3 @@
+This is a PAM module for authenticating with LDAP.
+
+WWW: http://www.padl.com/pam_ldap.html
diff --git a/security/pam_ldap/pkg-plist b/security/pam_ldap/pkg-plist
new file mode 100644
index 000000000000..968f51a14485
--- /dev/null
+++ b/security/pam_ldap/pkg-plist
@@ -0,0 +1,2 @@
+lib/pam_ldap.so
+etc/ldap.conf.dist