aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Henrion <mux@FreeBSD.org>2006-05-23 20:16:31 +0000
committerMaxime Henrion <mux@FreeBSD.org>2006-05-23 20:16:31 +0000
commit8f66b836faaec6386ad75189cf767b4733664718 (patch)
tree7a1c49796122b288f15ec84ebf6971637e27ac22
parent4de73b8fee5e704784533a5433b48121415391e6 (diff)
downloadports-8f66b836faaec6386ad75189cf767b4733664718.tar.gz
ports-8f66b836faaec6386ad75189cf767b4733664718.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-fps/Makefile51
-rw-r--r--devel/hs-fps/distinfo3
-rw-r--r--devel/hs-fps/pkg-descr11
-rw-r--r--devel/hs-fps/pkg-plist13
5 files changed, 79 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b81aae817037..03598ac6a39e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -383,6 +383,7 @@
SUBDIR += hs-cpphs
SUBDIR += hs-crypto
SUBDIR += hs-drift
+ SUBDIR += hs-fps
SUBDIR += hs-green-card
SUBDIR += hs-haddock
SUBDIR += hs-happy
diff --git a/devel/hs-fps/Makefile b/devel/hs-fps/Makefile
new file mode 100644
index 000000000000..e810987efdb2
--- /dev/null
+++ b/devel/hs-fps/Makefile
@@ -0,0 +1,51 @@
+# ex:ts=8
+# New ports collection makefile for: hs-fps
+# Date created: 23 May 2006
+# Whom: Maxime Henrion <mux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fps
+PORTVERSION= 0.6
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.cse.unsw.edu.au/pub/users/dons/fps/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mux
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= mux@FreeBSD.org
+COMMENT= Fast, packed, strict byte arrays for Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+OPTIONS= PROFILE "Build libraries for profiling" off
+
+.include <bsd.port.pre.mk>
+
+SETUP= Setup.hs
+
+.if defined(WITH_PROFILE)
+PLIST_SUB+= PROFILE=""
+PROFILE= -p
+.else
+PLIST_SUB+= PROFILE="@comment "
+.endif
+
+PLIST_SUB+= FPS_VERSION=${PORTVERSION}
+
+do-configure:
+ @${CHMOD} +x ${WRKSRC}/${SETUP}
+ @cd ${WRKSRC}; ./${SETUP} configure ${PROFILE} --prefix=${LOCALBASE}
+
+do-build:
+ @cd ${WRKSRC}; ./${SETUP} build
+
+do-install:
+ @cd ${WRKSRC}; ./${SETUP} install
+
+post-install:
+ @ver=`ghc -V | ${SED} "s/^.*version \(.*\)$$/\1/"`; \
+ ${REINPLACE_CMD} -e "s|%%GHC_VERSION%%|$${ver}|g" ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/hs-fps/distinfo b/devel/hs-fps/distinfo
new file mode 100644
index 000000000000..e21381b6fe68
--- /dev/null
+++ b/devel/hs-fps/distinfo
@@ -0,0 +1,3 @@
+MD5 (fps-0.6.tar.gz) = 36cde5d348809d14ba0b1d16503b2edb
+SHA256 (fps-0.6.tar.gz) = c0d7eda495bc7a44b046b4f090bdf0c0d1a401f27ceec9530372f26e129524b8
+SIZE (fps-0.6.tar.gz) = 358894
diff --git a/devel/hs-fps/pkg-descr b/devel/hs-fps/pkg-descr
new file mode 100644
index 000000000000..ab64619bf318
--- /dev/null
+++ b/devel/hs-fps/pkg-descr
@@ -0,0 +1,11 @@
+Data.ByteString (formerly FPS) provides packed strings (byte arrays held by a
+ForeignPtr), along with a list interface to these strings. It lets you do
+extremely fast IO in Haskell; in some cases, even faster than typical C
+implementations, and much faster than [Char]. It uses a flexible "foreign
+pointer" representation, allowing the transparent use of Haskell or C code to
+manipulate the strings.
+
+Data.ByteString is written in Haskell98 + the foreign function interface and
+cpp. It has been tested succesfully with GHC 6.4 and 6.5, and hugs March 2005.
+
+WWW: http://www.cse.unsw.edu.au/~dons/fps.html
diff --git a/devel/hs-fps/pkg-plist b/devel/hs-fps/pkg-plist
new file mode 100644
index 000000000000..699d6702739d
--- /dev/null
+++ b/devel/hs-fps/pkg-plist
@@ -0,0 +1,13 @@
+lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString/Char8.hi
+%%PROFILE%%lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString/Char8.p_hi
+@dirrm lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString
+lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString.hi
+%%PROFILE%%lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString.p_hi
+@dirrm lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/Data
+lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/libHSfps-0.6.a
+lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/HSfps-0.6.o
+lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%/libHSfps-0.6_p.a
+@dirrm lib/fps-%%FPS_VERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/fps-%%FPS_VERSION%%
+@unexec %D/bin/ghc-pkg -r fps
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old