aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 22:39:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 22:39:17 +0000
commit9afb91ced919bf67e510fcd2fb28b3bb9ca7155f (patch)
treed5d59e9ccfb17b59f7c9841e2c591fdd6165b1d3
parentca24d52577c0104c8b1bb2f88355d2524a8d4161 (diff)
downloadports-9afb91ced919bf67e510fcd2fb28b3bb9ca7155f.tar.gz
ports-9afb91ced919bf67e510fcd2fb28b3bb9ca7155f.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/separate/Makefile54
-rw-r--r--graphics/separate/distinfo3
-rw-r--r--graphics/separate/files/patch-Makefile45
-rw-r--r--graphics/separate/pkg-descr9
-rw-r--r--graphics/separate/pkg-message2
6 files changed, 114 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7126f7cd311d..8ad8125b7a79 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -678,6 +678,7 @@
SUBDIR += sdl_image
SUBDIR += sdl_ttf
SUBDIR += seejpeg
+ SUBDIR += separate
SUBDIR += sharpconstruct
SUBDIR += shim
SUBDIR += show
diff --git a/graphics/separate/Makefile b/graphics/separate/Makefile
new file mode 100644
index 000000000000..3a62344ef62d
--- /dev/null
+++ b/graphics/separate/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: separate
+# Date created: 30 January 2008
+# Whom: Pietro Cerutti <gahr@gahr.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= separate
+PORTVERSION= 20070727
+CATEGORIES= graphics
+MASTER_SITES= http://www.gahr.ch/FreeBSD/distfiles/
+
+MAINTAINER= gahr@gahr.ch
+COMMENT= A CMYK plugin for The GIMP
+
+BUILD_DEPENDS= gccmakedep:${PORTSDIR}/devel/gccmakedep \
+ gimp-2.4:${PORTSDIR}/graphics/gimp
+LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms
+
+WRKSRC= ${WRKDIR}/${PORTNAME}+
+
+USE_ZIP= yes
+
+GIMP_PLUGINS_DIR= libexec/gimp/2.2/plug-ins/
+TARGETS= separate separate_import icc_colorspace
+
+.for PLUGIN in ${TARGETS}
+PLIST_FILES+= ${GIMP_PLUGINS_DIR}/${PLUGIN}
+.endfor
+
+PORTDOCS= README*
+PORTEXAMPLES= quickproof.scm quicksave.scm
+
+MAKE_ENV+= TARGETS="${TARGETS}"
+
+do-install:
+.for PLUGIN in ${TARGETS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PLUGIN} ${PREFIX}/${GIMP_PLUGINS_DIR}/
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README_ICC_COLORSPACE ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample-scripts/for_GIMP2.3+/quickproof.scm ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample-scripts/for_GIMP2.3+/quicksave.scm ${EXAMPLESDIR}
+.endif
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/graphics/separate/distinfo b/graphics/separate/distinfo
new file mode 100644
index 000000000000..b61569fa2416
--- /dev/null
+++ b/graphics/separate/distinfo
@@ -0,0 +1,3 @@
+MD5 (separate-20070727.zip) = 35edd674a08f66e40df5eaa0dd4dc3a4
+SHA256 (separate-20070727.zip) = a308f35986743481e185f83fb298fc69e86eab166b135f72e5f74b54d969988a
+SIZE (separate-20070727.zip) = 325392
diff --git a/graphics/separate/files/patch-Makefile b/graphics/separate/files/patch-Makefile
new file mode 100644
index 000000000000..973f52e7c13a
--- /dev/null
+++ b/graphics/separate/files/patch-Makefile
@@ -0,0 +1,45 @@
+--- Makefile.orig 2008-01-30 18:58:11.000000000 +0100
++++ Makefile 2008-01-30 19:02:42.000000000 +0100
+@@ -1,7 +1,4 @@
+
+-PREFIX=/usr/devel
+-
+-GIMP_VER = 2.3
+ GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+ GTK_LIB = `pkg-config gtk+-2.0 --libs`
+ GIMP_INCLUDE = `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags`
+@@ -10,10 +7,7 @@
+ LCMS_LIB = `pkg-config lcms --libs`
+ TIFF_LIB = -ltiff
+
+-VERSION = 0.3
+-CC = gcc -g
+ DEPEND = gccmakedep
+-RM = rm -f
+
+ # If you will use with the GIMP 2.2.x, remove "-DENABLE_COLOR_MANAGEMENT".
+ # If you don't want to merge "normal" and "to Colour" dialog,
+@@ -41,8 +35,6 @@
+
+ ICC_COLORSPACE_OBJECTS = $(ICC_COLORSPACE_SOURCES:.c=.o) $(EXTRA_SOURCES:.c=.o)
+
+-TARGETS = separate separate_import icc_colorspace
+-
+ all: $(TARGETS)
+
+ depend:
+@@ -60,14 +52,6 @@
+ icc_colorspace: $(ICC_COLORSPACE_OBJECTS)
+ $(CC) $(ICC_COLORSPACE_OBJECTS) -o $@ $(LDFLAGS)
+
+-install: $(TARGETS)
+- install -c $^ $(HOME)/.gimp-$(GIMP_VER)/plug-ins/
+-
+-uninstall:
+- rm -f $(HOME)/.gimp-$(GIMP_VER)/plug-ins/separate
+- rm -f $(HOME)/.gimp-$(GIMP_VER)/plug-ins/separate_import
+- rm -f $(HOME)/.gimp-$(GIMP_VER)/plug-ins/icc_colorspace
+-
+ # Inference rules
+
+ .c.o:
diff --git a/graphics/separate/pkg-descr b/graphics/separate/pkg-descr
new file mode 100644
index 000000000000..a343b6a626b7
--- /dev/null
+++ b/graphics/separate/pkg-descr
@@ -0,0 +1,9 @@
+Separate+ is a CMYK Separation plugin for The GIMP.
+
+One thing preventing The GIMP from being useful
+in a pre-press environment is the lack of support
+for the CMYK colour-space. This plug-in goes some
+small way towards rectifying the situation, using
+a trick with layers to fake CMYK support.
+
+WWW: http://cue.yellowmagic.info/softwares/separate.html
diff --git a/graphics/separate/pkg-message b/graphics/separate/pkg-message
new file mode 100644
index 000000000000..c47105553b5d
--- /dev/null
+++ b/graphics/separate/pkg-message
@@ -0,0 +1,2 @@
+You can download and install Adobe's ICC profiles from:
+http://www.adobe.com/support/downloads/product.jsp?product=62&platform=Windows