aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2007-04-23 21:28:04 +0000
committerDiane Bruce <db@FreeBSD.org>2007-04-23 21:28:04 +0000
commit9ce19b5e36dda22770e05fe0c9f75a0a82d6035a (patch)
tree2d95a0c119c2d95129307fe1e3ca0b5f03cbd277
parent7d645b9416df66683acdde69e778f2819869221f (diff)
Notes
-rw-r--r--comms/linrad/Makefile17
-rw-r--r--comms/linrad/distinfo6
-rw-r--r--comms/linrad/files/patch-Makefile.in35
-rw-r--r--comms/linrad/files/patch-lxsys.c22
4 files changed, 44 insertions, 36 deletions
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index ce86e5af777a..b8dd94ddad01 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= linrad
-PORTVERSION= 2.23
+PORTVERSION= 2.28
CATEGORIES= comms
MASTER_SITES= http://www.nitehawk.com/sm5bsz/linuxdsp/archive/\
http://g7rau.demon.co.uk/sm5bsz/linuxdsp/archive/\
http://www.sm5bsz.com/linuxdsp/archive/
-DISTNAME= lir02-23
+DISTNAME= lir02-28
EXTRACT_SUFX= .tbz
DIST_SUBDIR= ${PORTNAME}
@@ -20,10 +20,11 @@ COMMENT= Amateur Radio DSP utility (SDR)
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-WRKSRC= ${WRKDIR}/${PORTNAME}-02.23
+WRKSRC= ${WRKDIR}/${PORTNAME}-0${PORTVERSION}
-USE_AUTOTOOLS= autoconf:253
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX} --mandir=${PREFIX}/man
USE_GMAKE= yes
USE_BZIP2= yes
ALL_TARGET= xlinrad
@@ -36,12 +37,6 @@ LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
z_PARALLEL_PORT.txt z_SETTINGS.txt \
z_USERS_EXTRA.txt z_USERS_HWARE.txt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on FreeBSD 4.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile.in
@@ -70,4 +65,4 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/linrad/distinfo b/comms/linrad/distinfo
index 26efa48d607a..c6e0c4349303 100644
--- a/comms/linrad/distinfo
+++ b/comms/linrad/distinfo
@@ -1,3 +1,3 @@
-MD5 (linrad/lir02-23.tbz) = 234c10cf3dc313edb6601b75375fc6d8
-SHA256 (linrad/lir02-23.tbz) = c1cd8609d419faa3e7678c4821b27e177f4c449653c6bca94a8b9b835ee12078
-SIZE (linrad/lir02-23.tbz) = 455056
+MD5 (linrad/lir02-28.tbz) = 671c3e9072f70a1b6ca942de55259bde
+SHA256 (linrad/lir02-28.tbz) = 904928349136586c4dad22e5242be104e57b1e8c98b21aac0faf3e9ab1823498
+SIZE (linrad/lir02-28.tbz) = 471279
diff --git a/comms/linrad/files/patch-Makefile.in b/comms/linrad/files/patch-Makefile.in
index d9f82126a4e0..2966bcf7c6e2 100644
--- a/comms/linrad/files/patch-Makefile.in
+++ b/comms/linrad/files/patch-Makefile.in
@@ -1,40 +1,45 @@
---- Makefile.in.orig Wed Feb 14 04:37:46 2007
-+++ Makefile.in Thu Feb 22 19:52:33 2007
-@@ -4,17 +4,14 @@
+--- Makefile.in.orig Tue Apr 10 14:08:58 2007
++++ Makefile.in Sat Apr 21 23:23:50 2007
+@@ -4,7 +4,7 @@
# Name the output files *.ol instead of *.o
# so we definitely know it is for Linux.
# (*.o files can be present by mistake)
-LCC = gcc
-+LCC = $(CC)
- # Use the mingw cross compiler for Windows
- # Name the output files *.ow instead of *.o
++LCC = ${CC}
+ WCC = /usr/bin/i586-mingw32msvc-gcc
+ WINWCC = C:\mingw\bin\mingw32-gcc
+ NASM = nasm
+@@ -14,13 +14,10 @@
# so we definitely know it is for Windows.
# (*.o files can be present by mistake)
- WCC = /usr/bin/i586-mingw32msvc-gcc
# Always use the same flags.
-CFL = -g -O -DOSNUM=1 -W -Wimplicit -Wreturn-type -Wformat \
---m32 -Wunused -Wcomment -Wchar-subscripts -Wshadow -Wuninitialized \
+-@MEM@ -Wunused -Wcomment -Wchar-subscripts -Wshadow -Wuninitialized \
--Wparentheses -Wstrict-prototypes -Werror -ffast-math \
--fomit-frame-pointer -c -o
-+CFL = ${CFLAGS} -I/usr/X11R6/include -DOSNUM=1 -c -o
++CFL = ${CFLAGS} -DOSNUM=1 -I${X11BASE}/include -c -o
CFW = -g -O -DOSNUM=2 -W -Wimplicit -Wreturn-type -Wformat \
-Wunused -Wcomment -Wchar-subscripts -Wshadow -Wuninitialized \
- -Wparentheses -Wstrict-prototypes -Werror -ffast-math \
-@@ -387,7 +384,7 @@
- meter_graph.ol fonts.ol screensub.ol membeg.ol lxsys.ol memend.ol
+--Wparentheses -Wstrict-prototypes -Werror -ffast-math \
++-Wparentheses -Wstrict-prototypes -ffast-math \
+ -fomit-frame-pointer -c -o
+ # Define dependencies for routines used both in Linux and Windows
+
+@@ -624,7 +621,7 @@
+ meter_graph.ol fonts.ol screensub.ol lxsys.ol
- gcc -olinrad -lvgagl -lvga -lpthread -lm \
+ $(CC) -olinrad -lvgagl -lvga -pthread -lm \
-Wl,-Map,linrad.lmap,-warn-common \
- membeg.ol lmain.ol lvar.ol ui.ol lsetad.ol fft1.ol buf.ol \
+ lmain.ol lvar.ol ui.ol lsetad.ol fft1.ol buf.ol \
mouse.ol wide_graph.ol getiq.ol fft0.ol adtest.ol hires_graph.ol \
-@@ -434,7 +431,7 @@
+@@ -671,7 +668,7 @@
- gcc -oxlinrad -L/usr/X11R6/lib -lX11 -lpthread -lm \
+ $(CC) -oxlinrad -L/usr/X11R6/lib -lX11 -pthread -lm \
-Wl,-Map,linrad.xmap,-warn-common \
- membeg.ol xmain.ol xvar.ol ui.ol lsetad.ol fft1.ol buf.ol lvar.ol \
+ xmain.ol xvar.ol ui.ol lsetad.ol fft1.ol buf.ol lvar.ol \
mouse.ol wide_graph.ol getiq.ol fft0.ol adtest.ol hires_graph.ol \
diff --git a/comms/linrad/files/patch-lxsys.c b/comms/linrad/files/patch-lxsys.c
index b66cfe99c508..6d148bbbfd78 100644
--- a/comms/linrad/files/patch-lxsys.c
+++ b/comms/linrad/files/patch-lxsys.c
@@ -1,5 +1,5 @@
---- lxsys.c.orig Wed Feb 14 04:37:46 2007
-+++ lxsys.c Thu Feb 22 18:44:17 2007
+--- lxsys.c.orig Tue Apr 10 14:08:58 2007
++++ lxsys.c Sat Apr 21 23:31:47 2007
@@ -1,12 +1,14 @@
-
-#include <sys/io.h>
@@ -18,15 +18,23 @@
#include <fcntl.h>
#include <termios.h>
#include "thrdef.h"
-@@ -17,6 +19,7 @@
- #include "ldef.h"
+@@ -18,8 +20,9 @@
#include "hwaredef.h"
+ struct termios old_options;
+-char serport_name[]="/dev/ttyS?";
++char serport_name[]="/dev/ttyd?";
+
+extern int saved_euid;
+
void lirerr(int errcod)
+@@ -152,15 +155,13 @@
+
+ int lir_parport_permission(void)
{
-@@ -60,11 +63,9 @@
+-int i;
++int i=0;
// Get permission to write to the parallel port
if(ui.parport < 0x400-4)
{
@@ -41,7 +49,7 @@
}
if(i != 0)
{
-@@ -209,11 +210,9 @@
+@@ -305,11 +306,9 @@
int i;
if(ui.parport < 0x400-4)
{
@@ -56,7 +64,7 @@
}
if(i!=0)lirerr(764921);
i=1000;
-@@ -226,11 +225,9 @@
+@@ -322,11 +321,9 @@
int i;
if(ui.parport < 0x400-4)
{