aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-06-04 08:23:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-06-04 08:23:11 +0000
commita0efd6ec9ba7bf8abe629c2259547765ffb3030c (patch)
tree17490f8cdd4fb8db679198da5a896854ea2738a7
parent189f7f398482f23b4e9eedf199328cdab2eaf0ca (diff)
downloadports-a0efd6ec9ba7bf8abe629c2259547765ffb3030c.tar.gz
ports-a0efd6ec9ba7bf8abe629c2259547765ffb3030c.zip
Notes
-rw-r--r--editors/vigor/Makefile22
-rw-r--r--editors/vigor/files/patch-ab33
-rw-r--r--editors/vigor/files/patch-cl__cl_read.c11
-rw-r--r--editors/vigor/files/patch-ex__ex_script.c11
-rw-r--r--editors/vigor/files/patch-ex__ex_tcl.c11
-rw-r--r--editors/vigor/files/patch-tcl_api__tcl.c29
-rw-r--r--editors/vigor/files/patch-vigor__vigor.c38
7 files changed, 111 insertions, 44 deletions
diff --git a/editors/vigor/Makefile b/editors/vigor/Makefile
index 2c30466ca39f..d27bb21af4f8 100644
--- a/editors/vigor/Makefile
+++ b/editors/vigor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vigor
-# Date created: 17 Jan 2000
-# Whom: Bill Fumerola <billf@chc-chimes.com>
-#
+# Created by: Bill Fumerola <billf@chc-chimes.com>
# $FreeBSD$
-#
PORTNAME= vigor
PORTVERSION= 0.016
@@ -12,7 +8,12 @@ CATEGORIES= editors tcl tk
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A vi clone inspired by the userfriendly comic strip
+COMMENT= Vi clone inspired by the userfriendly comic strip
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/build
USE_TCL= yes
USE_TCL_BUILD= yes
@@ -20,14 +21,13 @@ USE_TK= yes
USE_TK_BUILD= yes
USE_XORG= x11
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--program-transform-name="s,0,1,"
-LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/build
-CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} -I${LOCALBASE}/include/tk${TK_VER}
+CPPFLAGS+= -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
- ${REINPLACE_CMD} -e 's|tcl80|tcl${TCL_VER:S/.//} -L${LOCALBASE}/lib|; \
+ ${REINPLACE_CMD} -e 's|tcl80|tcl${TCL_VER:S/.//}|; \
s|tk80|tk${TK_VER:S/.//}|; \
s|^grantpt|XXXgrantpt|;' \
${WRKSRC}/configure
diff --git a/editors/vigor/files/patch-ab b/editors/vigor/files/patch-ab
index 11cb86bdcce8..e69de29bb2d1 100644
--- a/editors/vigor/files/patch-ab
+++ b/editors/vigor/files/patch-ab
@@ -1,33 +0,0 @@
---- ../vigor/vigor.c.orig Fri Sep 15 18:41:47 2000
-+++ ../vigor/vigor.c Fri Sep 15 18:41:54 2000
-@@ -13,7 +13,7 @@
- #include <sys/types.h>
- #include <sys/queue.h>
- #include <sys/time.h>
--#ifdef HAVE_SYS_SELECT_H
-+#if 0
- #include <sys/select.h>
- #endif
-
---- ../cl/cl_read.c.orig Fri Sep 15 18:37:07 2000
-+++ ../cl/cl_read.c Fri Sep 15 18:40:21 2000
-@@ -15,7 +15,7 @@
-
- #include <sys/types.h>
- #include <sys/queue.h>
--#ifdef HAVE_SYS_SELECT_H
-+#if 0
- #include <sys/select.h>
- #endif
- #include <sys/time.h>
---- ../ex/ex_script.c.orig Fri Sep 15 18:40:53 2000
-+++ ../ex/ex_script.c Fri Sep 15 18:41:02 2000
-@@ -19,7 +19,7 @@
- #include <sys/types.h>
- #include <sys/ioctl.h>
- #include <sys/queue.h>
--#ifdef HAVE_SYS_SELECT_H
-+#if 0
- #include <sys/select.h>
- #endif
- #include <sys/stat.h>
diff --git a/editors/vigor/files/patch-cl__cl_read.c b/editors/vigor/files/patch-cl__cl_read.c
new file mode 100644
index 000000000000..6a7006c754f4
--- /dev/null
+++ b/editors/vigor/files/patch-cl__cl_read.c
@@ -0,0 +1,11 @@
+--- ../cl/cl_read.c.orig Fri Sep 15 18:37:07 2000
++++ ../cl/cl_read.c Fri Sep 15 18:40:21 2000
+@@ -15,7 +15,7 @@
+
+ #include <sys/types.h>
+ #include <sys/queue.h>
+-#ifdef HAVE_SYS_SELECT_H
++#if 0
+ #include <sys/select.h>
+ #endif
+ #include <sys/time.h>
diff --git a/editors/vigor/files/patch-ex__ex_script.c b/editors/vigor/files/patch-ex__ex_script.c
new file mode 100644
index 000000000000..6c425835e9d8
--- /dev/null
+++ b/editors/vigor/files/patch-ex__ex_script.c
@@ -0,0 +1,11 @@
+--- ../ex/ex_script.c.orig
++++ ../ex/ex_script.c
+@@ -19,7 +19,7 @@
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+ #include <sys/queue.h>
+-#ifdef HAVE_SYS_SELECT_H
++#if 0
+ #include <sys/select.h>
+ #endif
+ #include <sys/stat.h>
diff --git a/editors/vigor/files/patch-ex__ex_tcl.c b/editors/vigor/files/patch-ex__ex_tcl.c
new file mode 100644
index 000000000000..e22a792000e0
--- /dev/null
+++ b/editors/vigor/files/patch-ex__ex_tcl.c
@@ -0,0 +1,11 @@
+--- ../ex/ex_tcl.c.orig
++++ ../ex/ex_tcl.c
+@@ -71,7 +71,7 @@
+ Tcl_Eval(gp->tcl_interp, cmdp->argv[0]->bp) == TCL_OK)
+ return (0);
+
+- msgq(sp, M_ERR, "Tcl: %s", ((Tcl_Interp *)gp->tcl_interp)->result);
++ msgq(sp, M_ERR, "Tcl: %s", Tcl_GetStringResult(gp->tcl_interp));
+ return (1);
+ #else
+ msgq(sp, M_ERR, "302|Vi was not loaded with a Tcl interpreter");
diff --git a/editors/vigor/files/patch-tcl_api__tcl.c b/editors/vigor/files/patch-tcl_api__tcl.c
new file mode 100644
index 000000000000..06554f430cf8
--- /dev/null
+++ b/editors/vigor/files/patch-tcl_api__tcl.c
@@ -0,0 +1,29 @@
+--- ../tcl_api/tcl.c.orig
++++ ../tcl_api/tcl.c
+@@ -73,7 +73,7 @@
+ if (getscreenid(interp, &sp, NULL, argv[1]))
+ return (TCL_ERROR);
+
+- (void)sprintf(interp->result, "%d", sp->id);
++ (void)sprintf(Tcl_GetStringResult(interp), "%d", sp->id);
+ return (TCL_OK);
+ }
+
+@@ -254,7 +254,7 @@
+ if (rval)
+ return (TCL_ERROR);
+
+- (void)sprintf(interp->result, "%lu", (unsigned long)last);
++ (void)sprintf(Tcl_GetStringResult(interp), "%lu", (unsigned long)last);
+ return (TCL_OK);
+ }
+
+@@ -520,7 +520,7 @@
+ if (rval)
+ return (TCL_ERROR);
+
+- (void)sprintf(interp->result, "%d", nsp->id);
++ (void)sprintf(Tcl_GetStringResult(interp), "%d", nsp->id);
+ return (TCL_OK);
+ }
+
diff --git a/editors/vigor/files/patch-vigor__vigor.c b/editors/vigor/files/patch-vigor__vigor.c
new file mode 100644
index 000000000000..64489506b0a4
--- /dev/null
+++ b/editors/vigor/files/patch-vigor__vigor.c
@@ -0,0 +1,38 @@
+--- ../vigor/vigor.c.orig
++++ ../vigor/vigor.c
+@@ -13,7 +13,7 @@
+ #include <sys/types.h>
+ #include <sys/queue.h>
+ #include <sys/time.h>
+-#ifdef HAVE_SYS_SELECT_H
++#if 0
+ #include <sys/select.h>
+ #endif
+
+@@ -78,7 +78,7 @@
+ * to want tk's main window cluttering up the place. I should
+ * use a wm_withdraw instead. */
+ if (Tk_Init(vigor_interp) == TCL_ERROR) {
+- fprintf(stderr, "%s\n", vigor_interp->result);
++ fprintf(stderr, "%s\n", Tcl_GetStringResult(vigor_interp));
+ return (1);
+ }
+
+@@ -87,7 +87,7 @@
+ return (1);
+ #endif
+ if (Tcl_Eval(vigor_interp, vigor_tcl) == TCL_ERROR) {
+- fprintf(stderr, "%s\n", vigor_interp->result);
++ fprintf(stderr, "%s\n", Tcl_GetStringResult(vigor_interp));
+ return (1);
+ }
+
+@@ -127,7 +127,7 @@
+ init_vigor_phrases();
+
+ if (Tcl_Eval(vigor_interp, "vigor_init") == TCL_ERROR) {
+- fprintf(stderr, "%s\n", vigor_interp->result);
++ fprintf(stderr, "%s\n", Tcl_GetStringResult(vigor_interp));
+ return (1);
+ }
+