aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 10:04:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 10:04:56 +0000
commitb3a96ed6ee9c272be4c0763868b0cc1778d550ec (patch)
treea2ab1131a1a192007181705e999f9f8b61e5e7c0
parente04596d72eed49b08af4f018be6a29a86e7dca5f (diff)
downloadports-b3a96ed6ee9c272be4c0763868b0cc1778d550ec.tar.gz
ports-b3a96ed6ee9c272be4c0763868b0cc1778d550ec.zip
Notes
-rw-r--r--archivers/ark/Makefile4
-rw-r--r--archivers/dact/Makefile4
-rw-r--r--archivers/epkg/Makefile4
-rw-r--r--archivers/libarchive/Makefile2
-rw-r--r--archivers/liborange/Makefile8
-rw-r--r--archivers/lrzip/Makefile2
-rw-r--r--archivers/p5-Compress-LZO/Makefile2
-rw-r--r--archivers/p5-Compress-Raw-Lzma/Makefile2
-rw-r--r--archivers/pixz/Makefile2
-rw-r--r--archivers/rpm/Makefile2
-rw-r--r--archivers/rpm5/Makefile16
-rw-r--r--archivers/tardy/Makefile2
-rw-r--r--archivers/upx/Makefile2
13 files changed, 26 insertions, 26 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index 605269729da3..0d8af8aa1978 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Archiving tool for KDE
-LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson
+LIB_DEPENDS= libqjson.so:${PORTSDIR}/devel/qjson
CONFLICTS_INSTALL= kdeutils-4.[0-7].*
@@ -44,7 +44,7 @@ RUN_DEPENDS+= unzip>0:${PORTSDIR}/archivers/unzip \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
-LIB_DEPENDS+= archive:${PORTSDIR}/archivers/libarchive
+LIB_DEPENDS+= libarchive.so:${PORTSDIR}/archivers/libarchive
.endif
.if ${PORT_OPTIONS:MRAR}
diff --git a/archivers/dact/Makefile b/archivers/dact/Makefile
index 383519a55dce..1395a145bbc2 100644
--- a/archivers/dact/Makefile
+++ b/archivers/dact/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= http://www.rkeene.org/files/oss/dact/release/
MAINTAINER= miwi@FreeBSD.org
COMMENT= Dynamic Adaptive Compression Tool
-LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt \
- lzo2.2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS= libmcrypt.so:${PORTSDIR}/security/libmcrypt \
+ liblzo2.so:${PORTSDIR}/archivers/lzo2
NO_STAGE= yes
USES= gmake
diff --git a/archivers/epkg/Makefile b/archivers/epkg/Makefile
index 260539463738..4a3e586ba2da 100644
--- a/archivers/epkg/Makefile
+++ b/archivers/epkg/Makefile
@@ -11,8 +11,8 @@ MAINTAINER= pirzyk@FreeBSD.org
COMMENT= Encap Package Manager
BUILD_DEPENDS= ${LOCALBASE}/lib/libfget.a:${PORTSDIR}/ftp/fget
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libexpat.so:${PORTSDIR}/textproc/expat2
NO_STAGE= yes
HAS_CONFIGURE= YES
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index e24273cdcfd2..1c6d960ca703 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -92,7 +92,7 @@ CONFIGURE_ARGS+= --without-xml2
.endif
.if ${PORT_OPTIONS:MLZO}
-LIB_DEPENDS= lzo2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2
CONFIGURE_ARGS+= --with-lzo2
.else
CONFIGURE_ARGS+= --without-lzo2
diff --git a/archivers/liborange/Makefile b/archivers/liborange/Makefile
index 68f4f16387ff..20c3aa9aa748 100644
--- a/archivers/liborange/Makefile
+++ b/archivers/liborange/Makefile
@@ -34,7 +34,7 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS+= --without-libsynce
REQUIRES+= libsynce
.else
-LIB_DEPENDS+= synce:${PORTSDIR}/palm/synce-libsynce
+LIB_DEPENDS+= libsynce.so:${PORTSDIR}/palm/synce-libsynce
CONFIGURE_ARGS+= --with-libsynce
.endif
@@ -42,7 +42,7 @@ CONFIGURE_ARGS+= --with-libsynce
CONFIGURE_ARGS+= --without-libdynamite
REQUIRES+= libdynamite
.else
-LIB_DEPENDS+= dynamite:${PORTSDIR}/archivers/libdynamite
+LIB_DEPENDS+= libdynamite.so:${PORTSDIR}/archivers/libdynamite
CONFIGURE_ARGS+= --with-libdynamite
.endif
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --with-libdynamite
CONFIGURE_ARGS+= --without-libunshield
REQUIRES+= libunshield
.else
-LIB_DEPENDS+= unshield:${PORTSDIR}/archivers/unshield
+LIB_DEPENDS+= libunshield.so:${PORTSDIR}/archivers/unshield
CONFIGURE_ARGS+= --with-libunshield
.endif
@@ -64,7 +64,7 @@ CONFIGURE_ARGS+= --enable-vise
.if ${PORT_OPTIONS:MMSI}
CONFIGURE_ARGS+= --enable-msi --with-libgsf
-LIB_DEPENDS+= gsf-1.114:${PORTSDIR}/devel/libgsf
+LIB_DEPENDS+= libgsf-1.so.114:${PORTSDIR}/devel/libgsf
.endif
post-patch:
diff --git a/archivers/lrzip/Makefile b/archivers/lrzip/Makefile
index 511c0e175b02..e6fdedc3476a 100644
--- a/archivers/lrzip/Makefile
+++ b/archivers/lrzip/Makefile
@@ -13,7 +13,7 @@ COMMENT= Long Range ZIP or Lzma RZIP
LICENSE= GPLv2
BUILD_DEPENDS= nasm>=0:${PORTSDIR}/devel/nasm
-LIB_DEPENDS= lzo2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2
NO_STAGE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/archivers/p5-Compress-LZO/Makefile b/archivers/p5-Compress-LZO/Makefile
index 1c94d0422bb9..967c39401276 100644
--- a/archivers/p5-Compress-LZO/Makefile
+++ b/archivers/p5-Compress-LZO/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface to the LZO compression library
-LIB_DEPENDS= lzo2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2
CFLAGS+= -I${LOCALBASE}/include/lzo
USES= perl5
diff --git a/archivers/p5-Compress-Raw-Lzma/Makefile b/archivers/p5-Compress-Raw-Lzma/Makefile
index cc01931a87c6..bd5a54488d69 100644
--- a/archivers/p5-Compress-Raw-Lzma/Makefile
+++ b/archivers/p5-Compress-Raw-Lzma/Makefile
@@ -32,7 +32,7 @@ LZMA_DEPEND?= xz
.endif
.if (${LZMA_DEPEND} == "xz") || (${LZMA_DEPEND} == "lzmalib")
-LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/${LZMA_DEPEND}
+LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/${LZMA_DEPEND}
.endif
pre-build:
diff --git a/archivers/pixz/Makefile b/archivers/pixz/Makefile
index 57324e1939ed..5a713698e0c5 100644
--- a/archivers/pixz/Makefile
+++ b/archivers/pixz/Makefile
@@ -19,7 +19,7 @@ MAKE_ENV+= PTHREAD_LIBS=${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
-LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
+LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/xz
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.endif
diff --git a/archivers/rpm/Makefile b/archivers/rpm/Makefile
index bedd064ba55e..082e719cd043 100644
--- a/archivers/rpm/Makefile
+++ b/archivers/rpm/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://rpm5.org/files/rpm/rpm-3.0/ \
MAINTAINER= sylvio@FreeBSD.org
COMMENT= The Red Hat Package Manager
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
CONFLICTS= rpm-[45].*
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
index e287c43fb384..ff701e6908a9 100644
--- a/archivers/rpm5/Makefile
+++ b/archivers/rpm5/Makefile
@@ -10,13 +10,13 @@ MASTER_SITES= http://rpm5.org/files/rpm/rpm-${PORTVERSION:R}/
MAINTAINER= afb@rpm5.org
COMMENT= The RPM Package Manager
-LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- popt.0:${PORTSDIR}/devel/popt \
- beecrypt.7:${PORTSDIR}/security/beecrypt \
- neon.27:${PORTSDIR}/www/neon29 \
- magic:${PORTSDIR}/sysutils/file \
- xar:${PORTSDIR}/archivers/xar \
- pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
+ libpopt.so:${PORTSDIR}/devel/popt \
+ libbeecrypt.so:${PORTSDIR}/security/beecrypt \
+ libneon.so:${PORTSDIR}/www/neon29 \
+ libmagic.so:${PORTSDIR}/sysutils/file \
+ libxar.so:${PORTSDIR}/archivers/xar \
+ libpcre.so:${PORTSDIR}/devel/pcre
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed \
${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid \
bash:${PORTSDIR}/shells/bash
@@ -122,7 +122,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
-LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
+LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/xz
.endif
.if ${OSVERSION} <= 701000
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index 555a7e6b2f01..2daa863a67b0 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/libiberty/libiberty.h:${PORTSDIR}/devel/gnulibiberty
-LIB_DEPENDS= explain:${PORTSDIR}/devel/libexplain
+LIB_DEPENDS= libexplain.so:${PORTSDIR}/devel/libexplain
GNU_CONFIGURE= yes
diff --git a/archivers/upx/Makefile b/archivers/upx/Makefile
index d26a23849798..b3f2ff68eb4e 100644
--- a/archivers/upx/Makefile
+++ b/archivers/upx/Makefile
@@ -12,7 +12,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}-src${EXTRACT_SUFX}\
MAINTAINER= fjoe@FreeBSD.org
COMMENT= The Ultimate Packer for eXecutables
-LIB_DEPENDS= ucl.1:${PORTSDIR}/archivers/ucl
+LIB_DEPENDS= libucl.so:${PORTSDIR}/archivers/ucl
NO_STAGE= yes
LZMA_VER= 4.65