aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-23 08:22:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-23 08:22:13 +0000
commitc955d457ef8de1d3985e25ed32ca432b4f25b1b2 (patch)
tree8b6ceb715afc5ec5303510085978e7457813c4fb
parent43ad8e0f957a22bcb43e64223509d2b8e339f151 (diff)
downloadports-c955d457ef8de1d3985e25ed32ca432b4f25b1b2.tar.gz
ports-c955d457ef8de1d3985e25ed32ca432b4f25b1b2.zip
Notes
-rw-r--r--benchmarks/unixbench/Makefile1
-rw-r--r--benchmarks/unixbench/files/patch-execl.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/benchmarks/unixbench/Makefile b/benchmarks/unixbench/Makefile
index 45899ab1ee95..ba72c0eb8d62 100644
--- a/benchmarks/unixbench/Makefile
+++ b/benchmarks/unixbench/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unixbench
PORTVERSION= 4.1.0
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= http://www.tux.org/pub/tux/benchmarks/System/unixbench/
EXTRACT_SUFX= .tgz
diff --git a/benchmarks/unixbench/files/patch-execl.c b/benchmarks/unixbench/files/patch-execl.c
new file mode 100644
index 000000000000..affb32ff6d6e
--- /dev/null
+++ b/benchmarks/unixbench/files/patch-execl.c
@@ -0,0 +1,11 @@
+--- src/execl.c.orig Wed Jul 28 23:46:58 1999
++++ src/execl.c Fri Mar 23 09:20:36 2007
+@@ -88,7 +88,7 @@
+ fprintf(stderr, "%lu loops\n", iter);
+ exit(0);
+ }
+- execl(fullpath, fullpath, "0", dur_str, count_str, start_str, 0);
++ execl(fullpath, fullpath, "0", dur_str, count_str, start_str, NULL);
+ printf("Exec failed at iteration %lu\n", iter);
+ perror("Reason");
+ exit(1);