aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-10 14:36:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-10 14:36:46 +0000
commitcb155a7e5d4797cc21602de5205af67230e89a31 (patch)
treed378e2c04ca9d3d7f76b11768e349e43e1e406a1
parent054cd56e4a1ec043184c0ecaf027f3802c2e21fa (diff)
downloadports-cb155a7e5d4797cc21602de5205af67230e89a31.tar.gz
ports-cb155a7e5d4797cc21602de5205af67230e89a31.zip
Notes
-rw-r--r--devel/pear-Net_Gearman/Makefile1
-rw-r--r--devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php26
2 files changed, 27 insertions, 0 deletions
diff --git a/devel/pear-Net_Gearman/Makefile b/devel/pear-Net_Gearman/Makefile
index f10a22b46f69..dc868e6e4544 100644
--- a/devel/pear-Net_Gearman/Makefile
+++ b/devel/pear-Net_Gearman/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Net_Gearman
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= devel pear
MAINTAINER= gslin@gslin.org
diff --git a/devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php b/devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php
new file mode 100644
index 000000000000..284346500a93
--- /dev/null
+++ b/devel/pear-Net_Gearman/files/patch-Net__Gearman__Client.php
@@ -0,0 +1,26 @@
+--- ./Net/Gearman/Client.php.orig 2013-03-13 17:50:59.000000000 +0800
++++ ./Net/Gearman/Client.php 2013-03-13 17:51:18.000000000 +0800
+@@ -166,11 +166,11 @@
+ $s = $this->getConnection();
+ Net_Gearman_Connection::send($s, $type, $params);
+
+- if (!is_array(Net_Gearman_Connection::$waiting[$s])) {
+- Net_Gearman_Connection::$waiting[$s] = array();
++ if (!is_array(Net_Gearman_Connection::$waiting[(int) $s])) {
++ Net_Gearman_Connection::$waiting[(int) $s] = array();
+ }
+
+- array_push(Net_Gearman_Connection::$waiting[$s], $task);
++ array_push(Net_Gearman_Connection::$waiting[(int) $s], $task);
+ }
+
+ /**
+@@ -244,7 +244,7 @@
+ $task->fail();
+ break;
+ case 'job_created':
+- $task = array_shift(Net_Gearman_Connection::$waiting[$s]);
++ $task = array_shift(Net_Gearman_Connection::$waiting[(int) $s]);
+ $task->handle = $resp['data']['handle'];
+ if ($task->type == Net_Gearman_Task::JOB_BACKGROUND) {
+ $task->finished = true;