aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-19 10:42:54 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-19 10:42:54 +0000
commitde09fed6e5a2ec063637bb998449d0b47a102870 (patch)
tree83ba326700226cd5d3d59293e9e328d918eb55c9
parent6cda9642eb1676d609b6b8dd69889093bf0706b0 (diff)
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pms/Makefile29
-rw-r--r--audio/pms/distinfo3
-rw-r--r--audio/pms/files/patch-src_pms.cpp16
-rw-r--r--audio/pms/pkg-descr7
5 files changed, 56 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1a4b3b441cca..d696e0b19f85 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -583,6 +583,7 @@
SUBDIR += playgsf
SUBDIR += playmidi
SUBDIR += pm3umpdl
+ SUBDIR += pms
SUBDIR += pocketsphinx
SUBDIR += portaudio
SUBDIR += portaudio2
diff --git a/audio/pms/Makefile b/audio/pms/Makefile
new file mode 100644
index 000000000000..f6c2977a8b97
--- /dev/null
+++ b/audio/pms/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pms
+# Date created: 2010-05-13
+# Whom: Ashish SHUKLA <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pms
+PORTVERSION= 0.42
+CATEGORIES= audio
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= A ncurses-based client for the Music Player Daemon
+
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= glib20
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/audio/pms/distinfo b/audio/pms/distinfo
new file mode 100644
index 000000000000..116d242f1cd5
--- /dev/null
+++ b/audio/pms/distinfo
@@ -0,0 +1,3 @@
+MD5 (pms-0.42.tar.bz2) = 8ebd65c5e6e33cd0ca79817a5e823805
+SHA256 (pms-0.42.tar.bz2) = 96bf942b08cba10ee891a63eeccad307fd082ef3bd20be879f189e1959e775a6
+SIZE (pms-0.42.tar.bz2) = 196053
diff --git a/audio/pms/files/patch-src_pms.cpp b/audio/pms/files/patch-src_pms.cpp
new file mode 100644
index 000000000000..27b0f8c54999
--- /dev/null
+++ b/audio/pms/files/patch-src_pms.cpp
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- src/pms.cpp.orig
++++ src/pms.cpp
+@@ -23,6 +23,10 @@
+
+ #include "pms.h"
+
++#ifdef __FreeBSD__
++#include <sys/wait.h>
++#endif
++
+ using namespace std;
+
+ Pms * pms;
diff --git a/audio/pms/pkg-descr b/audio/pms/pkg-descr
new file mode 100644
index 000000000000..4a9c752ed727
--- /dev/null
+++ b/audio/pms/pkg-descr
@@ -0,0 +1,7 @@
+Practical Music Search is an open source ncurses client for Music
+Player Daemon, written in C++. The target audience are power users who
+need an MPD client that is highly configurable and accessible. PMS
+features a simple but powerful interface similar to Vim, and runs on
+(at least) Linux and Mac OS X.
+
+WWW: http://pms.sourceforge.net/