aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-17 10:38:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-17 10:38:07 +0000
commitde1a24d0f8cf165db01441327a725762343ed6fa (patch)
treeb75cc4d8e8d492542d62b5cd3a1afbf1d669e468
parentc72f9bc05d197b76003a11b6e58e5b1341759f48 (diff)
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Flow/Makefile21
-rw-r--r--net/p5-Net-Flow/distinfo3
-rw-r--r--net/p5-Net-Flow/pkg-descr12
-rw-r--r--net/p5-Net-Flow/pkg-plist5
5 files changed, 42 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8e3f868422d7..cc31e349f1e8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -485,6 +485,7 @@
SUBDIR += p5-Net-FS-Gmail
SUBDIR += p5-Net-FTP-File
SUBDIR += p5-Net-Finger
+ SUBDIR += p5-Net-Flow
SUBDIR += p5-Net-Frame
SUBDIR += p5-Net-Frame-Dump
SUBDIR += p5-Net-Gnats
diff --git a/net/p5-Net-Flow/Makefile b/net/p5-Net-Flow/Makefile
new file mode 100644
index 000000000000..7eb91e535ee8
--- /dev/null
+++ b/net/p5-Net-Flow/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Net-Flow
+# Date created: 2008-02-17
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Flow
+PORTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= Decode and encode NetFlow/IPFIX datagrams
+
+PERL_CONFIGURE= 5.6.1+
+
+MAN3= Net::Flow.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Flow/distinfo b/net/p5-Net-Flow/distinfo
new file mode 100644
index 000000000000..1b0d96ce666b
--- /dev/null
+++ b/net/p5-Net-Flow/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Flow-0.02.tar.gz) = 8a56b1b654be28b68e979bc89e55452c
+SHA256 (Net-Flow-0.02.tar.gz) = 92725203e5d19e56fcacb2a653aa8de81aadf68a381aa91583dc135ea5e913f9
+SIZE (Net-Flow-0.02.tar.gz) = 9609
diff --git a/net/p5-Net-Flow/pkg-descr b/net/p5-Net-Flow/pkg-descr
new file mode 100644
index 000000000000..aa2f7f4d48be
--- /dev/null
+++ b/net/p5-Net-Flow/pkg-descr
@@ -0,0 +1,12 @@
+The Flow module provides the decoding function for NetFlow version 5,9
+and IPFIX, and the encoding function for NetFlow version 9 and IPFIX.
+It supports NetFlow version 9 (RFC3945) and NetFlow version 5
+(http://www.cisco.com/) and IPFIX(draft-ietf-ipfix-protocol-26.txt).
+Regretfully, it doesn't provide the full specification of IPFIX, yet.
+It is future work. You can easily make the Flow Proxy, Protocol Converter
+and Flow Concentrator by using the combination of both function. And also,
+you can make the flexible Collector which can receive any Templates
+by using the Storable perl module.
+
+AUTHOR: Atsushi Kobayashi <akoba@nttv6.net>
+WWW: http://search.cpan.org/dist/Net-Flow/
diff --git a/net/p5-Net-Flow/pkg-plist b/net/p5-Net-Flow/pkg-plist
new file mode 100644
index 000000000000..631b64b25c20
--- /dev/null
+++ b/net/p5-Net-Flow/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Net/Flow.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Flow/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Flow
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net