aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-07-21 14:35:00 +0000
committerJohn Marino <marino@FreeBSD.org>2013-07-21 14:35:00 +0000
commite012a92d09f42c4b4e6c4742e81f6016b993e790 (patch)
treeefca8f58ca7abd5443baeea875916fac4d24b507
parent2d60de8ed2825470a8ed9a2a427f248d2e9ae645 (diff)
downloadports-e012a92d09f42c4b4e6c4742e81f6016b993e790.tar.gz
ports-e012a92d09f42c4b4e6c4742e81f6016b993e790.zip
Notes
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/qtada/Makefile42
-rw-r--r--x11-toolkits/qtada/distinfo2
-rw-r--r--x11-toolkits/qtada/pkg-descr15
4 files changed, 60 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 9662719fc07c..b98e8059ecfd 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -223,6 +223,7 @@
SUBDIR += qt33
SUBDIR += qt4-gui
SUBDIR += qt4pas
+ SUBDIR += qtada
SUBDIR += qwt4
SUBDIR += qwt5
SUBDIR += qwt5-designerplugin
diff --git a/x11-toolkits/qtada/Makefile b/x11-toolkits/qtada/Makefile
new file mode 100644
index 000000000000..eaeda24f74ec
--- /dev/null
+++ b/x11-toolkits/qtada/Makefile
@@ -0,0 +1,42 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= qtada
+PORTVERSION= 3.2.0.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://download.qtada.com/
+DISTNAME= ${PORTNAME}-gpl-3.2.0-20120708-3871
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Ada2005 language bindings to Qt4 framework
+
+BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
+ gnat_util>=2013:${PORTSDIR}/lang/gnat_util \
+ asis>=2011:${PORTSDIR}/lang/asis
+
+USES= ada gmake pkgconfig
+GNU_CONFIGURE= yes
+USE_QT4= corelib gui xml designer sql opengl webkit
+DESTINY= ${WRKDIR}/destino
+MAKE_ENV= DESTDIR=${DESTINY}
+
+#CONFIGURE_ARGS= --with-gtkada=NO
+
+post-install:
+ ${MV} ${DESTINY}${PREFIX}/examples ${DESTINY}${PREFIX}/share/
+ ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
+ @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${WRKDIR}/PLIST.all
+ @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
+ ${SORT} -r | ${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' \
+ -e '/share\/gps$$/d' -e '/share\/gps\/plug-ins$$/d' \
+ -e '/share\/gprconfig$$/d' -e 's/^/@dirrm /g' \
+ >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/gprconfig 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qtada/distinfo b/x11-toolkits/qtada/distinfo
new file mode 100644
index 000000000000..09c4eaf45658
--- /dev/null
+++ b/x11-toolkits/qtada/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qtada-gpl-3.2.0-20120708-3871.tar.gz) = f6d07d5399bc62717191d1c298b969bf72b4c02c3fed950c07b63978edc5bd63
+SIZE (qtada-gpl-3.2.0-20120708-3871.tar.gz) = 3082986
diff --git a/x11-toolkits/qtada/pkg-descr b/x11-toolkits/qtada/pkg-descr
new file mode 100644
index 000000000000..6b191ba685f2
--- /dev/null
+++ b/x11-toolkits/qtada/pkg-descr
@@ -0,0 +1,15 @@
+QtAda is an Ada 2005 language binding to the Qt libraries and a set of
+useful tools. Qt versions 4.6 and later are supported.
+
+QtAda easily enables powerful cross-platform graphical user interfaces
+completely on Ada 2005. QtAda applications work on all popular platforms
+without any changes or platform-specific coding. QtAda applications have
+the platforms' native look and feel.
+
+It is possible to develop custom widgets and integrate them into the Qt
+designer for rapid GUI development.
+
+QtAda has excellent support for localization and internationalization, and
+usings native safe threading for transparent integration with Ada tasks.
+
+WWW: http://www.qtada.com