aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 09:17:40 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 09:17:40 +0000
commite0e2c5228a6690440b633c25b0c582a06dc91003 (patch)
tree7ae2b7f867c64787822b0e475abe322934da04e0
parentba7f0475a6bfd8a064b21583cd187f5dd34a8175 (diff)
Notes
-rw-r--r--devel/moonshine/Makefile4
-rw-r--r--devel/qtez/Makefile4
-rw-r--r--mail/liamail/Makefile8
-rw-r--r--misc/icemc/Makefile8
-rw-r--r--textproc/kbedic/Makefile8
-rw-r--r--x11-wm/icemc/Makefile8
6 files changed, 36 insertions, 4 deletions
diff --git a/devel/moonshine/Makefile b/devel/moonshine/Makefile
index b7444b69e372..e52426b5a027 100644
--- a/devel/moonshine/Makefile
+++ b/devel/moonshine/Makefile
@@ -23,6 +23,10 @@ QTCPPFLAGS+= -I${X11BASE}/include
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
.if ${MACHINE_ARCH} == "alpha"
CFLAGS+= -O0
.endif
diff --git a/devel/qtez/Makefile b/devel/qtez/Makefile
index de3a281ca841..297e811a5b7c 100644
--- a/devel/qtez/Makefile
+++ b/devel/qtez/Makefile
@@ -26,6 +26,10 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
.if ${MACHINE_ARCH} == "alpha"
CFLAGS+= -O0
.endif
diff --git a/mail/liamail/Makefile b/mail/liamail/Makefile
index ea373a4f666e..6391e6218e29 100644
--- a/mail/liamail/Makefile
+++ b/mail/liamail/Makefile
@@ -15,6 +15,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= kde@freebsd.org
COMMENT= A graphical mail client
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_REINPLACE= yes
@@ -29,4 +35,4 @@ post-patch:
@${REINPLACE_CMD} -e "s/qt.so/qt2.so/g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s/-lqt/-lqt2/g" ${WRKSRC}/src/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/icemc/Makefile b/misc/icemc/Makefile
index ca2d11a4a715..0ff803ca1090 100644
--- a/misc/icemc/Makefile
+++ b/misc/icemc/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.algorithm.at/comp/icemc/
MAINTAINER= adamw@FreeBSD.org
COMMENT= QT-based menu editor for IceWM
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_X_PREFIX= yes
USE_QT_VER= 3
@@ -22,4 +28,4 @@ MAKE_ENV= QTCPPFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/icemc ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/kbedic/Makefile b/textproc/kbedic/Makefile
index 12990a0210cf..0a542c257bed 100644
--- a/textproc/kbedic/Makefile
+++ b/textproc/kbedic/Makefile
@@ -16,6 +16,12 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= todorov@freebsd-bg.org
COMMENT= An English-to-Bulgarian and Bulgarian-to-English dictionary
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
RUN_DEPENDS= ${DICT_DIR}/${DICT_CHECK}:${PORTSDIR}/textproc/bedic-data
DICT_CHECK?= buleng.dat
@@ -46,4 +52,4 @@ pre-fetch:
@${ECHO_MSG} "to the names of the dictionaries that the textproc/bedic-data port"
@${ECHO_MSG} "will install; refer to that port for more information."
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/icemc/Makefile b/x11-wm/icemc/Makefile
index ca2d11a4a715..0ff803ca1090 100644
--- a/x11-wm/icemc/Makefile
+++ b/x11-wm/icemc/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.algorithm.at/comp/icemc/
MAINTAINER= adamw@FreeBSD.org
COMMENT= QT-based menu editor for IceWM
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_X_PREFIX= yes
USE_QT_VER= 3
@@ -22,4 +28,4 @@ MAKE_ENV= QTCPPFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/icemc ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>