aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-07-10 03:07:30 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-07-10 03:07:30 +0000
commitf844d449b605e81bbd4718341ba2672dde7e36e9 (patch)
tree8d11052d1631d9fd4ea1677c3c5ff957e1ba6061
parentbdf954a1a87b36f44ba6f61c3264c24c4176e26a (diff)
downloadports-f844d449b605e81bbd4718341ba2672dde7e36e9.tar.gz
ports-f844d449b605e81bbd4718341ba2672dde7e36e9.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-PySQLite10/Makefile2
-rw-r--r--databases/py-PySQLite11/Makefile2
-rw-r--r--databases/py-pysqlite20/Makefile2
-rw-r--r--databases/py-pysqlite21/Makefile2
-rw-r--r--databases/py-pysqlite22/Makefile2
-rw-r--r--databases/py-pysqlite23/Makefile6
-rw-r--r--databases/py-pysqlite23/distinfo6
8 files changed, 12 insertions, 11 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 88f3423d22ce..128191bbd6ec 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -375,6 +375,7 @@
SUBDIR += py-pysqlite20
SUBDIR += py-pysqlite21
SUBDIR += py-pysqlite22
+ SUBDIR += py-pysqlite23
SUBDIR += py-SQLDict
SUBDIR += py-axiom
SUBDIR += py-bsddb
diff --git a/databases/py-PySQLite10/Makefile b/databases/py-PySQLite10/Makefile
index a319394d3216..ba7d09daaf20 100644
--- a/databases/py-PySQLite10/Makefile
+++ b/databases/py-PySQLite10/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2
NO_LATEST_LINK= yes
-CONFLICTS= py*-PySQLite-1.1*
+CONFLICTS= py*-PySQLite-1.1.*
WRKSRC= ${WRKDIR}/pysqlite
USE_PYTHON= yes
diff --git a/databases/py-PySQLite11/Makefile b/databases/py-PySQLite11/Makefile
index 9fd43ac5ddc1..8cc37d7ff33d 100644
--- a/databases/py-PySQLite11/Makefile
+++ b/databases/py-PySQLite11/Makefile
@@ -17,7 +17,7 @@ COMMENT= A DB-API v2 Python library for the SQLite 3 embedded SQL engine
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
-CONFLICTS= py*-PySQLite-1.0*
+CONFLICTS= py*-PySQLite-1.0.*
NO_LATEST_LINK= yes
diff --git a/databases/py-pysqlite20/Makefile b/databases/py-pysqlite20/Makefile
index db7cfdd3352f..94d1b9a48b8f 100644
--- a/databases/py-pysqlite20/Makefile
+++ b/databases/py-pysqlite20/Makefile
@@ -19,7 +19,7 @@ COMMENT= A DB-API v2 Python library for the SQLite 3 embedded SQL engine
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
-CONFLICTS= py*-pysqlite-2.1*
+CONFLICTS= py*-pysqlite-2.[1-9].*
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}20${PKGNAMESUFFIX}
diff --git a/databases/py-pysqlite21/Makefile b/databases/py-pysqlite21/Makefile
index 1a6e35068a2b..21ad1db151f1 100644
--- a/databases/py-pysqlite21/Makefile
+++ b/databases/py-pysqlite21/Makefile
@@ -19,7 +19,7 @@ COMMENT= A DB-API v2 Python library for the SQLite 3 embedded SQL engine
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
-CONFLICTS= py*-pysqlite-2.0*
+CONFLICTS= py*-pysqlite-2.[02-9].*
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}21${PKGNAMESUFFIX}
diff --git a/databases/py-pysqlite22/Makefile b/databases/py-pysqlite22/Makefile
index fed2213ff8f7..ebd56d2c0689 100644
--- a/databases/py-pysqlite22/Makefile
+++ b/databases/py-pysqlite22/Makefile
@@ -18,7 +18,7 @@ COMMENT= A DB-API v2 Python library for the SQLite 3 embedded SQL engine
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
-CONFLICTS= py*-pysqlite-2.0*
+CONFLICTS= py*-pysqlite-2.[0-13-9].*
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
diff --git a/databases/py-pysqlite23/Makefile b/databases/py-pysqlite23/Makefile
index fed2213ff8f7..150c7dc428f7 100644
--- a/databases/py-pysqlite23/Makefile
+++ b/databases/py-pysqlite23/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pysqlite
-PORTVERSION= 2.2.2
+PORTVERSION= 2.3.2
CATEGORIES= databases python
MASTER_SITES= http://initd.org/pub/software/pysqlite/releases/${PORTVERSION:C/\.[0-9]$//}/${PORTVERSION}/ \
${MASTER_SITE_GENTOO}
@@ -18,7 +18,7 @@ COMMENT= A DB-API v2 Python library for the SQLite 3 embedded SQL engine
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
-CONFLICTS= py*-pysqlite-2.0*
+CONFLICTS= py*-pysqlite-2.[0-24-9].*
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
@@ -29,7 +29,7 @@ DOCSDIR= ${PREFIX}/${DOCSBASE}
PORTDOCS= *
post-patch:
- @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|" ${WRKSRC}/setup.cfg
+ @${REINPLACE_CMD} -e "s|/usr|${PREFIX}|" ${WRKSRC}/setup.cfg
.if !defined(NOPORTDOCS)
@${REINPLACE_CMD} -E -e "s|pysqlite2-doc|${DOCSBASE}|" \
-e "s/.*(cmdclass|extras_require) =.*//" \
diff --git a/databases/py-pysqlite23/distinfo b/databases/py-pysqlite23/distinfo
index efc5dc47942c..fc6d5d856e07 100644
--- a/databases/py-pysqlite23/distinfo
+++ b/databases/py-pysqlite23/distinfo
@@ -1,3 +1,3 @@
-MD5 (pysqlite-2.2.2.tar.gz) = 3260547d3f11c85613b2de8ed529a4fc
-SHA256 (pysqlite-2.2.2.tar.gz) = 76a82a6a45ae9c12c0409427765ae56c06d8dbb03321f21b8c4d7da48c7cd2b3
-SIZE (pysqlite-2.2.2.tar.gz) = 75176
+MD5 (pysqlite-2.3.2.tar.gz) = bb9a67d62ff91cd8c53720bd15c86a30
+SHA256 (pysqlite-2.3.2.tar.gz) = 9c9115116867d7852b712a9faf05f3e1c4305cfbfa5468268301b26925e6f961
+SIZE (pysqlite-2.3.2.tar.gz) = 79532