aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2015-03-10 19:29:58 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2015-03-10 19:29:58 +0000
commit103ed39cff481dfe5228962fdf7b305bc238c365 (patch)
tree36e8c268706a6377b8ab1464f3973174c33f4ce3
parentdc85a31709d4dc5c3d1d24c9226fd756f76b7165 (diff)
downloadports-103ed39cff481dfe5228962fdf7b305bc238c365.tar.gz
ports-103ed39cff481dfe5228962fdf7b305bc238c365.zip
MFH: r380791
HTML-FormatExternal lets you turn HTML into plain text using one of the browsing/formatting programs, elinks http://elinks.cz/ html2text http://www.mbayer.de/html2text/ links http://links.twibright.com/ lynx http://lynx.isc.org/ netrik http://netrik.sourceforge.net/ vilistextum http://bhaak.dyndns.org/vilistextum/ w3m http://sourceforge.net/projects/w3m zen http://www.nocrew.org/software/zen/ WWW: http://search.cpan.org/dist/HTML-FormatExternal/ Approved by: ports-secteam (delphij)
Notes
Notes: svn path=/branches/2015Q1/; revision=380958
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-HTML-FormatExternal/Makefile46
-rw-r--r--textproc/p5-HTML-FormatExternal/distinfo2
-rw-r--r--textproc/p5-HTML-FormatExternal/pkg-descr13
-rw-r--r--textproc/p5-HTML-FormatExternal/pkg-plist18
5 files changed, 80 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e4375227ac30..97c140b31bab 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -524,6 +524,7 @@
SUBDIR += p5-HTML-Entities-Numbered
SUBDIR += p5-HTML-EscapeEvil
SUBDIR += p5-HTML-Format
+ SUBDIR += p5-HTML-FormatExternal
SUBDIR += p5-HTML-FormatText-WithLinks
SUBDIR += p5-HTML-FormatText-WithLinks-AndTables
SUBDIR += p5-HTML-Fraction
diff --git a/textproc/p5-HTML-FormatExternal/Makefile b/textproc/p5-HTML-FormatExternal/Makefile
new file mode 100644
index 000000000000..02b402edd567
--- /dev/null
+++ b/textproc/p5-HTML-FormatExternal/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= HTML-FormatExternal
+PORTVERSION= 22
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= HTML to text formatting using external programs
+
+LICENSE= GPLv3
+
+OPTIONS_DEFINE= ELINKS HTML2TEXT LINKS LYNX LYNX_CURRENT NETRIK W3M
+OPTIONS_DEFAULT= LYNX
+
+BUILD_DEPENDS= p5-Encode>=0:${PORTSDIR}/converters/p5-Encode \
+ p5-URI>=0.08:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+INSTALL_TARGET= pure_install
+
+ELINKS_DESC= Install with elinks
+ELINKS_RUN_DEPENDS= elinks:${PORTSDIR}/www/elinks
+
+HTML2TEXT_DESC= Install with html2text
+HTML2TEXT_RUN_DEPENDS= html2text:${PORTSDIR}/textproc/html2text
+
+LINKS_DESC= Install with links
+LINKS_RUN_DEPENDS= links:${PORTSDIR}/www/links
+
+LYNX_DESC= Install with lynx
+LYNX_RUN_DEPENDS= lynx:${PORTSDIR}/www/lynx
+
+LYNX_CURRENT_DESC= Install with lynx-current
+LYNX_CURRENT_RUN_DEPENDS= lynx:${PORTSDIR}/www/lynx-current
+
+NETRIK_DESC= Install with netrik
+NETRIK_RUN_DEPENDS= netrik:${PORTSDIR}/www/netrik
+
+W3M_DESC= Install with w3m
+W3M_RUN_DEPENDS= w3m:${PORTSDIR}/www/w3m
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-HTML-FormatExternal/distinfo b/textproc/p5-HTML-FormatExternal/distinfo
new file mode 100644
index 000000000000..cce325e619d0
--- /dev/null
+++ b/textproc/p5-HTML-FormatExternal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTML-FormatExternal-22.tar.gz) = 8dbce273f43796e3bf5d14ac4166694de4ed68a560fd0675d4a297ef998d2793
+SIZE (HTML-FormatExternal-22.tar.gz) = 50668
diff --git a/textproc/p5-HTML-FormatExternal/pkg-descr b/textproc/p5-HTML-FormatExternal/pkg-descr
new file mode 100644
index 000000000000..78b5fbf93f59
--- /dev/null
+++ b/textproc/p5-HTML-FormatExternal/pkg-descr
@@ -0,0 +1,13 @@
+HTML-FormatExternal lets you turn HTML into plain text using one of
+the browsing/formatting programs,
+
+ elinks http://elinks.cz/
+ html2text http://www.mbayer.de/html2text/
+ links http://links.twibright.com/
+ lynx http://lynx.isc.org/
+ netrik http://netrik.sourceforge.net/
+ vilistextum http://bhaak.dyndns.org/vilistextum/
+ w3m http://sourceforge.net/projects/w3m
+ zen http://www.nocrew.org/software/zen/
+
+WWW: http://search.cpan.org/dist/HTML-FormatExternal/
diff --git a/textproc/p5-HTML-FormatExternal/pkg-plist b/textproc/p5-HTML-FormatExternal/pkg-plist
new file mode 100644
index 000000000000..af947ce30080
--- /dev/null
+++ b/textproc/p5-HTML-FormatExternal/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/HTML/FormatExternal.pm
+%%SITE_PERL%%/HTML/FormatText/Elinks.pm
+%%SITE_PERL%%/HTML/FormatText/Html2text.pm
+%%SITE_PERL%%/HTML/FormatText/Links.pm
+%%SITE_PERL%%/HTML/FormatText/Lynx.pm
+%%SITE_PERL%%/HTML/FormatText/Netrik.pm
+%%SITE_PERL%%/HTML/FormatText/Vilistextum.pm
+%%SITE_PERL%%/HTML/FormatText/W3m.pm
+%%SITE_PERL%%/HTML/FormatText/Zen.pm
+%%PERL5_MAN3%%/HTML::FormatExternal.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::Elinks.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::Html2text.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::Links.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::Lynx.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::Netrik.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::Vilistextum.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::W3m.3.gz
+%%PERL5_MAN3%%/HTML::FormatText::Zen.3.gz