aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-19 00:24:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-19 00:24:05 +0000
commit059deee79dfe5c8657880164881235df38644908 (patch)
tree94fa6980c43005aa02c41036b5603c85de962926
parent52f4e24a901b21a50363096af3d265dd93d8db81 (diff)
downloadports-059deee79dfe5c8657880164881235df38644908.tar.gz
ports-059deee79dfe5c8657880164881235df38644908.zip
MFH: r390088
- Fix build on i386 Approved by: ports-secteam (zi)
Notes
Notes: svn path=/branches/2015Q2/; revision=390090
-rw-r--r--math/tomsfastmath/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/math/tomsfastmath/Makefile b/math/tomsfastmath/Makefile
index 2e699fab7b28..fdaf45f3b732 100644
--- a/math/tomsfastmath/Makefile
+++ b/math/tomsfastmath/Makefile
@@ -11,13 +11,21 @@ COMMENT= Portable fixed precision math library for fast exponentiations
BROKEN_powerpc= internal compiler error at src/mul/fp_mul_comba_48.c:398
-USES= gmake tar:bzip2
+USES= compiler:features gmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
ALL_TARGET= default
PLIST_FILES= include/tfm.h lib/libtfm.a
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386
+# on clang:
+# src/mul/fp_mul_comba.c:349:11: error: inline assembly requires more registers than available
+USE_GCC= yes
+.endif
+
# Unbreak against Clang ("cc" is not a register)
post-patch:
@${REINPLACE_CMD} -e 's,"%cc","cc",' \
@@ -25,4 +33,4 @@ post-patch:
${WRKSRC}/src/mul/fp_mul_comba.c \
${WRKSRC}/src/sqr/fp_sqr_comba.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>