aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-17 07:48:22 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-17 07:48:22 +0000
commit3a1aa3c465962334c072adbaa3f74ba2b30aecb6 (patch)
tree61c25d819a68a2060aa77437512597afc5738a10
parent15c4a5ecf338d0133b87647ab773c6df26f3ea15 (diff)
downloadports-3a1aa3c465962334c072adbaa3f74ba2b30aecb6.tar.gz
ports-3a1aa3c465962334c072adbaa3f74ba2b30aecb6.zip
Notes
-rw-r--r--CHANGES10
-rw-r--r--Mk/bsd.autotools.mk60
-rw-r--r--Mk/bsd.gnome.mk78
-rw-r--r--Mk/bsd.sanity.mk10
4 files changed, 21 insertions, 137 deletions
diff --git a/CHANGES b/CHANGES
index cee766b2ffd5..c58d2f2ab9dd 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,16 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20140917:
+AUTHOR: tijl@FreeBSD.org
+
+ Support for USE_AUTOTOOLS=libtool, USE_GNOME=ltasneededhack,
+ USE_GNOME=lthack and USE_GNOME=ltverhack has been removed. Ports
+ should use USES=libtool instead.
+
+ Support for USE_AUTOTOOLS=libltdl has been removed. Ports should
+ use LIB_DEPENDS=libltdl.so:${PORTSDIR}/devel/libltdl
+
20140916:
AUTHOR: tijl@FreeBSD.org
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 79da3568e50a..24140bd856d8 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -17,7 +17,7 @@ Autotools_Include_MAINTAINER= autotools@FreeBSD.org
# autoconf213, autoheader213 (legacy version)
# automake, aclocal
# automake14, aclocal14 (legacy version)
-# libtool, libtoolize, libltdl
+# libtoolize
#
# ':env' is used to specify that the environmental variables are needed
# but the relevant tool should NOT be run as part of the
@@ -41,12 +41,6 @@ Autotools_Include_MAINTAINER= autotools@FreeBSD.org
# LIBTOOLIZE_ARGS=...
# - Extra arguments passed to libtoolize during configure step
#
-# LIBTOOLFLAGS=<value>
-# - Arguments passed to libtool during configure step
-#
-# LIBTOOLFILES=<list-of-files>
-# - A list of files to patch during libtool pre-configuration
-#
# AUTOTOOLSFILES=<list-of-files>
# - A list of files to further patch with derived information
# post-patching to reduce churn during component updates
@@ -60,7 +54,7 @@ Autotools_Include_MAINTAINER= autotools@FreeBSD.org
# Known autotools components
_AUTOTOOLS_ALL= autoconf autoheader autoconf213 autoheader213 \
automake aclocal automake14 aclocal14 \
- libtool libtoolize libltdl
+ libtoolize
# Incompatible autotools mixing
_AUTOTOOLS_IGN_autoconf= autoconf213 autoheader213
@@ -254,25 +248,13 @@ BUILD_DEPENDS+= ${AUTOCONF_DEPENDS}
.endif
#---------------------------------------------------------------------------
-# libltdl
+# libtoolize
#---------------------------------------------------------------------------
-.if defined(_AUTOTOOL_libltdl)
-LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl
-.endif
-
-#---------------------------------------------------------------------------
-# libtool/libtoolize
-#---------------------------------------------------------------------------
-
-.if defined(_AUTOTOOL_libtool) || defined(_AUTOTOOL_libtoolize)
+.if defined(_AUTOTOOL_libtoolize)
LIBTOOL_VERSION= 2.4
LIBTOOL_PORT= devel/libtool
-. if defined(_AUTOTOOL_libtool) && ${_AUTOTOOL_libtool} == "yes"
-_AUTOTOOL_rule_libtool= yes
-GNU_CONFIGURE?= yes
-. endif
. if defined(_AUTOTOOL_libtoolize) && ${_AUTOTOOL_libtoolize} == "yes"
_AUTOTOOL_rule_libtoolize= yes
GNU_CONFIGURE?= yes
@@ -281,28 +263,18 @@ GNU_CONFIGURE?= yes
.endif
.if defined(LIBTOOL_VERSION)
-LIBTOOL= ${LOCALBASE}/bin/libtool
LIBTOOLIZE= ${LOCALBASE}/bin/libtoolize
LIBTOOL_LIBEXECDIR= ${LOCALBASE}/libexec/libtool
LIBTOOL_SHAREDIR= ${LOCALBASE}/share/libtool
LIBTOOL_M4= ${LOCALBASE}/share/aclocal/libtool.m4
LTMAIN= ${LOCALBASE}/share/libtool/config/ltmain.sh
-LIBTOOL_VARS= LIBTOOL=${LIBTOOL} \
- LIBTOOLIZE=${LIBTOOLIZE} \
+LIBTOOL_VARS= LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_LIBEXECDIR=${LIBTOOL_LIBEXECDIR} \
LIBTOOL_SHAREDIR=${LIBTOOL_SHAREDIR} \
LIBTOOL_M4=${LIBTOOL_M4} \
LTMAIN=${LTMAIN}
-LIBTOOLFLAGS?= # default to empty
-
-. if defined(_AUTOTOOL_rule_autoconf) || defined(_AUTOTOOL_rule_autoconf213)
-LIBTOOLFILES?= aclocal.m4
-. elif defined(_AUTOTOOL_rule_libtool)
-LIBTOOLFILES?= ${CONFIGURE_SCRIPT}
-. endif
-
LIBTOOLIZE_ARGS?= -i -c -f
LIBTOOL_DEPENDS= libtool>=2.4:${PORTSDIR}/${LIBTOOL_PORT}
@@ -327,12 +299,12 @@ ${var:tu}_ENV+= ${AUTOTOOLS_VARS}
.if !target(run-autotools)
.ORDER: run-autotools run-autotools-libtoolize run-autotools-aclocal \
- patch-autotools-libtool run-autotools-autoconf \
- run-autotools-autoheader run-autotools-automake
+ run-autotools-autoconf run-autotools-autoheader \
+ run-autotools-automake
run-autotools:: run-autotools-libtoolize run-autotools-aclocal \
- patch-autotools-libtool run-autotools-autoconf \
- run-autotools-autoheader run-autotools-automake
+ run-autotools-autoconf run-autotools-autoheader \
+ run-autotools-automake
.endif
.if !target(run-autotools-aclocal)
@@ -385,20 +357,6 @@ run-autotools-libtoolize:
. endif
.endif
-.if !target(patch-autotools-libtool)
-patch-autotools-libtool::
-. if defined(_AUTOTOOL_rule_libtool)
- @for file in ${LIBTOOLFILES}; do \
- ${REINPLACE_CMD} -e \
- "/^ltmain=/!s|\$$ac_aux_dir/ltmain.sh|${LIBTOOLFLAGS} ${LTMAIN}|g; \
- /^LIBTOOL=/s|\$$(top_builddir)/libtool|${LIBTOOL}|g" \
- ${PATCH_WRKSRC}/$$file; \
- done;
-. else
- @${DO_NADA}
-. endif
-.endif
-
#---------------------------------------------------------------------------
# Reduce patch churn by auto-substituting data from AUTOTOOLS_VARS
# into the correct places. Code shamelessly stolen from PLIST_SUB.
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index 6e1a72fceb31..a371357b6b4a 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -68,8 +68,8 @@ Gnome_Pre_Include= bsd.gnome.mk
#
# non-version specific components
-_USE_GNOME_ALL= esound intlhack intltool introspection ltasneededhack lthack \
- ltverhack gnomehack referencehack gnomehier gnomemimedata \
+_USE_GNOME_ALL= esound intlhack intltool introspection \
+ gnomehack referencehack gnomehier gnomemimedata \
gnomeprefix
# GNOME 1 components
@@ -116,9 +116,6 @@ gnomehack_PRE_PATCH= ${FIND} ${WRKSRC} -name "${GNOME_MAKEFILEIN}*" -type f | ${
referencehack_PRE_PATCH= ${FIND} ${WRKSRC} -name "Makefile.in" -type f | ${XARGS} ${REINPLACE_CMD} -e \
"s|test \"\$$\$$installfiles\" = '\$$(srcdir)/html/\*'|:|"
-lthack_PRE_PATCH= ${FIND} ${WRKSRC} -name "configure" -type f | ${XARGS} ${REINPLACE_CMD} -e \
- '/^LIBTOOL_DEPS="$$ac_aux_dir\/ltmain.sh"$$/s|$$|; $$ac_aux_dir/ltconfig $$LIBTOOL_DEPS;|'
-
GNOME_MTREE_FILE?= ${LOCALBASE}/etc/mtree/BSD.gnome.dist
gnomehier_DETECT= ${GNOME_MTREE_FILE}
gnomehier_RUN_DEPENDS= ${gnomehier_DETECT}:${PORTSDIR}/misc/gnomehier
@@ -698,61 +695,6 @@ _USE_GNOME+= ${${component}_USE_GNOME_IMPL} ${component}
PLIST_SUB+= GTK2_VERSION="${GTK2_VERSION}" \
GTK3_VERSION="${GTK3_VERSION}"
-# Then handle the ltverhack component (it has to be done here, because
-# we rely on some bsd.autotools.mk variables, and bsd.autotools.mk is
-# included in the post-makefile section).
-.if defined(_AUTOTOOL_libtool)
-lthacks_CONFIGURE_ENV= ac_cv_path_DOLT_BASH=
-lthacks_PRE_PATCH= \
- ${CP} -pf ${LTMAIN} ${WRKDIR}/gnome-ltmain.sh && \
- ${CP} -pf ${LIBTOOL} ${WRKDIR}/gnome-libtool && \
- for file in ${LIBTOOLFILES}; do \
- ${REINPLACE_CMD} -e \
- '/^ltmain=/!s|$$ac_aux_dir/ltmain\.sh|${LIBTOOLFLAGS} ${WRKDIR}/gnome-ltmain.sh|g; \
- /^LIBTOOL=/s|$$(top_builddir)/libtool|${WRKDIR}/gnome-libtool|g' \
- ${PATCH_WRKSRC}/$$file; \
- done;
-.else
-. if ${USE_GNOME:Mltasneededhack}!=""
-IGNORE= cannot install: ${PORTNAME} uses the ltasneededhack GNOME component but does not use libtool
-. endif
-.endif
-
-.if ${USE_GNOME:Mltverhack\:*:C/^[^:]+:([^:]+).*/\1/}==""
-ltverhack_LIB_VERSION= major=.`expr $$current - $$age`
-.else
-ltverhack_LIB_VERSION= major=".${USE_GNOME:Mltverhack\:*:C/^[^:]+:([^:]+).*/\1/}"
-.endif
-
-.if defined(USE_AUTOTOOLS) && ${USE_AUTOTOOLS:Mlibtool*}
-ltverhack_PATCH_DEPENDS=${LIBTOOL_DEPENDS}
-ltverhack_PATCH_FILES= ../gnome-ltmain.sh ../gnome-libtool
-.else
-ltverhack_PATCH_FILES?= ltmain.sh libtool
-.endif
-
-ltverhack_PRE_PATCH= \
- for file in ${ltverhack_PATCH_FILES}; do \
- if [ -f ${WRKSRC}/$$file ]; then \
- ${REINPLACE_CMD} -e \
- '/freebsd-elf)/,/;;/ s|major="\.$$current"|${ltverhack_LIB_VERSION}|; \
- /freebsd-elf)/,/;;/ s|versuffix="\.$$current"|versuffix="$$major"|' \
- -e \
- '/freebsd-elf)/,/;;/ s|major=\.$$current|${ltverhack_LIB_VERSION}|; \
- /freebsd-elf)/,/;;/ s|versuffix=\.$$current|versuffix="$$major"|' \
- ${WRKSRC}/$$file; \
- fi; \
- done
-
-ltasneededhack_PATCH_DEPENDS=${LIBTOOL_DEPENDS}
-ltasneededhack_PRE_PATCH= \
- if [ -f ${WRKDIR}/gnome-libtool ]; then \
- ${REINPLACE_CMD} -e \
- '/^archive_cmds=/s/-shared/-shared -Wl,--as-needed/ ; \
- /^archive_expsym_cmds=/s/-shared/-shared -Wl,--as-needed/' \
- ${WRKDIR}/gnome-libtool; \
- fi
-
# Set USE_CSTD for all ports that depend on glib12
.if defined(_USE_GNOME) && !empty(_USE_GNOME:Mglib12)
USE_CSTD= gnu89
@@ -762,22 +704,6 @@ USE_CSTD= gnu89
# exist in ${_USE_GNOME} and set variables accordingly
.ifdef _USE_GNOME
-. if ${USE_GNOME:Mltasneededhack}!= ""
-_GNOME_NEED_LIBTOOL=1
-. endif
-
-# this is splitted out from the above entry because fmake trows a fit otherwise
-. if defined(USE_AUTOTOOLS) && ${USE_AUTOTOOLS:Mlibtool*}
-. if ${USE_GNOME:Mltverhack*}!= ""
-_GNOME_NEED_LIBTOOL=1
-. endif
-. endif
-
-. if defined(_GNOME_NEED_LIBTOOL)
-GNOME_PRE_PATCH+= ${lthacks_PRE_PATCH}
-CONFIGURE_ENV+= ${lthacks_CONFIGURE_ENV}
-. endif
-
. for component in ${_USE_GNOME:O:u}
. if defined(${component}_PATCH_DEPENDS)
PATCH_DEPENDS+= ${${component}_PATCH_DEPENDS}
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index a45dce2e4d3d..d980bab6d279 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -106,16 +106,6 @@ DEV_ERROR+= "USE_PYDISTUTILS=easy_install is no longer supported, please use USE
DEV_WARNING+= "PYDISTUTILS_PKGNAME has no effect for USE_PYDISTUTILS=yes and PYDISTUTILS_AUTOPLIST=yes"
.endif
-.if defined(USE_AUTOTOOLS)
-. if ${USE_AUTOTOOLS:Mlibtool} || ${USE_AUTOTOOLS:Mlibtool\:env}
-DEV_WARNING+= "USE_AUTOTOOLS=libtool is deprecated, please use USES=libtool"
-. endif
-.endif
-
-.if defined(USE_GNOME) && ${USE_GNOME:Mltverhack*}
-DEV_WARNING+= "USE_GNOME=ltverhack is deprecated, please use USES=libtool"
-.endif
-
.if defined(USE_PYTHON) && (${USE_PYTHON} == "yes" || ${USE_PYTHON:C/[-0-9.+]*//} == "")
_PYTHON_VAL := ${USE_PYTHON}
.if ${_PYTHON_VAL} != "yes"