aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-05-31 12:58:43 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-05-31 12:58:43 +0000
commit503873a8702462812bcbf00e89f55009446fcc0e (patch)
tree52e1ecac424adb4a75339b8964b7efbb10176625
parent1fbc65378b4fe8302f15b8366def8fe579a63a48 (diff)
downloadports-503873a8702462812bcbf00e89f55009446fcc0e.tar.gz
ports-503873a8702462812bcbf00e89f55009446fcc0e.zip
Notes
-rw-r--r--misc/Makefile1
-rw-r--r--misc/wmfirew/Makefile23
-rw-r--r--misc/wmfirew/distinfo1
-rw-r--r--misc/wmfirew/files/patch-Makefile38
-rw-r--r--misc/wmfirew/pkg-comment1
-rw-r--r--misc/wmfirew/pkg-descr4
-rw-r--r--misc/wmfirew/pkg-plist1
7 files changed, 69 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 6659bdbed05c..060fc3e650d9 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -286,6 +286,7 @@
SUBDIR += wmScoreBoard
SUBDIR += wmcp
SUBDIR += wmessage
+ SUBDIR += wmfirew
SUBDIR += wmjulia
SUBDIR += wmmand
SUBDIR += wmpal
diff --git a/misc/wmfirew/Makefile b/misc/wmfirew/Makefile
new file mode 100644
index 000000000000..bcc2bf9dfdcd
--- /dev/null
+++ b/misc/wmfirew/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: wmfirew
+# Date created: 16 May 2002
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmfirew
+PORTVERSION= 0.20
+CATEGORIES= misc windowmaker afterstep
+MASTER_SITES= http://web.novalis.org/programs/
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}.app/${PORTNAME}
+USE_GMAKE= yes
+USE_XPM= yes
+USE_X_PREFIX= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/wmfirew/distinfo b/misc/wmfirew/distinfo
new file mode 100644
index 000000000000..02a1cac7335a
--- /dev/null
+++ b/misc/wmfirew/distinfo
@@ -0,0 +1 @@
+MD5 (wmfirew-0.20.tar.gz) = 0862f9513a71d60d9c6535780f37b5f1
diff --git a/misc/wmfirew/files/patch-Makefile b/misc/wmfirew/files/patch-Makefile
new file mode 100644
index 000000000000..ccb43e80f3d9
--- /dev/null
+++ b/misc/wmfirew/files/patch-Makefile
@@ -0,0 +1,38 @@
+$FreeBSD$
+
+--- Makefile.orig Thu May 16 12:16:40 2002
++++ Makefile Thu May 16 12:17:17 2002
+@@ -1,21 +1,20 @@
+-INCDIR = -I/usr/X11R6/include
+-LIBDIR = -L/usr/X11R6/lib
+-LIBS = -lXpm -lXext -lX11
+-OBJS = wmfirew.o ../wmgeneral/wmgeneral.o
++CC ?= gcc
++CFLAGS += -c -Wall
++INCDIR = -I${X11BASE}/include
++LIBDIR = -L${X11BASE}/lib
++LIBS = -lXpm -lXext -lX11
++OBJS = wmfirew.o ../wmgeneral/wmgeneral.o
+
+ .c.o:
+- cc -c -g -O2 -Wall -D$(shell echo `uname -s`) $< -o $*.o $(INCDIR)
+-
+-all: wmfirew
++ ${CC} ${CFLAGS} ${INCDIR} -D${shell echo `uname -s`} $< -o $*.o
+
+ wmfirew: $(OBJS)
+- cc -o wmfirew $^ $(LIBDIR) $(LIBS)
++ ${CC} -o wmfirew $^ ${LIBDIR} ${LIBS}
++
++all: wmfirew
+
+ clean:
+- for i in $(OBJS) ; do \
++ for i in ${OBJS}; do \
+ rm -f $$i; \
+ done
+- rm -f wmfirew
+-
+-install:
+- mv wmfirew /usr/local/bin
++ rm -f wmfirew core
diff --git a/misc/wmfirew/pkg-comment b/misc/wmfirew/pkg-comment
new file mode 100644
index 000000000000..be5d93525b58
--- /dev/null
+++ b/misc/wmfirew/pkg-comment
@@ -0,0 +1 @@
+A dockapp that shows fireworks in action
diff --git a/misc/wmfirew/pkg-descr b/misc/wmfirew/pkg-descr
new file mode 100644
index 000000000000..3b4e79ec8baf
--- /dev/null
+++ b/misc/wmfirew/pkg-descr
@@ -0,0 +1,4 @@
+A WindowMaker/AfterStep dockable app, showing fireworks in action.
+Not particularly useful, but looks kinda cool.
+
+WWW: http://web.novalis.org/
diff --git a/misc/wmfirew/pkg-plist b/misc/wmfirew/pkg-plist
new file mode 100644
index 000000000000..5053cbcc21e8
--- /dev/null
+++ b/misc/wmfirew/pkg-plist
@@ -0,0 +1 @@
+bin/wmfirew