aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2011-07-17 11:18:47 +0000
committerHiroki Sato <hrs@FreeBSD.org>2011-07-17 11:18:47 +0000
commit5b99c06b791f78a9cd39e73a84386d2283f5000a (patch)
tree5397e3ee33932527711a9c8156475857f6b9f0f0
parent212efffcb50e879ffb42a95a239e07121d6a9f3e (diff)
Fix a build failure when vaglib and/or lvga256 is specified.
PR: ports/158958
Notes
Notes: svn path=/head/; revision=277839
-rw-r--r--print/ghostscript9/Makefile2
-rw-r--r--print/ghostscript9/files/patch-base-gdevl256.c15
-rw-r--r--print/ghostscript9/files/patch-base-gdevvglb.c15
3 files changed, 31 insertions, 1 deletions
diff --git a/print/ghostscript9/Makefile b/print/ghostscript9/Makefile
index 5c31f3742b84..1536e1666c90 100644
--- a/print/ghostscript9/Makefile
+++ b/print/ghostscript9/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript9
PORTVERSION= 9.02
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= http://ghostscript.com/releases/:gs_srcs \
SF/ghostscript/files/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
diff --git a/print/ghostscript9/files/patch-base-gdevl256.c b/print/ghostscript9/files/patch-base-gdevl256.c
new file mode 100644
index 000000000000..d2fcd1b42baa
--- /dev/null
+++ b/print/ghostscript9/files/patch-base-gdevl256.c
@@ -0,0 +1,15 @@
+--- base/gdevl256.c.orig 2011-07-17 19:57:32.000000000 +0900
++++ base/gdevl256.c 2011-07-17 19:57:39.000000000 +0900
+@@ -302,12 +302,3 @@
+ gl_line(x0, y0, x1, y1, color);
+ return 0;
+ }
+-
+-#ifdef GS_DEVS_SHARED
+-extern void gs_lib_register_device(const gx_device *dev);
+-void
+-gs_shared_init(void)
+-{
+- gs_lib_register_device(&gs_lvga256_device);
+-}
+-#endif
diff --git a/print/ghostscript9/files/patch-base-gdevvglb.c b/print/ghostscript9/files/patch-base-gdevvglb.c
new file mode 100644
index 000000000000..8f7d239726ff
--- /dev/null
+++ b/print/ghostscript9/files/patch-base-gdevvglb.c
@@ -0,0 +1,15 @@
+--- base/gdevvglb.c.orig 2011-07-17 19:56:33.000000000 +0900
++++ base/gdevvglb.c 2011-07-17 19:57:10.000000000 +0900
+@@ -367,12 +367,3 @@
+ }
+ return 0;
+ }
+-
+-#ifdef GS_DEVS_SHARED
+-extern void gs_lib_register_device(const gx_device *dev);
+-void
+-gs_shared_init(void)
+-{
+- gs_lib_register_device(&gs_vgalib_device);
+-}
+-#endif