aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2011-01-24 22:41:25 +0000
committerThierry Thomas <thierry@FreeBSD.org>2011-01-24 22:41:25 +0000
commit5fc8670fdcc21d9083e72f7ed7ef3e58cdd2bb34 (patch)
tree63e4560f78ef1e97bfd47cc21da1c0f4f75d6e21
parentd417ce8c009b147c8e1bbfb5a0753b8bfaef82cf (diff)
downloadports-5fc8670fdcc21d9083e72f7ed7ef3e58cdd2bb34.tar.gz
ports-5fc8670fdcc21d9083e72f7ed7ef3e58cdd2bb34.zip
Notes
-rw-r--r--graphics/cimg/Makefile2
-rw-r--r--graphics/cimg/distinfo4
-rw-r--r--graphics/cimg/files/patch-examples::Makefile38
-rw-r--r--graphics/cimg/pkg-plist1
4 files changed, 30 insertions, 15 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 918117ecc666..239adbe058c9 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cimg
-PORTVERSION= 1.4.6
+PORTVERSION= 1.4.7
PORTEPOCH= 2
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index 52f40f4d2437..a753ef374a88 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cimg-1.4.6,2/CImg-1.4.6.zip) = 01f92f1b8a12ae45ca3c09fdca3aad0196abbb8a82d7c3952d83f5a82c6ae3b4
-SIZE (cimg-1.4.6,2/CImg-1.4.6.zip) = 10393478
+SHA256 (cimg-1.4.7,2/CImg-1.4.7.zip) = 5bd56677bda6891eeb9671e977d4e48460b9dfbf3126eb07301d2c96d8fb552a
+SIZE (cimg-1.4.7,2/CImg-1.4.7.zip) = 10452496
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 81d6002cb1cd..375c707faf7a 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,9 +1,9 @@
---- examples/Makefile.orig 2010-10-01 15:26:30.000000000 +0200
-+++ examples/Makefile 2010-10-03 15:09:36.000000000 +0200
+--- examples/Makefile.orig 2011-01-21 15:58:40.000000000 +0100
++++ examples/Makefile 2011-01-24 22:24:41.000000000 +0100
@@ -85,8 +85,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.4.6
+ CIMG_VERSION = 1.4.7
-X11PATH = /usr/X11R6
-CC = g++
+#X11PATH = /usr/X11R6
@@ -38,23 +38,21 @@
# Flags to enable fast image display, using the XSHM library (when using X11).
# !!! Seems to randomly crash when used on MacOSX, so do not use it on MacOSX !!!
-@@ -175,13 +175,13 @@
+@@ -175,12 +175,12 @@
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
-CIMG_EXR_CFLAGS = -Dcimg_use_openexr -I/usr/include/OpenEXR
-+CIMG_EXR_CFLAGS = -Dcimg_use_openexr -I$(LOCALBASE)/include/OpenEXR
++CIMG_EXR_CFLAGS = -Dcimg_use_openexr -I/$(LOCALBASE)/include/OpenEXR
CIMG_EXR_LDFLAGS = -lIlmImf
# Flags to enable native support for various video files, using the FFMPEG library.
# ( http://www.ffmpeg.org/ )
--CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -I/usr/include/libavcodec -I/usr/include/libavformat -I/usr/include/libswscale
--CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
-+#CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -I$(LOCALBASE)/include/libavcodec -I$(LOCALBASE)/include/libavformat -I$(LOCALBASE)/include/libswscale
-+#CIMG_FFMPEG_LDFLAGS = -L$(LOCALBASE)/lib -lavcodec -lavformat -lswscale
+-CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/usr/include/libavcodec -I/usr/include/libavformat -I/usr/include/libswscale -I/usr/include/ffmpeg
++CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/$(LOCALBASE)/include/libavcodec -I/$(LOCALBASE)/include/libavformat -I/$(LOCALBASE)/include/libswscale -I/$(LOCALBASE)/include/ffmpeg
+ CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
- # ( http://www.zlib.net/ )
@@ -190,8 +190,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.
@@ -97,7 +95,25 @@
@echo " > solaris : Sun Solaris target, X11 display, optimizations disabled."
@echo " > dsolaris : Sun Solaris target, X11 display, debug mode."
@echo " > osolaris : Sun Solaris target, X11 display, optimizations enabled."
-@@ -420,6 +426,56 @@
+@@ -288,7 +294,7 @@
+ $(CC) -o gmic_gimp.o -c gmic.cpp -Dcimg_build -Dgmic_gimp -Dgmic_minimal $(CIMG_OPT_CFLAGS) $(CIMG_FFTW3_CFLAGS) $(CIMG_PNG_CFLAGS)
+
+ gmic_gimp: gmic_gimp.o gmic_gimp.cpp
+- $(CC) -o $(EXEPFX)gmic_gimp gmic_gimp.cpp gmic_gimp.o -Dcimg_build `gimptool-2.0 --cflags` `gimptool-2.0 --libs` -lpthread $(CIMG_OPT_FLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_PNG_LDFLAGS) $(CIMG_GIMP_CFLAGS)
++ $(CC) -o $(EXEPFX)gmic_gimp gmic_gimp.cpp gmic_gimp.o -Dcimg_build `gimptool-2.0 --cflags` `gimptool-2.0 --libs` $(CIMG_OPT_FLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_PNG_LDFLAGS) $(CIMG_GIMP_CFLAGS) $(PTHREAD_LIBS)
+
+ # Specific targets for 'gmic'.
+ gmic_def: gmic_def.gmic
+@@ -328,7 +334,7 @@
+ gmic_uint.o gmic_int.o gmic_float.o gmic_double.o $(CFLAGS) $(LDFLAGS) $(CONF_CFLAGS) $(CONF_LDFLAGS)
+
+ gmic_minimal:
+- $(CC) -o $(EXEPFX)gmic gmic.cpp -I.. -Dcimg_build -Dgmic_minimal -Dgmic_main -Dcimg_use_fftw3 -Dcimg_use_png -Dcimg_display=1 -I/usr/X11R6/include -g -W -Wall -ansi -pedantic -L/usr/X11R6/lib -lX11 -lpthread -lfftw3 -lpng -lz
++ $(CC) -o $(EXEPFX)gmic gmic.cpp -I.. -Dcimg_build -Dgmic_minimal -Dgmic_main -Dcimg_use_fftw3 -Dcimg_use_png -Dcimg_display=1 -I$(LOCALBASE)/X11R6/include -g -W -Wall -ansi -pedantic -L$(LOCALBASE)/X11R6/lib -lX11 -lfftw3 -lpng -lz $(PTHREAD_LIBS)
+
+ ifeq ($(STRIP_EXE),true)
+ strip $(EXEPFX)gmic
+@@ -414,6 +420,56 @@
"STRIP_EXE=true" \
all $(CIMG_EXTRA_FILES)
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index ab15f1d6c6bd..1d8487b95118 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -289,7 +289,6 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_index.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_isoline3d.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_isosurface3d.jpg
-%%PORTDOCS%%%%DOCSDIR%%/reference/ref_label_regions.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_map.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_noise.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_norm.jpg