aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2015-06-26 18:26:45 +0000
committerAlberto Villa <avilla@FreeBSD.org>2015-06-26 18:26:45 +0000
commit6697dd52e55bdc1e6395cb5fe49afd2b1e632aae (patch)
treebbddee889364e3ac35dae8623af75ce167a10d7a
parent3af9e3e58cd18f18164e05c46cd475132cb9a356 (diff)
downloadports-6697dd52e55bdc1e6395cb5fe49afd2b1e632aae.tar.gz
ports-6697dd52e55bdc1e6395cb5fe49afd2b1e632aae.zip
MFH: r390539
graphics/opencv: fix configure when EIGEN is off When EIGEN option is off, CMAKE_ARGS is reset, thus enabling build of tests and docs (causing some leftovers), and, should it be installed, linking against libdc1394 even when option DC1394 is off. PORTREVISION bump is needed to address the latter case. Meanwhile, re-enable make jobs. Differential Revision: https://reviews.freebsd.org/D2893 Reviewed by: jhale (maintainer) Approved by: jhale (maintainer) Approved by: portmgr
Notes
Notes: svn path=/branches/2015Q2/; revision=390659
-rw-r--r--graphics/opencv/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 6b80eb298d71..9f6d6efc3196 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= opencv
PORTVERSION= 2.4.9
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}library/${PORTNAME}-unix/${PORTVERSION}
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake pkgconfig zip
USE_LDCONFIG= yes
WANT_GSTREAMER= yes
-MAKE_JOBS_UNSAFE= yes
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON_sparc64= does not compile on sparc64
@@ -76,7 +75,7 @@ CMAKE_ARGS+= -DWITH_1394:BOOL=Off
BUILD_DEPENDS+= ${LOCALBASE}/include/eigen3/Eigen/Eigen:${PORTSDIR}/math/eigen3
CMAKE_ARGS+= -DWITH_EIGEN:BOOL=On
.else
-CMAKE_ARGS= -DWITH_EIGEN:BOOL=Off
+CMAKE_ARGS+= -DWITH_EIGEN:BOOL=Off
.endif
.if ${PORT_OPTIONS:MEXAMPLES}