aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-05-02 14:04:25 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-05-02 14:04:25 +0000
commit76a37c45de0e5d4c946998972548eb2bd3d22293 (patch)
treeb181d4e0b5b7e3369dbe22fcf592dbbd1257e468
parenta028b2ac22c450af4deb7c10784f89901ffad388 (diff)
downloadports-76a37c45de0e5d4c946998972548eb2bd3d22293.tar.gz
ports-76a37c45de0e5d4c946998972548eb2bd3d22293.zip
Notes
-rw-r--r--security/ike/Makefile23
-rw-r--r--security/ike/distinfo4
-rw-r--r--security/ike/files/patch-CMakeLists.txt23
-rw-r--r--security/ike/pkg-plist21
4 files changed, 25 insertions, 46 deletions
diff --git a/security/ike/Makefile b/security/ike/Makefile
index 7a1dad3dc6a0..5b6220039fb8 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= ike
-PORTVERSION= 2.1.7
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= security net
-MASTER_SITES= http://www.shrew.net/download/ike/
+MASTER_SITES= https://www.shrew.net/download/ike/
DISTNAME= ${PORTNAME}-${PORTVERSION}-release
EXTRACT_SUFX= .tbz2
@@ -22,6 +21,8 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
CMAKE_ARGS+= -DETCDIR:PATH="${PREFIX}/etc" \
+ -DBINDIR:PATH="${PREFIX}/bin" \
+ -DSBINDIR:PATH="${PREFIX}/sbin" \
-DLIBDIR:PATH="${PREFIX}/lib" \
-DMANDIR:PATH="${PREFIX}/man"
@@ -32,6 +33,7 @@ LDAP_DESC= Enable LDAP XAuth daemon support
.include <bsd.port.options.mk>
+MAN1= ikec.1
MAN5= iked.conf.5
MAN8= iked.8
@@ -50,8 +52,9 @@ CMAKE_ARGS+= -DNATT=YES
.if ${PORT_OPTIONS:MQTGUI}
CMAKE_ARGS+= -DQTGUI=YES
-USE_QT_VER= 3
-MAN1= ikea.1 ikec.1
+USE_QT_VER= 4
+USE_QT4= gui moc_build qmake_build rcc_build uic_build
+MAN1+= qikea.1 qikec.1
PLIST_SUB+= QTGUI=""
.else
PLIST_SUB+= QTGUI="@comment "
@@ -70,16 +73,6 @@ post-patch:
@sleep 3
. endif
.endif
- @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
- ${WRKSRC}/CMakeLists.txt
-
-post-build:
-# QT 3.3 UIC (User Interface Compiler) creates these, so remove them.
-# Otherwise x11-toolkits/qt33 would have to be patched, as Gentoo did.
-.for f in .qt_plugins_* qt_plugins_*
- @${RM} -f ${LOCALBASE}/etc/settings/${f}
-.endfor
- @${RMDIR} ${LOCALBASE}/etc/settings || ${TRUE}
post-install:
@if ! ${SYSCTL} -a | ${GREP} -q ipsec; then \
diff --git a/security/ike/distinfo b/security/ike/distinfo
index 1fda232359d5..6291e364dd96 100644
--- a/security/ike/distinfo
+++ b/security/ike/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ike-2.1.7-release.tbz2) = 28e64efcec165522a775657a6c2c2263a3d03a78b114f62f5e30f4d38602edba
-SIZE (ike-2.1.7-release.tbz2) = 581284
+SHA256 (ike-2.2.0-release.tbz2) = 94a62f9a13dbf37c2ccba168cbc21c4a663d0f4d36aa0cf04fdac7061ba8dc48
+SIZE (ike-2.2.0-release.tbz2) = 671927
diff --git a/security/ike/files/patch-CMakeLists.txt b/security/ike/files/patch-CMakeLists.txt
deleted file mode 100644
index 0d259e2e6f4d..000000000000
--- a/security/ike/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
---- ./CMakeLists.txt.orig 2011-02-23 17:46:26.964357643 +0300
-+++ ./CMakeLists.txt 2011-02-23 17:56:25.405358356 +0300
-@@ -62,13 +62,13 @@
- # Path Option Checks
- #
-
--if( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
--
-- set(
-- CMAKE_INSTALL_PREFIX
-- "/usr" )
--
--endif( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
-+#if( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
-+#
-+# set(
-+# CMAKE_INSTALL_PREFIX
-+# "/usr" )
-+#
-+#endif( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
-
- message(
- STATUS
diff --git a/security/ike/pkg-plist b/security/ike/pkg-plist
index 9ae22fbd5f7f..b93c681b5d25 100644
--- a/security/ike/pkg-plist
+++ b/security/ike/pkg-plist
@@ -1,10 +1,19 @@
@unexec if cmp -s %D/etc/iked.conf %D/etc/iked.conf.sample; then rm -f %D/etc/iked.conf; fi
etc/iked.conf.sample
@exec [ -f %D/etc/iked.conf ] || cp %D/etc/iked.conf.sample %D/etc/iked.conf
+bin/ikec
sbin/iked
-%%QTGUI%%bin/ikea
-%%QTGUI%%bin/ikec
-lib/libike.so
-lib/libike.so.2.1.7
-lib/libpfk.so
-lib/libpfk.so.2.1.7
+%%QTGUI%%bin/qikea
+%%QTGUI%%bin/qikec
+lib/libss_idb.so
+lib/libss_idb.so.2.2.0
+lib/libss_ike.so
+lib/libss_ike.so.2.2.0
+lib/libss_ip.so
+lib/libss_ip.so.2.2.0
+lib/libss_ith.so
+lib/libss_ith.so.2.2.0
+lib/libss_log.so
+lib/libss_log.so.2.2.0
+lib/libss_pfk.so
+lib/libss_pfk.so.2.2.0