aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-11 04:05:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-11 04:05:52 +0000
commit7f21765ca53eaf3a1fccb48ff2e8cf4fb959975a (patch)
treeef31276220c2032907672c60ee08bf4e79aac6b6
parent08d0acafb8c32cf74a736721334ebebb0fbc1b19 (diff)
downloadports-7f21765ca53eaf3a1fccb48ff2e8cf4fb959975a.tar.gz
ports-7f21765ca53eaf3a1fccb48ff2e8cf4fb959975a.zip
Notes
-rw-r--r--lang/tcl82/Makefile11
-rw-r--r--lang/tcl83/Makefile11
-rw-r--r--x11-toolkits/tk82/Makefile11
-rw-r--r--x11-toolkits/tk83/Makefile11
4 files changed, 24 insertions, 20 deletions
diff --git a/lang/tcl82/Makefile b/lang/tcl82/Makefile
index 975c02081cd8..61f165d640ab 100644
--- a/lang/tcl82/Makefile
+++ b/lang/tcl82/Makefile
@@ -28,11 +28,12 @@ MAKE_ENV= SHORT_TCL_VER=82
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
PLIST_SUB= TCL_VER=8.2 SHORT_TCL_VER=82
-OPTIONS= TCL82_MAN "Install tcl 8.2 manpages" off
+OPTIONS_DEFINE= TCL82_MAN
+TCL82_MAN_DESC= Install tcl 8.2 manpages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL82_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTCL82_MAN}
MAN1= tclsh.1
@@ -388,11 +389,11 @@ post-configure:
${WRKSRC}/tclConfig.sh
post-install:
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL82_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTCL82_MAN}
@cd ${WRKSRC} && ${MAKE} -f Makefile install-doc
.endif
test:
cd ${WRKSRC} && ${MAKE} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index a337243db424..8edb3dccb5a6 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -29,11 +29,12 @@ TCL_VER= 8.3
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=83
-OPTIONS= TCL83_MAN "Install tcl 8.3 manpages" off
+OPTIONS_DEFINE= TCL83_MAN
+TCL83_MAN_DESC= Install tcl 8.3 manpages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL83_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTCL83_MAN}
MAN1= tclsh.1
@@ -437,11 +438,11 @@ post-configure:
post-install:
${INSTALL_DATA} ${FILESDIR}/koi8-u.enc \
${PREFIX}/lib/tcl${TCL_VER}/encoding/
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL83_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTCL83_MAN}
@cd ${WRKSRC} && ${MAKE} -f Makefile install-doc
.endif
test:
cd ${WRKSRC} && ${MAKE} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/tk82/Makefile b/x11-toolkits/tk82/Makefile
index 22f33d30cc8f..e38f5f70f8b7 100644
--- a/x11-toolkits/tk82/Makefile
+++ b/x11-toolkits/tk82/Makefile
@@ -35,11 +35,12 @@ PLIST_SUB= TK_VER=${TK_VER} SHORT_TK_VER=${SHORT_TK_VER}
TCL82_PORT?= lang/tcl82
MANCOMPRESSED= no
-OPTIONS= TK82_MAN "Install tk 8.2 manpages" off
+OPTIONS_DEFINE= TK82_MAN
+TK82_MAN_DESC= Install tk 8.2 manpages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TK82_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTK82_MAN}
MAN1= wish.1
MAN3= 3DBorder.3 BindTable.3 CanvPsY.3 CanvTkwin.3 CanvTxtInfo.3 \
@@ -321,11 +322,11 @@ post-configure:
post-install:
${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/tk${TK_VER}/
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TK82_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTK82_MAN}
@cd ${WRKSRC} && ${MAKE} -f Makefile install-doc
.endif
test:
cd ${WRKSRC}; make test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/tk83/Makefile b/x11-toolkits/tk83/Makefile
index 79cc4dc1eb14..a774d4898663 100644
--- a/x11-toolkits/tk83/Makefile
+++ b/x11-toolkits/tk83/Makefile
@@ -36,11 +36,12 @@ NOPRECIOUSMAKEVARS= Too many _MLINKS for README.html
TCL83_PORT?= lang/tcl83
MANCOMPRESSED= no
-OPTIONS= TK83_MAN "Install tk 8.3 manpages" off
+OPTIONS_DEFINE= TK83_MAN
+TK82_MAN_DESC= Install tk 8.3 manpages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TK83_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTK83_MAN}
MAN1= wish.1
MAN3= 3DBorder.3 AddOption.3 BindTable.3 CanvPsY.3 CanvTkwin.3 \
@@ -338,11 +339,11 @@ post-configure:
post-install:
${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/tk${TK_VER}/
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TK83_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTK83_MAN}
@cd ${WRKSRC} && ${MAKE} -f Makefile install-doc
.endif
test:
cd ${WRKSRC}; make test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>