aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 09:08:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 09:08:55 +0000
commit9aa75968e408a22b75e6cc6cba16ebcb446e7cc6 (patch)
tree3be754d1d28e354f15d02b450db3fd17b29603a4
parent8258baa18011a026ae54f2eaaad59f120b8acb6e (diff)
downloadports-9aa75968e408a22b75e6cc6cba16ebcb446e7cc6.tar.gz
ports-9aa75968e408a22b75e6cc6cba16ebcb446e7cc6.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBD-Excel/Makefile36
-rw-r--r--databases/p5-DBD-Excel/distinfo1
-rw-r--r--databases/p5-DBD-Excel/pkg-comment1
-rw-r--r--databases/p5-DBD-Excel/pkg-descr5
-rw-r--r--databases/p5-DBD-Excel/pkg-plist19
6 files changed, 63 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 90ebc877a23f..b41f27b43e83 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -70,6 +70,7 @@
SUBDIR += p5-CDB_File-Generator
SUBDIR += p5-Class-DBI
SUBDIR += p5-DBD-CSV
+ SUBDIR += p5-DBD-Excel
SUBDIR += p5-DBD-InterBase
SUBDIR += p5-DBD-mysql
SUBDIR += p5-DBD-ODBC
diff --git a/databases/p5-DBD-Excel/Makefile b/databases/p5-DBD-Excel/Makefile
new file mode 100644
index 000000000000..e0e6b3c059a1
--- /dev/null
+++ b/databases/p5-DBD-Excel/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: DBD::Excel
+# Date created: 24 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-Excel
+PORTVERSION= 0.05
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
+ ${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
+ ${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}
+PERL_CONFIGURE= yes
+
+MAN3= DBD::Excel.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Excel/distinfo b/databases/p5-DBD-Excel/distinfo
new file mode 100644
index 000000000000..8bb9a36804f8
--- /dev/null
+++ b/databases/p5-DBD-Excel/distinfo
@@ -0,0 +1 @@
+MD5 (DBD-Excel-0.05.tar.gz) = 7615d795c6bc01678eb305276e1d0bc2
diff --git a/databases/p5-DBD-Excel/pkg-comment b/databases/p5-DBD-Excel/pkg-comment
new file mode 100644
index 000000000000..333c9baf29da
--- /dev/null
+++ b/databases/p5-DBD-Excel/pkg-comment
@@ -0,0 +1 @@
+A class for DBI drivers that acts on Excel files
diff --git a/databases/p5-DBD-Excel/pkg-descr b/databases/p5-DBD-Excel/pkg-descr
new file mode 100644
index 000000000000..aa8a8ed6442b
--- /dev/null
+++ b/databases/p5-DBD-Excel/pkg-descr
@@ -0,0 +1,5 @@
+A class for DBI drivers that acts on Excel files
+
+WWW: http://search.cpan.org/search?dist=DBD-Excel
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/databases/p5-DBD-Excel/pkg-plist b/databases/p5-DBD-Excel/pkg-plist
new file mode 100644
index 000000000000..2527af43a4b5
--- /dev/null
+++ b/databases/p5-DBD-Excel/pkg-plist
@@ -0,0 +1,19 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/Excel/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/DBD/Excel.pm
+%%PORTDOCS%%share/examples/DBD-Excel/README
+%%PORTDOCS%%share/examples/DBD-Excel/dbdtest.xls
+%%PORTDOCS%%share/examples/DBD-Excel/newxl.xls
+%%PORTDOCS%%share/examples/DBD-Excel/res_hidden
+%%PORTDOCS%%share/examples/DBD-Excel/res_testj
+%%PORTDOCS%%share/examples/DBD-Excel/res_tex
+%%PORTDOCS%%share/examples/DBD-Excel/res_texj
+%%PORTDOCS%%share/examples/DBD-Excel/testj.pl
+%%PORTDOCS%%share/examples/DBD-Excel/testj.xls
+%%PORTDOCS%%share/examples/DBD-Excel/tex.pl
+%%PORTDOCS%%share/examples/DBD-Excel/texj.pl
+%%PORTDOCS%%share/examples/DBD-Excel/thidden.pl
+%%PORTDOCS%%share/examples/DBD-Excel/thidden.xls
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DBD 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/Excel 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD 2>/dev/null || true
+%%PORTDOCS%%@unexec rmdir %D/share/examples/DBD-Excel 2>/dev/null || true