aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 01:01:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 01:01:14 +0000
commitb8cf41f0328fff24b5ad86131191501239c3c95d (patch)
tree76113799436e719cb1d1e15bf70ad1cbe0324f09
parent5f7de065b44156c1adf89a8d177b64d937c5ccc5 (diff)
downloadports-b8cf41f0328fff24b5ad86131191501239c3c95d.tar.gz
ports-b8cf41f0328fff24b5ad86131191501239c3c95d.zip
MFH: r387865
- Fix shebangs - Strip library Approved by: portmgr blanket Approved by: ports-secteam (shebang fix blanket)
Notes
Notes: svn path=/branches/2015Q2/; revision=389800
-rw-r--r--devel/p5-Locale-libintl/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/devel/p5-Locale-libintl/Makefile b/devel/p5-Locale-libintl/Makefile
index fc29aa6f8de6..794c92c6bfc2 100644
--- a/devel/p5-Locale-libintl/Makefile
+++ b/devel/p5-Locale-libintl/Makefile
@@ -4,6 +4,7 @@
PORTNAME= Locale-libintl
PORTVERSION= 1.23
PORTREVISION= 2
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,7 +15,20 @@ COMMENT= Internationalization library for Perl
LICENSE= LGPL21
-USES= gettext perl5
+USES= gettext perl5 shebangfix
+SHEBANG_FILES= lib/Locale/Messages.pm \
+ lib/Locale/TextDomain.pm \
+ lib/Locale/gettext_dumb.pm \
+ lib/Locale/gettext_pp.pm \
+ lib/Locale/gettext_xs.pod
+SHEBANG_LANG= false
+false_OLD_CMD= /bin/false
+false_CMD= /usr/bin/false
USE_PERL5= configure
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Locale/gettext_xs/gettext_xs.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Locale/gettext_xs/gettext_xs.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Locale/gettext_xs/gettext_xs.so
+
.include <bsd.port.mk>