aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-01-04 19:00:06 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-01-04 19:00:06 +0000
commitdca2826dc7a4b2ca4644323ccdea48e8b74e6276 (patch)
tree98ea279e41e071195841868a5f8e326cbf7a713c
parent6da68fa3abfcd53e674fe4b3d6c44975091b154c (diff)
downloadports-dca2826dc7a4b2ca4644323ccdea48e8b74e6276.tar.gz
ports-dca2826dc7a4b2ca4644323ccdea48e8b74e6276.zip
Notes
-rw-r--r--emulators/wine-devel/Makefile8
-rw-r--r--emulators/wine/Makefile8
2 files changed, 16 insertions, 0 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 9d8fadc7f70f..a1340d34581b 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -44,6 +44,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
+ LDAP "Use LDAP" Off \
LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
.include <bsd.port.pre.mk>
@@ -62,6 +63,13 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --without-hal
.endif
+.ifdef WITH_LDAP
+CONFIGURE_ARGS+= --with-ldap
+USE_OPENLDAP= yes
+.else
+CONFIGURE_ARGS+= --without-ldap
+.endif
+
.ifdef WITH_LIBXSLT
CONFIGURE_ARGS+= --with-xslt
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 9d8fadc7f70f..a1340d34581b 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -44,6 +44,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
+ LDAP "Use LDAP" Off \
LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
.include <bsd.port.pre.mk>
@@ -62,6 +63,13 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --without-hal
.endif
+.ifdef WITH_LDAP
+CONFIGURE_ARGS+= --with-ldap
+USE_OPENLDAP= yes
+.else
+CONFIGURE_ARGS+= --without-ldap
+.endif
+
.ifdef WITH_LIBXSLT
CONFIGURE_ARGS+= --with-xslt
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt