aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 01:15:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 01:15:12 +0000
commite050e0e43cd80691d159d37b6b4faa3ce72762a4 (patch)
treeeb3edcc4e8ac94a5672901d165ff6c21dc836389
parentb129947f570241c75087ebdd7aeee81f54d095e9 (diff)
downloadports-e050e0e43cd80691d159d37b6b4faa3ce72762a4.tar.gz
ports-e050e0e43cd80691d159d37b6b4faa3ce72762a4.zip
MFH: r388524
- Disable precompiled headers to fix build with old gcc on -current kernel - Regenerate patch with make-patch Approved by: ports-secteam (build fix blanket)
Notes
Notes: svn path=/branches/2015Q2/; revision=389803
-rw-r--r--games/bloodfrontier/files/patch-src_Makefile (renamed from games/bloodfrontier/files/patch-src-Makefile)15
1 files changed, 12 insertions, 3 deletions
diff --git a/games/bloodfrontier/files/patch-src-Makefile b/games/bloodfrontier/files/patch-src_Makefile
index 409866feee98..65e018ab7fc1 100644
--- a/games/bloodfrontier/files/patch-src-Makefile
+++ b/games/bloodfrontier/files/patch-src_Makefile
@@ -1,12 +1,12 @@
---- src/Makefile.orig 2009-11-25 14:52:58.000000000 +0300
-+++ src/Makefile 2013-09-14 03:43:17.632226100 +0400
+--- src/Makefile.orig 2009-11-25 11:52:58 UTC
++++ src/Makefile
@@ -1,5 +1,4 @@
#CXXFLAGS= -ggdb3
-CXXFLAGS= -O3 -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char
PLATFORM= $(shell uname -s)
-@@ -21,8 +20,8 @@
+@@ -21,8 +20,8 @@ WINDRES= windres
CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -Iinclude
CLIENT_LIBS= -mwindows -lmingw32 -Llib -lSDLmain -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
else
@@ -17,3 +17,12 @@
endif
ifeq ($(PLATFORM),Linux)
CLIENT_LIBS+= -lrt
+@@ -82,8 +81,6 @@ CLIENT_OBJS= \
+ game/server.o \
+ game/stf.o \
+ game/weapons.o
+-
+-CLIENT_PCH= shared/cube.h.gch engine/engine.h.gch game/game.h.gch
+
+ ifneq (,$(findstring MINGW,$(PLATFORM)))
+ SERVER_INCLUDES= -DSTANDALONE -DMASTERSERVER -DIRC $(INCLUDES) -Iinclude