aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-09 15:13:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-09 15:13:20 +0000
commitee4ec90809cef2f6bf819e52903e3f800d79472d (patch)
tree6e8d58c70ab2cdfd3d5feeb3d52051a65ab944d1
parent09cb71b0260dd8bef8688f15b8013b4e97c89f8f (diff)
downloadports-ee4ec90809cef2f6bf819e52903e3f800d79472d.tar.gz
ports-ee4ec90809cef2f6bf819e52903e3f800d79472d.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/log4cplus/Makefile45
-rw-r--r--devel/log4cplus/distinfo4
-rw-r--r--devel/log4cplus/files/patch-src-socketbuffer.cxx10
-rw-r--r--devel/log4cplus/pkg-descr10
-rw-r--r--devel/log4cplus/pkg-plist45
6 files changed, 115 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3d8bf6f0b2b2..cc27f77715cb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -498,6 +498,7 @@
SUBDIR += linux_kdump
SUBDIR += linuxthreads
SUBDIR += log4c
+ SUBDIR += log4cplus
SUBDIR += log4cpp
SUBDIR += log4j
SUBDIR += lwp
diff --git a/devel/log4cplus/Makefile b/devel/log4cplus/Makefile
new file mode 100644
index 000000000000..b349e2d40293
--- /dev/null
+++ b/devel/log4cplus/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: log4cplus
+# Date created: 16 November 2004
+# Whom: Petri Totterman <petri.totterman@hmv.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= log4cplus
+PORTVERSION= 1.0.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= log4cplus
+DISTFILES= log4cplus-${PORTVERSION}.tar.gz log4cplus-${PORTVERSION}-docs.tar.gz
+
+MAINTAINER= petri.totterman@hmv.fi
+COMMENT= A logging library for C++
+
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/license.apl ${PREFIX}/include/log4cplus
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/*.config ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/*.html ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_MAN} ${WRKSRC}/docs/html/*.html ${DOCSDIR}/html
+ ${INSTALL_MAN} ${WRKSRC}/docs/html/*.png ${DOCSDIR}/html
+ ${INSTALL_MAN} ${WRKSRC}/docs/html/doxygen.css ${DOCSDIR}/html
+ ${INSTALL_MAN} ${WRKSRC}/docs/html/graph_legend.dot ${DOCSDIR}/html
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/log4cplus/distinfo b/devel/log4cplus/distinfo
new file mode 100644
index 000000000000..06b2aedfcac4
--- /dev/null
+++ b/devel/log4cplus/distinfo
@@ -0,0 +1,4 @@
+MD5 (log4cplus-1.0.2.tar.gz) = 0924064f529fd9ac39bbda341ef87d43
+SIZE (log4cplus-1.0.2.tar.gz) = 539550
+MD5 (log4cplus-1.0.2-docs.tar.gz) = 8fd35fd445edaf6c4d21bd4b929fa89b
+SIZE (log4cplus-1.0.2-docs.tar.gz) = 878960
diff --git a/devel/log4cplus/files/patch-src-socketbuffer.cxx b/devel/log4cplus/files/patch-src-socketbuffer.cxx
new file mode 100644
index 000000000000..bf30895eb7d4
--- /dev/null
+++ b/devel/log4cplus/files/patch-src-socketbuffer.cxx
@@ -0,0 +1,10 @@
+--- src/socketbuffer.cxx.orig Fri Nov 21 22:23:29 2003
++++ src/socketbuffer.cxx Thu Dec 9 15:49:28 2004
+@@ -29,6 +29,7 @@
+
+ #include <log4cplus/helpers/socketbuffer.h>
+ #include <log4cplus/helpers/loglog.h>
++#include <arpa/inet.h>
+
+ #if !defined(_WIN32)
+ # include <netdb.h>
diff --git a/devel/log4cplus/pkg-descr b/devel/log4cplus/pkg-descr
new file mode 100644
index 000000000000..ed3e201194ea
--- /dev/null
+++ b/devel/log4cplus/pkg-descr
@@ -0,0 +1,10 @@
+This is a port of log4cplus, a simple-to-use C++ logging API providing
+thread-safe, flexible, and arbitrarily granular control over log management
+and configuration. It is modeled after the Java log4j API.
+
+Authors:
+Tad E. Smith, Michael CATANZARITI, Steighton Haley
+
+WWW: http://log4cplus.sourceforge.net
+
+-pbt
diff --git a/devel/log4cplus/pkg-plist b/devel/log4cplus/pkg-plist
new file mode 100644
index 000000000000..41f19a93eedf
--- /dev/null
+++ b/devel/log4cplus/pkg-plist
@@ -0,0 +1,45 @@
+include/log4cplus/appender.h
+include/log4cplus/config.h
+include/log4cplus/configurator.h
+include/log4cplus/consoleappender.h
+include/log4cplus/fileappender.h
+include/log4cplus/fstreams.h
+include/log4cplus/helpers/appenderattachableimpl.h
+include/log4cplus/helpers/loglog.h
+include/log4cplus/helpers/logloguser.h
+include/log4cplus/helpers/pointer.h
+include/log4cplus/helpers/property.h
+include/log4cplus/helpers/sleep.h
+include/log4cplus/helpers/socket.h
+include/log4cplus/helpers/socketbuffer.h
+include/log4cplus/helpers/stringhelper.h
+include/log4cplus/helpers/thread-config.h
+include/log4cplus/helpers/threads.h
+include/log4cplus/helpers/timehelper.h
+include/log4cplus/hierarchy.h
+include/log4cplus/hierarchylocker.h
+include/log4cplus/layout.h
+include/log4cplus/license.apl
+include/log4cplus/logger.h
+include/log4cplus/loggingmacros.h
+include/log4cplus/loglevel.h
+include/log4cplus/ndc.h
+include/log4cplus/nullappender.h
+include/log4cplus/socketappender.h
+include/log4cplus/spi/appenderattachable.h
+include/log4cplus/spi/factory.h
+include/log4cplus/spi/filter.h
+include/log4cplus/spi/loggerfactory.h
+include/log4cplus/spi/loggerimpl.h
+include/log4cplus/spi/loggingevent.h
+include/log4cplus/spi/objectregistry.h
+include/log4cplus/spi/rootlogger.h
+include/log4cplus/streams.h
+include/log4cplus/syslogappender.h
+include/log4cplus/tstring.h
+lib/liblog4cplus.a
+lib/liblog4cplus.so
+lib/liblog4cplus.so.2
+@dirrm include/log4cplus/spi
+@dirrm include/log4cplus/helpers
+@dirrm include/log4cplus