aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-04 07:19:56 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-04 07:19:56 +0000
commitfcbd2acb27bbf4a355dbca49af027b65f4b023ac (patch)
tree431a616cd686d475c868c1f2804352af6faf26ee
parent30e317454821bc4a1c43314f0bca4297231a06c2 (diff)
downloadports-fcbd2acb27bbf4a355dbca49af027b65f4b023ac.tar.gz
ports-fcbd2acb27bbf4a355dbca49af027b65f4b023ac.zip
Notes
-rw-r--r--mail/mime-construct/Makefile3
-rw-r--r--mail/p5-Email-Address-Loose/Makefile3
-rw-r--r--mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile3
-rw-r--r--mail/p5-Email-Stuff/Makefile3
-rw-r--r--mail/p5-IMAP-Admin/Makefile3
-rw-r--r--mail/p5-Mail-IMAPClient/Makefile3
-rw-r--r--mail/p5-Mail-OpenDKIM/Makefile3
-rw-r--r--mail/p5-Mail-OpenRelay-Simple/Makefile3
-rw-r--r--mail/p5-Sendmail-AccessDB/Makefile3
-rw-r--r--mail/p5-WWW-GMail/Makefile3
-rw-r--r--mail/p5-WWW-Hotmail/Makefile3
-rw-r--r--mail/p5-ZConf-Mail/Makefile3
-rw-r--r--mail/pop-before-smtp/Makefile3
-rw-r--r--mail/prepflog/Makefile2
-rw-r--r--mail/sa-stats/Makefile2
-rw-r--r--mail/squirrelmail-avelsieve-plugin/Makefile3
-rw-r--r--mail/squirrelmail-login_notes-plugin/Makefile3
-rw-r--r--mail/squirrelmail-mark_read-plugin/Makefile3
-rw-r--r--mail/squirrelmail-password_forget-plugin/Makefile3
19 files changed, 36 insertions, 19 deletions
diff --git a/mail/mime-construct/Makefile b/mail/mime-construct/Makefile
index ebce67985001..d0b3dd87bc35 100644
--- a/mail/mime-construct/Makefile
+++ b/mail/mime-construct/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
p5-Proc-WaitStat>=0:${PORTSDIR}/devel/p5-Proc-WaitStat
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= mime-construct.1
diff --git a/mail/p5-Email-Address-Loose/Makefile b/mail/p5-Email-Address-Loose/Makefile
index 857c969e1784..489b8ff44047 100644
--- a/mail/p5-Email-Address-Loose/Makefile
+++ b/mail/p5-Email-Address-Loose/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-Email-Address>=1.88.9:${PORTSDIR}/mail/p5-Email-Address
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Address::Loose.3
diff --git a/mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile b/mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile
index df0166f2f648..1c2abd3efe27 100644
--- a/mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile
+++ b/mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-Email-Sender>=0.091660:${PORTSDIR}/mail/p5-Email-Sender \
p5-Net-SMTP-TLS-ButMaintained>=0.2:${PORTSDIR}/mail/p5-Net-SMTP-TLS-ButMaintained
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Sender::Transport::SMTP::TLS.3
diff --git a/mail/p5-Email-Stuff/Makefile b/mail/p5-Email-Stuff/Makefile
index 75e362cc5bde..f1c1d445c9a3 100644
--- a/mail/p5-Email-Stuff/Makefile
+++ b/mail/p5-Email-Stuff/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-prefork>=1.01:${PORTSDIR}/devel/p5-prefork \
p5-Email-Send>=2.185:${PORTSDIR}/mail/p5-Email-Send
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Stuff.3
diff --git a/mail/p5-IMAP-Admin/Makefile b/mail/p5-IMAP-Admin/Makefile
index 9e9d6a6d83a5..e7ac12c8ce04 100644
--- a/mail/p5-IMAP-Admin/Makefile
+++ b/mail/p5-IMAP-Admin/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= chifeng@gmail.com
COMMENT= Perl module for basic IMAP server administration
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= IMAP::Admin.3
EXAMPLESDIR= ${PREFIX}/share/examples/${UNIQUENAME}
diff --git a/mail/p5-Mail-IMAPClient/Makefile b/mail/p5-Mail-IMAPClient/Makefile
index 6123bfb90ffd..7e880036d78b 100644
--- a/mail/p5-Mail-IMAPClient/Makefile
+++ b/mail/p5-Mail-IMAPClient/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= </dev/null
MAN3= Mail::IMAPClient.3 \
diff --git a/mail/p5-Mail-OpenDKIM/Makefile b/mail/p5-Mail-OpenDKIM/Makefile
index 774b328133b4..05830237ed17 100644
--- a/mail/p5-Mail-OpenDKIM/Makefile
+++ b/mail/p5-Mail-OpenDKIM/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= opendkim>=2.5.0:${PORTSDIR}/mail/opendkim
TEST_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
p5-Test-Kwalitee>=0:${PORTSDIR}/devel/p5-Test-Kwalitee
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::OpenDKIM.3 Mail::OpenDKIM::DKIM.3 \
Mail::OpenDKIM::PrivateKey.3 Mail::OpenDKIM::Signature.3 \
diff --git a/mail/p5-Mail-OpenRelay-Simple/Makefile b/mail/p5-Mail-OpenRelay-Simple/Makefile
index 0195bb0f2d4f..636375dedf7c 100644
--- a/mail/p5-Mail-OpenRelay-Simple/Makefile
+++ b/mail/p5-Mail-OpenRelay-Simple/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Class-Accessor>=0.25:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Net-Telnet>=3.03:${PORTSDIR}/net/p5-Net-Telnet
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::OpenRelay::Simple.3
diff --git a/mail/p5-Sendmail-AccessDB/Makefile b/mail/p5-Sendmail-AccessDB/Makefile
index f4b3e1f0f6ac..162a2080ad6d 100644
--- a/mail/p5-Sendmail-AccessDB/Makefile
+++ b/mail/p5-Sendmail-AccessDB/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl5 interface to the Sendmail access.db list
BUILD_DEPENDS= p5-BerkeleyDB>=0:${PORTSDIR}/databases/p5-BerkeleyDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sendmail::AccessDB.3
diff --git a/mail/p5-WWW-GMail/Makefile b/mail/p5-WWW-GMail/Makefile
index 542be2ef04b9..cd1fcea24668 100644
--- a/mail/p5-WWW-GMail/Makefile
+++ b/mail/p5-WWW-GMail/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::GMail.3
diff --git a/mail/p5-WWW-Hotmail/Makefile b/mail/p5-WWW-Hotmail/Makefile
index 38b0e7e0f070..92e0a632b122 100644
--- a/mail/p5-WWW-Hotmail/Makefile
+++ b/mail/p5-WWW-Hotmail/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
p5-Mail-Audit>=0:${PORTSDIR}/mail/p5-Mail-Audit
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Hotmail.3
diff --git a/mail/p5-ZConf-Mail/Makefile b/mail/p5-ZConf-Mail/Makefile
index 3c62844e2572..3b76f742e2ca 100644
--- a/mail/p5-ZConf-Mail/Makefile
+++ b/mail/p5-ZConf-Mail/Makefile
@@ -32,7 +32,8 @@ BUILD_DEPENDS= p5-Config-Tiny>=0:${PORTSDIR}/devel/p5-Config-Tiny \
p5-ZConf>=0:${PORTSDIR}/net/p5-ZConf
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf::Mail.3
diff --git a/mail/pop-before-smtp/Makefile b/mail/pop-before-smtp/Makefile
index dd7b68433861..031aee1d3cd2 100644
--- a/mail/pop-before-smtp/Makefile
+++ b/mail/pop-before-smtp/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_RC_SUBR= pop-before-smtp
SUB_FILES= pkg-message
SUB_LIST= PERL=${PERL}
diff --git a/mail/prepflog/Makefile b/mail/prepflog/Makefile
index 911c1283f51b..b10db221cc83 100644
--- a/mail/prepflog/Makefile
+++ b/mail/prepflog/Makefile
@@ -17,7 +17,7 @@ COMMENT= Prepares logfiles in a sanitised format for pflogsumm and awstats
PLIST_FILES= bin/prepflog
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
diff --git a/mail/sa-stats/Makefile b/mail/sa-stats/Makefile
index b92d9e3d16d0..737cd14d8030 100644
--- a/mail/sa-stats/Makefile
+++ b/mail/sa-stats/Makefile
@@ -19,7 +19,7 @@ COMMENT= Generates top spam/ham rules fired for SpamAssassin installations
RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/mail/squirrelmail-avelsieve-plugin/Makefile b/mail/squirrelmail-avelsieve-plugin/Makefile
index e95569e6d6d4..49c603c5d968 100644
--- a/mail/squirrelmail-avelsieve-plugin/Makefile
+++ b/mail/squirrelmail-avelsieve-plugin/Makefile
@@ -9,7 +9,8 @@ DIST_SUBDIR= squirrelmail
MAINTAINER= neil@darlow.co.uk
COMMENT= SquirrelMail plugin for Server-Side Mail Filtering management
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
diff --git a/mail/squirrelmail-login_notes-plugin/Makefile b/mail/squirrelmail-login_notes-plugin/Makefile
index 9a2e3d6ee0a3..540763c2dd5e 100644
--- a/mail/squirrelmail-login_notes-plugin/Makefile
+++ b/mail/squirrelmail-login_notes-plugin/Makefile
@@ -13,7 +13,8 @@ LICENSE= GPLv2
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
diff --git a/mail/squirrelmail-mark_read-plugin/Makefile b/mail/squirrelmail-mark_read-plugin/Makefile
index 74192cdb0c26..4c10094d276f 100644
--- a/mail/squirrelmail-mark_read-plugin/Makefile
+++ b/mail/squirrelmail-mark_read-plugin/Makefile
@@ -11,7 +11,8 @@ MAINTAINER= itetcu@FreeBSD.org
COMMENT= Provides one-click link to mark read/unread all mails in a folder
USE_SM_COMPAT= YES
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
diff --git a/mail/squirrelmail-password_forget-plugin/Makefile b/mail/squirrelmail-password_forget-plugin/Makefile
index 645d4a03f426..12c0497efff3 100644
--- a/mail/squirrelmail-password_forget-plugin/Makefile
+++ b/mail/squirrelmail-password_forget-plugin/Makefile
@@ -15,7 +15,8 @@ COMMENT= Prevent reuse of login details by browsers at public terminals
RUN_DEPENDS= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>