aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-24 12:53:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-24 12:53:34 +0000
commit54b771cba36ce8650f03a72d873d0a497d01d20b (patch)
treec20b34ecc735b600fadb4eae2d6d5a61e53d9f1e
parent59fe15104b6d81bef7c3c15aa6e0a0752d9d4558 (diff)
downloadports-54b771cba36ce8650f03a72d873d0a497d01d20b.tar.gz
ports-54b771cba36ce8650f03a72d873d0a497d01d20b.zip
MFH: r404313
- Update to 2.1.8 - Add LICENSE_FILE - Use USES=autoreconf instead of USE_AUTOTOOLS=autoconf - Use USES=libedit - Silence patch and build messages Changes: https://www.ruby-lang.org/en/news/2015/12/16/ruby-2-1-8-released/ http://svn.ruby-lang.org/repos/ruby/tags/v2_1_8/ChangeLog Security: 3b50881d-1860-4721-aab1-503290e23f6c Differential Revision: https://reviews.freebsd.org/D4668 PR: 205487 Exp-run by: antoine Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2015Q4/; revision=404353
-rw-r--r--Mk/bsd.ruby.mk2
-rw-r--r--lang/ruby21/Makefile21
-rw-r--r--lang/ruby21/distinfo4
-rw-r--r--lang/ruby21/files/patch-ext_openssl_extconf.rb6
4 files changed, 18 insertions, 15 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 986ba564bc0c..5f64586efa0d 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -181,7 +181,7 @@ RUBY20= "" # PLIST_SUB helpers
#
# Ruby 2.1
#
-RUBY_RELVERSION= 2.1.7
+RUBY_RELVERSION= 2.1.8
RUBY_PORTREVISION= 0
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index dc79355859d6..9d05982c3aa7 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -15,6 +15,8 @@ COMMENT?= Object-oriented interpreted scripting language
LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
+LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
@@ -34,10 +36,9 @@ GNU_CONFIGURE= yes
# Keep this, else ruby will fail to load libraries dependent of libpthread.
LIBS+= -lpthread -L${LOCALBASE}/lib
MAKE_ENV= LC_ALL=C
-USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USES= cpe execinfo tar:xz
+USES= autoreconf cpe execinfo tar:xz
WRKSRC= ${RUBY_WRKSRC}
RUBY_VER= 2.1
@@ -45,6 +46,9 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= does not build
+
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES GMP RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
@@ -61,9 +65,8 @@ CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp
GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
-LIBEDIT_BUILD_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-prefix=${LOCALBASE}
-LIBEDIT_RUN_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
+LIBEDIT_USES= libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-prefix=${LOCALBASE}
@@ -138,20 +141,20 @@ post-patch:
# Remove modules we don't want
#
.for d in win32ole
- ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
+ @${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
# We get rake from ports.
.for d in bin/rake doc/rake lib/rake test/rake man/rake.1 lib/rake.rb
- ${RM} -rf ${BUILD_WRKSRC}/${d}
+ @${RM} -rf ${BUILD_WRKSRC}/${d}
.endfor
# We get the gem executable from ports.
- ${RM} ${BUILD_WRKSRC}/bin/gem
+ @${RM} ${BUILD_WRKSRC}/bin/gem
#
# Prepare modules we are wanting to build via external ports
#
.for d in gdbm tk
- ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
+ @${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
post-build:
@@ -166,7 +169,7 @@ post-build:
@${RB_SET_CONF_VAR} "INSTALL_DATA" "ENV['RB_USER_INSTALL'] ? '${INSTALL} ${COPY} -m ${SHAREMODE}' : '${INSTALL_DATA}'"
post-build-CAPIDOCS-on:
- ${FIND} ${WRKSRC}/doc -type d -empty -delete
+ @${FIND} ${WRKSRC}/doc -type d -empty -delete
pre-install:
${MKDIR} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}
diff --git a/lang/ruby21/distinfo b/lang/ruby21/distinfo
index 39e405d0b747..8b62cb6a9cc6 100644
--- a/lang/ruby21/distinfo
+++ b/lang/ruby21/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-2.1.7.tar.xz) = 225c067d9820fe52fcffbfb91d5b5243708a0b666b9929bea466e9379eb40ad7
-SIZE (ruby/ruby-2.1.7.tar.xz) = 9371208
+SHA256 (ruby/ruby-2.1.8.tar.xz) = 94eeae3b3e3ac93cfd205e1aaef4c5325227b7656cbb2fc1ee217618145dd19d
+SIZE (ruby/ruby-2.1.8.tar.xz) = 9382672
diff --git a/lang/ruby21/files/patch-ext_openssl_extconf.rb b/lang/ruby21/files/patch-ext_openssl_extconf.rb
index 2577c1c1ec13..0d837b15d4da 100644
--- a/lang/ruby21/files/patch-ext_openssl_extconf.rb
+++ b/lang/ruby21/files/patch-ext_openssl_extconf.rb
@@ -10,6 +10,6 @@
+have_func("SSLv23_method")
+have_func("SSLv23_server_method")
+have_func("SSLv23_client_method")
- have_func("TLSv1_1_method")
- have_func("TLSv1_1_server_method")
- have_func("TLSv1_1_client_method")
+ have_func("SSLv3_method")
+ have_func("SSLv3_server_method")
+ have_func("SSLv3_client_method")