aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-12-21 15:43:03 +0000
committerMark Felder <feld@FreeBSD.org>2015-12-21 15:43:03 +0000
commit9804854c3d7d75b1fbe78b069d9d64142be611fe (patch)
treeba0ff26b976bd01aa47e37a21e5eb33c5ca998ea
parent2143ab99a510cd0397b807ae4a985ed37743de31 (diff)
downloadports-9804854c3d7d75b1fbe78b069d9d64142be611fe.tar.gz
ports-9804854c3d7d75b1fbe78b069d9d64142be611fe.zip
MFH: r404119
irc/quassel: Import patch to resolve DoS CVE Approved by: ports-secteam (with hat) Security: CVE-2015-8547
Notes
Notes: svn path=/branches/2015Q4/; revision=404120
-rw-r--r--irc/quassel/Makefile1
-rw-r--r--irc/quassel/files/patch-src_core_coreuserinputhandler.cpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index a405df8e6d2c..a5c98c0dffc2 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= quassel
PORTVERSION= 0.11.1
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.quassel-irc.org/pub/
diff --git a/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp b/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp
new file mode 100644
index 000000000000..c3cff156f59c
--- /dev/null
+++ b/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp
@@ -0,0 +1,12 @@
+Fix CVE-2015-8547
+--- src/core/coreuserinputhandler.cpp.orig 2015-04-23 20:47:17 UTC
++++ src/core/coreuserinputhandler.cpp
+@@ -228,7 +228,7 @@ void CoreUserInputHandler::doMode(const
+ if (!isNumber || maxModes == 0) maxModes = 1;
+
+ QStringList nickList;
+- if (nicks == "*") { // All users in channel
++ if (nicks == "*" && bufferInfo.type() == BufferInfo::ChannelBuffer) { // All users in channel
+ const QList<IrcUser*> users = network()->ircChannel(bufferInfo.bufferName())->ircUsers();
+ foreach(IrcUser *user, users) {
+ if ((addOrRemove == '+' && !network()->ircChannel(bufferInfo.bufferName())->userModes(user).contains(mode))