aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2015-12-08 01:39:27 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2015-12-08 01:39:27 +0000
commita3b9870e89ab6d5e085ab23a9c1f4f2afa99b099 (patch)
tree3940bcb214ae7bcefc0ba5df9fdfa0197d24338d
parentf3895a43a8beaabdc58d3f191e10be14b88e1ed1 (diff)
downloadports-a3b9870e89ab6d5e085ab23a9c1f4f2afa99b099.tar.gz
ports-a3b9870e89ab6d5e085ab23a9c1f4f2afa99b099.zip
MFH: r402464
mail/msmtp: fix configuration for gnome password management In order to enable password management, now '--with-libsecret' option should be used instead of '--with-gnome-keyring'. So fix configure args and rename the GNOMEKEYRING option to LIBSECRET. Also modernize options usage and bump PORTREVISION due to package change. PR: 204760 (with minor edits) Submitted by: John Hein Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2015Q4/; revision=403246
-rw-r--r--mail/msmtp/Makefile83
-rw-r--r--mail/msmtp/pkg-plist1
2 files changed, 29 insertions, 55 deletions
diff --git a/mail/msmtp/Makefile b/mail/msmtp/Makefile
index 527d410fe142..db070fea8819 100644
--- a/mail/msmtp/Makefile
+++ b/mail/msmtp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= msmtp
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= SF
@@ -17,78 +18,52 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INFO= msmtp
-OPTIONS_DEFINE= GSASL NLS IDN GNOMEKEYRING MSMTPQ
+OPTIONS_DEFINE= DOCS GSASL NLS IDN LIBSECRET MSMTPQ
OPTIONS_RADIO= TLS
OPTIONS_RADIO_TLS= GNUTLS OPENSSL
OPTIONS_DEFAULT= MSMTPQ OPENSSL
+OPTIONS_SUB= yes
GSASL_DESC= GSASL support
+LIBSECRET_DESC= GNOME password management
MSMTPQ_DESC= Install offline messaging scripts
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-ssl=gnutls
-.elif ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --with-ssl=openssl
-CONFIGURE_ENV+= libssl_CFLAGS="-I${OPENSSLINC}" \
+GSASL_CONFIGURE_WITH= libgsasl
+GSASL_LIB_DEPENDS= libgsasl.so:${PORTSDIR}/security/gsasl
+IDN_CONFIGURE_WITH= libidn
+IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
+LIBSECRET_CONFIGURE_WITH= libsecret
+LIBSECRET_LIB_DEPENDS= libsecret-1.so:${PORTSDIR}/security/libsecret
+MSMTPQ_PORTDOCS= README.msmtpq
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+
+GNUTLS_CONFIGURE_ON= --with-ssl=gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+OPENSSL_VARS= USE_OPENSSL=yes
+OPENSSL_CONFIGURE_ON= --with-ssl=openssl
+OPENSSL_CONFIGURE_ENV= libssl_CFLAGS="-I${OPENSSLINC}" \
libssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
-.else
-CONFIGURE_ARGS+= --with-ssl=no
-.endif
-
-.if ${PORT_OPTIONS:MGNUTLS} || ${PORT_OPTIONS:MOPENSSL}
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-.endif
-
-.if ${PORT_OPTIONS:MGSASL}
-LIB_DEPENDS+= libgsasl.so:${PORTSDIR}/security/gsasl
-CONFIGURE_ARGS+= --with-libgsasl
-.else
-CONFIGURE_ARGS+= --without-libgsasl
-.endif
+CERTSFILE= ${LOCALBASE}/share/certs/ca-root-nss.crt
-.if ${PORT_OPTIONS:MIDN}
-LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
-CONFIGURE_ARGS+= --with-libidn
-.else
-CONFIGURE_ARGS+= --without-libidn
-.endif
-
-.if ${PORT_OPTIONS:MGNOMEKEYRING}
-CONFIGURE_ARGS+= --with-gnome-keyring
-LIB_DEPENDS+= libgnome-keyring.so:${PORTSDIR}/security/gnome-keyring
-.else
-CONFIGURE_ARGS+= --without-gnome-keyring
-.endif
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
+.if ${PORT_OPTIONS:MGNUTLS} || ${PORT_OPTIONS:MOPENSSL}
+RUN_DEPENDS+= ${CERTSFILE}:${PORTSDIR}/security/ca_root_nss
.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --with-ssl=no
.endif
-.include <bsd.port.pre.mk>
-
post-extract:
- @${REINPLACE_CMD} -e 's|/etc/ssl/certs/ca\\-certificates.crt|${LOCALBASE}/share/certs/ca\\-root\\-nss.crt|' \
+ @${REINPLACE_CMD} -e 's|/etc/ssl/certs/ca\\-certificates.crt|${CERTSFILE}|' \
${WRKSRC}/doc/msmtp.1
.if ${PORT_OPTIONS:MMSMTPQ}
-PLIST_SUB+= MSMTPQ=""
-
-post-install:
+post-stage:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/msmtpq/msmtp-queue ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/scripts/msmtpq/msmtpq ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/scripts/msmtpq/README.msmtpq ${STAGEDIR}${DOCSDIR}
-.else
-PLIST_SUB+= MSMTPQ="@comment "
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/msmtpq/README.msmtpq ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/msmtp/pkg-plist b/mail/msmtp/pkg-plist
index 98c3410eab29..0590320374d8 100644
--- a/mail/msmtp/pkg-plist
+++ b/mail/msmtp/pkg-plist
@@ -2,5 +2,4 @@ bin/msmtp
man/man1/msmtp.1.gz
%%MSMTPQ%%bin/msmtp-queue
%%MSMTPQ%%bin/msmtpq
-%%MSMTPQ%%%%DOCSDIR%%/README.msmtpq
%%NLS%%share/locale/de/LC_MESSAGES/msmtp.mo