aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2015-12-22 08:46:33 +0000
committerMatthias Andree <mandree@FreeBSD.org>2015-12-22 08:46:33 +0000
commitb98dded4c8cc446df091c77cf83a5a717e68f52e (patch)
tree8bf89a49d70506f132c83065984fa3c425168e46
parentfcc905e797a3988349405f454ed554a5eab2abe5 (diff)
downloadports-b98dded4c8cc446df091c77cf83a5a717e68f52e.tar.gz
ports-b98dded4c8cc446df091c77cf83a5a717e68f52e.zip
MFH: r401088 r404013
As with armv6 we need to use POSIX mutexes. Without this the ports try to use fcntl mutexes and fails as they are deprecated. Approved by: mandree (maintainer) Differential Revision: https://reviews.freebsd.org/D4107 Fix crash by using POSIX mutexes on all armv6* ARCHes not just armv6. This is to fix illegal-instruction crashes on armv6hf. PR: 205001 Submitted by: dave@dogwood.com Reviewed by: mikael.urankar@gmail.com Approved by: ports-secteam (feld@)
Notes
Notes: svn path=/branches/2015Q4/; revision=404223
-rw-r--r--databases/db48/Makefile2
-rw-r--r--databases/db5/Makefile5
-rw-r--r--databases/db6/Makefile4
3 files changed, 7 insertions, 4 deletions
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index d8e5c39b1085..3e010b76e8f9 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -35,7 +35,7 @@ USE_LDCONFIG= yes
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db48 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
.endif
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 822a53846031..a323233c9ed3 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= db5
PORTVERSION= 5.3.28
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases java
MASTER_SITES= http://download.oracle.com/berkeley-db/
PKGNAMEPREFIX?=
@@ -39,8 +39,9 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH:Marmv6*}
# db5 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
+# also bug#205001
CONFIGURE_ARGS+= --enable-posixmutexes
.endif
diff --git a/databases/db6/Makefile b/databases/db6/Makefile
index 2c9f3312a047..09290072daff 100644
--- a/databases/db6/Makefile
+++ b/databases/db6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= db6
PORTVERSION= 6.1.19
+PORTREVISION= 1
CATEGORIES= databases java
MASTER_SITES= http://download.oracle.com/berkeley-db/
PKGNAMEPREFIX?=
@@ -40,8 +41,9 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH:Marmv6*}
# db6 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
+# and also bug #205001
CONFIGURE_ARGS+= --enable-posixmutexes
.endif