aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-25 09:53:42 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-25 09:53:42 +0000
commitc3f693e70c0a8a0efa3efe1ad5e71decb19144fc (patch)
treec2c8f41978ab05a4d589a37f2da17ff61bbce624
parent2c1455dfbf268e471aa1a41a9089bd97d1e5b009 (diff)
downloadports-c3f693e70c0a8a0efa3efe1ad5e71decb19144fc.tar.gz
ports-c3f693e70c0a8a0efa3efe1ad5e71decb19144fc.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Date-Easter/Makefile29
-rw-r--r--devel/p5-Date-Easter/distinfo2
-rw-r--r--devel/p5-Date-Easter/pkg-descr6
-rw-r--r--devel/p5-Date-Easter/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b12f5c36ecd9..b567a06548cf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -657,6 +657,7 @@
SUBDIR += p5-Data-UUID
SUBDIR += p5-Date-Calc
SUBDIR += p5-Date-DayOfWeek
+ SUBDIR += p5-Date-Easter
SUBDIR += p5-Date-ICal
SUBDIR += p5-Date-ISO
SUBDIR += p5-Date-Leapyear
diff --git a/devel/p5-Date-Easter/Makefile b/devel/p5-Date-Easter/Makefile
new file mode 100644
index 000000000000..4ccc345412e9
--- /dev/null
+++ b/devel/p5-Date-Easter/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Date-Easter
+# Date created: Sun May 23 11:36:48 CEST 2004
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= Date-Easter
+PORTVERSION= 1.14
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Date
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Calculates Easter for any given year
+
+PERL_CONFIGURE= yes
+
+MAN3= Date::Easter.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500503
+# make PREFIX-clean under perl 5.005_03
+post-configure:
+ ${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Date-Easter/distinfo b/devel/p5-Date-Easter/distinfo
new file mode 100644
index 000000000000..9bc458bdd69a
--- /dev/null
+++ b/devel/p5-Date-Easter/distinfo
@@ -0,0 +1,2 @@
+MD5 (Date-Easter-1.14.tar.gz) = 9a6e8aa50ffdc1958dc3d9585e22422f
+SIZE (Date-Easter-1.14.tar.gz) = 5857
diff --git a/devel/p5-Date-Easter/pkg-descr b/devel/p5-Date-Easter/pkg-descr
new file mode 100644
index 000000000000..239c77f46b3c
--- /dev/null
+++ b/devel/p5-Date-Easter/pkg-descr
@@ -0,0 +1,6 @@
+Calculates Easter for a given year. Yes, Date::Manip already has
+code in it to do this. But Date::Manip is very big, and rather slow.
+I needed something faster and smaller, and did not need all that
+other stuff.
+
+WWW: http://search.cpan.org/dist/Date-Easter/
diff --git a/devel/p5-Date-Easter/pkg-plist b/devel/p5-Date-Easter/pkg-plist
new file mode 100644
index 000000000000..8c1f4b9ec305
--- /dev/null
+++ b/devel/p5-Date-Easter/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Date/Easter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Date/Easter/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Date/Easter
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Date 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Date 2>/dev/null || true