aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-02-18 16:02:31 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-02-18 16:02:31 +0000
commitc729cef42cfbe5dc1a11df66af3ccb6176a4682a (patch)
tree11154b0f221456992d65df8e7768815ebf14ef11
parentb44a3949398804841d8a4e386a5adc112a224ae6 (diff)
downloadports-c729cef42cfbe5dc1a11df66af3ccb6176a4682a.tar.gz
ports-c729cef42cfbe5dc1a11df66af3ccb6176a4682a.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--games/Makefile2
-rw-r--r--games/py-ski/Makefile23
-rw-r--r--games/py-ski/distinfo2
-rw-r--r--games/ski/Makefile43
-rw-r--r--games/ski/distinfo4
-rw-r--r--games/ski/pkg-descr (renamed from games/py-ski/pkg-descr)0
7 files changed, 49 insertions, 26 deletions
diff --git a/MOVED b/MOVED
index 5d7b9084aea5..9282e2ae8467 100644
--- a/MOVED
+++ b/MOVED
@@ -5456,3 +5456,4 @@ deskutils/kdepim44-runtime||2014-02-18|Removed: conflicts with new kdepimlibs
deskutils/kdepim44||2014-02-18|Removed: depends on deskutils/kdepim44-runtime
misc/kde-xdg-env||2014-02-18|Removed, remnant of KDE 3
lang/g95||2014-02-18|Removed, uses an old version of GCC which can't be built anymore
+games/py-ski|games/ski|2014-02-18|Rename to match upstream naming
diff --git a/games/Makefile b/games/Makefile
index 7cfc261d4bd6..7e2309aa5845 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -759,7 +759,6 @@
SUBDIR += py-pychess
SUBDIR += py-sgflib
SUBDIR += py-sgfsummary
- SUBDIR += py-ski
SUBDIR += pyawale
SUBDIR += pycadia
SUBDIR += pyching
@@ -884,6 +883,7 @@
SUBDIR += simsu
SUBDIR += simutrans
SUBDIR += sjeng
+ SUBDIR += ski
SUBDIR += sl
SUBDIR += slashem-tty
SUBDIR += slump
diff --git a/games/py-ski/Makefile b/games/py-ski/Makefile
deleted file mode 100644
index 050735a2dcf4..000000000000
--- a/games/py-ski/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# Created by: janos.mohacsi@bsd.hu
-# $FreeBSD$
-
-PORTNAME= ski
-PORTVERSION= 6.5
-CATEGORIES= games python
-MASTER_SITES= http://catb.org/~esr/ski/
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= jmohacsi@bsd.hu
-COMMENT= Skiing simulation with curses interface in python
-
-USE_PYTHON= yes
-NO_BUILD= yes
-MAN6= ski.6
-PLIST_FILES= bin/ski
-
-NO_STAGE= yes
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/ski ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/ski.6 ${PREFIX}/man/man6/
-
-.include <bsd.port.mk>
diff --git a/games/py-ski/distinfo b/games/py-ski/distinfo
deleted file mode 100644
index 1f177464a67c..000000000000
--- a/games/py-ski/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ski-6.5.tar.gz) = 346be95447df7eddc3888b5378dbed4bc9cd9136b14839b89c771ca425b7f1ed
-SIZE (ski-6.5.tar.gz) = 17389
diff --git a/games/ski/Makefile b/games/ski/Makefile
new file mode 100644
index 000000000000..e3a047c6a856
--- /dev/null
+++ b/games/ski/Makefile
@@ -0,0 +1,43 @@
+# Created by: janos.mohacsi@bsd.hu
+# $FreeBSD$
+
+PORTNAME= ski
+PORTVERSION= 6.7
+CATEGORIES= games python
+MASTER_SITES= http://catb.org/~esr/ski/
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Skiing simulation with curses interface in python
+
+LICENSE= BSD3CLAUSE
+
+USE_PYTHON_RUN= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/${PORTNAME}.6.gz \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${PREFIX}/man/man6/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/ski/distinfo b/games/ski/distinfo
new file mode 100644
index 000000000000..00de68070b7c
--- /dev/null
+++ b/games/ski/distinfo
@@ -0,0 +1,4 @@
+SHA256 (ski-6.7.tar.gz) = 7346f12fcb645e9fe3bd934c552af5e6a0ac149c84642a244d0ebd0405e6cf36
+SIZE (ski-6.7.tar.gz) = 12175
+SHA256 (ski.png) = 084423df9c6b37cad54bc4ac0eb0382dcb9f1efb8294e1f25bb49c7d0cc8aa33
+SIZE (ski.png) = 4314
diff --git a/games/py-ski/pkg-descr b/games/ski/pkg-descr
index b8aa9f112b37..b8aa9f112b37 100644
--- a/games/py-ski/pkg-descr
+++ b/games/ski/pkg-descr