aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-12-22 16:34:53 +0000
committerMark Felder <feld@FreeBSD.org>2015-12-22 16:34:53 +0000
commite62b85d33e8e1ed50145fb1ceed6bc807ce4581d (patch)
tree771c96b75227d54d0ec7355f8e7e04b1bd74a38c
parentb98dded4c8cc446df091c77cf83a5a717e68f52e (diff)
downloadports-e62b85d33e8e1ed50145fb1ceed6bc807ce4581d.tar.gz
ports-e62b85d33e8e1ed50145fb1ceed6bc807ce4581d.zip
MFH: r402636
Update Samba supplimentary libs Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2015Q4/; revision=404249
-rw-r--r--databases/ldb/Makefile11
-rw-r--r--databases/ldb/distinfo4
-rw-r--r--databases/ldb/files/patch-lib_replace_replace.c68
-rw-r--r--databases/tdb/Makefile4
-rw-r--r--databases/tdb/distinfo4
-rw-r--r--databases/tdb/files/patch-lib_replace_replace.c68
-rw-r--r--devel/talloc/Makefile4
-rw-r--r--devel/talloc/distinfo4
-rw-r--r--devel/talloc/files/patch-lib_replace_replace.c68
-rw-r--r--devel/tevent/Makefile4
-rw-r--r--devel/tevent/distinfo4
11 files changed, 20 insertions, 223 deletions
diff --git a/databases/ldb/Makefile b/databases/ldb/Makefile
index 166f0e48ec76..69c5ae960057 100644
--- a/databases/ldb/Makefile
+++ b/databases/ldb/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= ldb
-PORTVERSION= 1.1.21
-PORTREVISION= 1
+PORTVERSION= 1.1.23
+PORTREVISION= 0
PORTEPOCH= 0
CATEGORIES= databases
MASTER_SITES= SAMBA
@@ -32,9 +32,9 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
OPTIONS_DEFINE= MANPAGES
MANPAGES_DESC= Build and install manpages (requires textproc/docbook-xsl)
-BUILD_DEPENDS+= talloc>=2.1.1:${PORTSDIR}/devel/talloc \
- tevent>=0.9.22:${PORTSDIR}/devel/tevent \
- tdb>=1.3.4,1:${PORTSDIR}/databases/tdb \
+BUILD_DEPENDS+= talloc>=2.1.5:${PORTSDIR}/devel/talloc \
+ tevent>=0.9.26:${PORTSDIR}/devel/tevent \
+ tdb>=1.3.8,1:${PORTSDIR}/databases/tdb \
popt>=0:${PORTSDIR}/devel/popt
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -87,6 +87,7 @@ PLIST_FILES+= include/pyldb.h \
lib/libpyldb-util.so \
lib/libpyldb-util.so.1 \
%%PYTHON_SITELIBDIR%%/ldb.so \
+ %%PYTHON_SITELIBDIR%%/_ldb_text.py \
%%PKGCONFIGDIR%%/pyldb-util.pc
LDB_MAN1= man/man1/ldbadd.1.gz \
diff --git a/databases/ldb/distinfo b/databases/ldb/distinfo
index 2f238d37365c..cc4d12737f0b 100644
--- a/databases/ldb/distinfo
+++ b/databases/ldb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ldb-1.1.21.tar.gz) = 267bbb7f278068eaf0de27adffda2e691a070a93c5c15ee27c828e87b4c7dbf1
-SIZE (ldb-1.1.21.tar.gz) = 1244825
+SHA256 (ldb-1.1.23.tar.gz) = 8f8b2f7f04b24c847d088a091e6a2261ac6c7810fc711f553d3b61a3dee39559
+SIZE (ldb-1.1.23.tar.gz) = 1258249
diff --git a/databases/ldb/files/patch-lib_replace_replace.c b/databases/ldb/files/patch-lib_replace_replace.c
deleted file mode 100644
index ec08fd5e8169..000000000000
--- a/databases/ldb/files/patch-lib_replace_replace.c
+++ /dev/null
@@ -1,68 +0,0 @@
-From 035dd6447a06409c2df5ed559218f52479621abd Mon Sep 17 00:00:00 2001
-From: Volker Lendecke <vl@samba.org>
-Date: Tue, 18 Aug 2015 20:57:27 +0200
-Subject: [PATCH] replace: Fix bug 11455
-
-Don't call rep_strtoull recursively
-
-Signed-off-by: Volker Lendecke <vl@samba.org>
-Bug: https://bugzilla.samba.org/show_bug.cgi?id=11455
-
-https://lists.samba.org/archive/samba-technical/2015-July/108587.html
-https://lists.samba.org/archive/samba-technical/2015-July/108588.html
-
---- ./lib/replace/replace.c.orig 2015-09-18 23:51:08 UTC
-+++ ./lib/replace/replace.c 2015-09-18 23:51:08 UTC
-@@ -518,8 +518,10 @@
- }
- #else
- #ifdef HAVE_BSD_STRTOLL
-+#undef strtoll
- long long int rep_strtoll(const char *str, char **endptr, int base)
- {
-+ int errno0 = errno;
- long long int nb = strtoll(str, endptr, base);
- /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
-@@ -528,7 +530,7 @@
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
-@@ -551,26 +553,24 @@
- #endif
- }
- #else
--#ifdef HAVE_BSD_STRTOLL
--#ifdef HAVE_STRTOUQ
-+#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
-+#undef strtoull
- unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
- {
-- unsigned long long int nb = strtouq(str, endptr, base);
-- /* In linux EINVAL is only returned if base is not ok */
-+ int errno0 = errno;
-+ unsigned long long int nb = strtoull(str, endptr, base);
-+ /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
- if (base == 0 || (base >1 && base <37)) {
- /* Base was ok so it's because we were not
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
- }
--#else
--#error "You need the strtouq function"
--#endif /* HAVE_STRTOUQ */
- #endif /* HAVE_BSD_STRTOLL */
- #endif /* HAVE_STRTOULL */
-
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
index a919973e9fdc..3c071cdd1d3f 100644
--- a/databases/tdb/Makefile
+++ b/databases/tdb/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= tdb
-PORTVERSION= 1.3.7
-PORTREVISION= 1
+PORTVERSION= 1.3.8
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= SAMBA
diff --git a/databases/tdb/distinfo b/databases/tdb/distinfo
index 64b451776514..7914af7638f6 100644
--- a/databases/tdb/distinfo
+++ b/databases/tdb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tdb-1.3.7.tar.gz) = a64d95ca0cc06a28fed24c6e952aed7660cae04983108735d6bc30b925136412
-SIZE (tdb-1.3.7.tar.gz) = 493847
+SHA256 (tdb-1.3.8.tar.gz) = 0605ac0427eac9c23bf61ebfd8206a07d5ece198498eab1769cd0cfb6e7de6b1
+SIZE (tdb-1.3.8.tar.gz) = 494106
diff --git a/databases/tdb/files/patch-lib_replace_replace.c b/databases/tdb/files/patch-lib_replace_replace.c
deleted file mode 100644
index ec08fd5e8169..000000000000
--- a/databases/tdb/files/patch-lib_replace_replace.c
+++ /dev/null
@@ -1,68 +0,0 @@
-From 035dd6447a06409c2df5ed559218f52479621abd Mon Sep 17 00:00:00 2001
-From: Volker Lendecke <vl@samba.org>
-Date: Tue, 18 Aug 2015 20:57:27 +0200
-Subject: [PATCH] replace: Fix bug 11455
-
-Don't call rep_strtoull recursively
-
-Signed-off-by: Volker Lendecke <vl@samba.org>
-Bug: https://bugzilla.samba.org/show_bug.cgi?id=11455
-
-https://lists.samba.org/archive/samba-technical/2015-July/108587.html
-https://lists.samba.org/archive/samba-technical/2015-July/108588.html
-
---- ./lib/replace/replace.c.orig 2015-09-18 23:51:08 UTC
-+++ ./lib/replace/replace.c 2015-09-18 23:51:08 UTC
-@@ -518,8 +518,10 @@
- }
- #else
- #ifdef HAVE_BSD_STRTOLL
-+#undef strtoll
- long long int rep_strtoll(const char *str, char **endptr, int base)
- {
-+ int errno0 = errno;
- long long int nb = strtoll(str, endptr, base);
- /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
-@@ -528,7 +530,7 @@
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
-@@ -551,26 +553,24 @@
- #endif
- }
- #else
--#ifdef HAVE_BSD_STRTOLL
--#ifdef HAVE_STRTOUQ
-+#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
-+#undef strtoull
- unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
- {
-- unsigned long long int nb = strtouq(str, endptr, base);
-- /* In linux EINVAL is only returned if base is not ok */
-+ int errno0 = errno;
-+ unsigned long long int nb = strtoull(str, endptr, base);
-+ /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
- if (base == 0 || (base >1 && base <37)) {
- /* Base was ok so it's because we were not
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
- }
--#else
--#error "You need the strtouq function"
--#endif /* HAVE_STRTOUQ */
- #endif /* HAVE_BSD_STRTOLL */
- #endif /* HAVE_STRTOULL */
-
diff --git a/devel/talloc/Makefile b/devel/talloc/Makefile
index 54a01ede111c..a2491774d571 100644
--- a/devel/talloc/Makefile
+++ b/devel/talloc/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= talloc
-PORTVERSION= 2.1.3
-PORTREVISION= 1
+PORTVERSION= 2.1.5
+PORTREVISION= 0
PORTEPOCH= 0
CATEGORIES= devel
MASTER_SITES= SAMBA
diff --git a/devel/talloc/distinfo b/devel/talloc/distinfo
index 69beb1b3ccf0..2a150478bbb0 100644
--- a/devel/talloc/distinfo
+++ b/devel/talloc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (talloc-2.1.3.tar.gz) = 7aa5f75b22d4ef9c737b25515f2a2837ddc13014ff4ac6e58dd9e311f41f2cb0
-SIZE (talloc-2.1.3.tar.gz) = 434093
+SHA256 (talloc-2.1.5.tar.gz) = 3833e750cf0b8c3439186cba38800cba9e26adfbce10ee98ba709c24eb1cdddd
+SIZE (talloc-2.1.5.tar.gz) = 436193
diff --git a/devel/talloc/files/patch-lib_replace_replace.c b/devel/talloc/files/patch-lib_replace_replace.c
deleted file mode 100644
index ec08fd5e8169..000000000000
--- a/devel/talloc/files/patch-lib_replace_replace.c
+++ /dev/null
@@ -1,68 +0,0 @@
-From 035dd6447a06409c2df5ed559218f52479621abd Mon Sep 17 00:00:00 2001
-From: Volker Lendecke <vl@samba.org>
-Date: Tue, 18 Aug 2015 20:57:27 +0200
-Subject: [PATCH] replace: Fix bug 11455
-
-Don't call rep_strtoull recursively
-
-Signed-off-by: Volker Lendecke <vl@samba.org>
-Bug: https://bugzilla.samba.org/show_bug.cgi?id=11455
-
-https://lists.samba.org/archive/samba-technical/2015-July/108587.html
-https://lists.samba.org/archive/samba-technical/2015-July/108588.html
-
---- ./lib/replace/replace.c.orig 2015-09-18 23:51:08 UTC
-+++ ./lib/replace/replace.c 2015-09-18 23:51:08 UTC
-@@ -518,8 +518,10 @@
- }
- #else
- #ifdef HAVE_BSD_STRTOLL
-+#undef strtoll
- long long int rep_strtoll(const char *str, char **endptr, int base)
- {
-+ int errno0 = errno;
- long long int nb = strtoll(str, endptr, base);
- /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
-@@ -528,7 +530,7 @@
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
-@@ -551,26 +553,24 @@
- #endif
- }
- #else
--#ifdef HAVE_BSD_STRTOLL
--#ifdef HAVE_STRTOUQ
-+#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
-+#undef strtoull
- unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
- {
-- unsigned long long int nb = strtouq(str, endptr, base);
-- /* In linux EINVAL is only returned if base is not ok */
-+ int errno0 = errno;
-+ unsigned long long int nb = strtoull(str, endptr, base);
-+ /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
- if (base == 0 || (base >1 && base <37)) {
- /* Base was ok so it's because we were not
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
- }
--#else
--#error "You need the strtouq function"
--#endif /* HAVE_STRTOUQ */
- #endif /* HAVE_BSD_STRTOLL */
- #endif /* HAVE_STRTOULL */
-
diff --git a/devel/tevent/Makefile b/devel/tevent/Makefile
index d9cca9c99ffb..e5167f7dddcf 100644
--- a/devel/tevent/Makefile
+++ b/devel/tevent/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= tevent
-PORTVERSION= 0.9.25
+PORTVERSION= 0.9.26
PORTREVISION= 0
PORTEPOCH= 0
CATEGORIES= devel
@@ -30,7 +30,7 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
OPTIONS_DEFINE= MANPAGES
MANPAGES_DESC= Build and install manpages (requires textproc/docbook-xsl)
-BUILD_DEPENDS+= talloc>=2.1.1:${PORTSDIR}/devel/talloc
+BUILD_DEPENDS+= talloc>=2.1.5:${PORTSDIR}/devel/talloc
RUN_DEPENDS:= ${BUILD_DEPENDS}
.include <bsd.port.options.mk>
diff --git a/devel/tevent/distinfo b/devel/tevent/distinfo
index cd3c94d38224..77711f9ee86b 100644
--- a/devel/tevent/distinfo
+++ b/devel/tevent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tevent-0.9.25.tar.gz) = fedeb0d55a11b3593b562ec09b32e44bd67619ed10e5fa10d1868adb1649c669
-SIZE (tevent-0.9.25.tar.gz) = 573357
+SHA256 (tevent-0.9.26.tar.gz) = 262c14d78ede13f2c4fc5e61485ae7250a201782d94735a1d8412652453370bd
+SIZE (tevent-0.9.26.tar.gz) = 581664