aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-11-12 10:00:08 +0000
committerRene Ladan <rene@FreeBSD.org>2013-11-12 10:00:08 +0000
commitf6ecd174b6ba733bed40214a7b7486e8ec356ad8 (patch)
tree022d0243c1bf42ef82473a8a7005034b4c5241ff
parent24e24e77334104257f430072895b500656e444e9 (diff)
downloadports-f6ecd174b6ba733bed40214a7b7486e8ec356ad8.tar.gz
ports-f6ecd174b6ba733bed40214a7b7486e8ec356ad8.zip
Notes
-rw-r--r--MOVED2
-rw-r--r--games/Makefile2
-rw-r--r--games/intensityengine/Makefile64
-rw-r--r--games/intensityengine/distinfo2
-rw-r--r--games/intensityengine/files/intensity_client.in5
-rw-r--r--games/intensityengine/files/patch-src-engine-cubeloader.cpp28
-rw-r--r--games/intensityengine/files/patch-src-thirdparty-v8-SConstruct14
-rw-r--r--games/intensityengine/files/patch-src-thirdparty-v8-tools-utils.py11
-rw-r--r--games/intensityengine/pkg-descr6
-rw-r--r--games/windstille/Makefile50
-rw-r--r--games/windstille/distinfo2
-rw-r--r--games/windstille/files/patch-SConstruct15
-rw-r--r--games/windstille/files/patch-src-SConstruct29
-rw-r--r--games/windstille/files/patch-src-display-surface__manager.cpp14
-rw-r--r--games/windstille/files/patch-src-display-texture__manager.cpp11
-rw-r--r--games/windstille/files/patch-src-script__manager.cpp11
-rw-r--r--games/windstille/files/patch-src-tinygettext-tinygettext.cpp11
-rw-r--r--games/windstille/files/patch-tools-SConscript20
-rw-r--r--games/windstille/pkg-descr13
-rw-r--r--games/windstille/pkg-plist294
20 files changed, 2 insertions, 602 deletions
diff --git a/MOVED b/MOVED
index 0369f1dd91c7..11cf8e587dab 100644
--- a/MOVED
+++ b/MOVED
@@ -5179,3 +5179,5 @@ textproc/docproj-nojadetex||2013-11-07|Removed
games/frozenbubble|games/frozen-bubble|2013-11-08|Renamed to match upstream naming
biology/dotter|biology/seqtools|2013-11-10|Replaced with biology/seqtools
games/nil||2013-11-11|Removed: long unmaintained, failes to build
+games/windstille||2013-11-12|Has expired: Unplayable, development ceased
+games/intensityengine||2013-11-12|Has expired: Unplayable, main server down, development ceased
diff --git a/games/Makefile b/games/Makefile
index 770011dd45a5..18c578c933fb 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -401,7 +401,6 @@
SUBDIR += inform
SUBDIR += inform7
SUBDIR += instead
- SUBDIR += intensityengine
SUBDIR += interlogic
SUBDIR += ioquake3
SUBDIR += ioquake3-devel
@@ -1009,7 +1008,6 @@
SUBDIR += wesnoth
SUBDIR += whichwayisup
SUBDIR += widelands
- SUBDIR += windstille
SUBDIR += wizznic
SUBDIR += wmeyes
SUBDIR += wmfortune
diff --git a/games/intensityengine/Makefile b/games/intensityengine/Makefile
deleted file mode 100644
index ee5784b1936a..000000000000
--- a/games/intensityengine/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= intensityengine
-DISTVERSION= r20100129
-PORTREVISION= 5
-CATEGORIES= games
-MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
-
-MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Engine that forms the basis of Syntensity, 3D games world
-
-BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
-
-USE_BZIP2= yes
-USE_SDL= sdl mixer image
-USE_GL= gl glu
-USES= cmake
-SUB_FILES= intensity_client
-
-ONLY_FOR_ARCHS= i386 amd64
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-DEPRECATED= Unplayable, main server down, development ceased
-EXPIRATION_DATE=2013-11-12
-
-PORTDOCS= *
-PORTDATA= *
-
-PLIST_FILES= bin/intensityengine_client libexec/intensityengine_client
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e '/set.*CMAKE_CXX_FLAGS/ d' ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/src/thirdparty/v8/SConstruct
- @${REINPLACE_CMD} -e '/add_subdirectory.*server/ d' \
- ${WRKSRC}/src/CMakeLists.txt
-
-pre-build:
- cd ${WRKSRC}/src/thirdparty/v8 && ${SETENV} CC="${CC}" CXX="${CXX}" \
- CCFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- ${LOCALBASE}/bin/scons ${_MAKE_JOBS}
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/intensity_client ${PREFIX}/bin/
- ${INSTALL_PROGRAM} ${WRKSRC}/src/client/Intensity_CClient ${PREFIX}/libexec/intensity_client
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} \
- "data src/python src/javascript packages intensity_client.py mybrushes.cfg" \
- ${DATADIR}/
-.endif
-.if ${PORT_OPTIONS:MDOCS}
-post-install:
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/docs && ${COPYTREE_SHARE} '*' ${DOCSDIR}/
-.endif
-
-.include <bsd.port.mk>
diff --git a/games/intensityengine/distinfo b/games/intensityengine/distinfo
deleted file mode 100644
index 049d2faedd77..000000000000
--- a/games/intensityengine/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (intensityengine-r20100129.tar.bz2) = 44f570e26d19765f9c741d47475c7d7dd3254669f029e0628255272970c04020
-SIZE (intensityengine-r20100129.tar.bz2) = 39446122
diff --git a/games/intensityengine/files/intensity_client.in b/games/intensityengine/files/intensity_client.in
deleted file mode 100644
index 39d0ef43249e..000000000000
--- a/games/intensityengine/files/intensity_client.in
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-cd %%DATADIR%% || exit 1
-
-exec %%PREFIX%%/libexec/intensity_client "$@"
diff --git a/games/intensityengine/files/patch-src-engine-cubeloader.cpp b/games/intensityengine/files/patch-src-engine-cubeloader.cpp
deleted file mode 100644
index 8d403bfed00c..000000000000
--- a/games/intensityengine/files/patch-src-engine-cubeloader.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git src/engine/cubeloader.cpp src/engine/cubeloader.cpp
-index b7a1504..939cc2c 100755
---- src/engine/cubeloader.cpp
-+++ src/engine/cubeloader.cpp
-@@ -259,12 +259,12 @@ struct cubeloader
- else
- {
- conoutf(CON_ERROR, "map %s has malformatted header", cgzname);
-- gzclose(f);
-+ delete f;
- return;
- }
- }
- else if(hdr.version>5) mod = true;
-- if(hdr.version>5 && !mod) { conoutf(CON_ERROR, "map %s requires a newer version of the Cube 1 importer", cgzname); gzclose(f); return; }
-+ if(hdr.version>5 && !mod) { conoutf(CON_ERROR, "map %s requires a newer version of the Cube 1 importer", cgzname); delete f; return; }
- if(!haslocalclients()) game::forceedit("");
- emptymap(12, true, NULL);
- freeocta(worldroot);
-@@ -280,7 +280,7 @@ struct cubeloader
- {
- hdr.waterlevel = -100000;
- }
-- if(mod) gzseek(f, hdr.numents*sizeof(c_persistent_entity), SEEK_CUR);
-+ if(mod) f->seek(hdr.numents*sizeof(c_persistent_entity), SEEK_CUR);
- else loopi(hdr.numents)
- {
- c_persistent_entity e;
diff --git a/games/intensityengine/files/patch-src-thirdparty-v8-SConstruct b/games/intensityengine/files/patch-src-thirdparty-v8-SConstruct
deleted file mode 100644
index 7dccb6e8ecc5..000000000000
--- a/games/intensityengine/files/patch-src-thirdparty-v8-SConstruct
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/thirdparty/v8/SConstruct.orig 2010-01-30 03:01:20.000000000 +0300
-+++ src/thirdparty/v8/SConstruct 2010-01-30 03:02:10.000000000 +0300
-@@ -824,7 +824,10 @@
- else:
- prefix = options[key]
- if isinstance(prefix, StringTypes): prefix = prefix.split()
-- options[key] = prefix + value
-+ if key == 'CPPPATH':
-+ options[key] = value + prefix
-+ else:
-+ options[key] = prefix + value
-
- def ConfigureObject(self, env, input, **kw):
- if (kw.has_key('CPPPATH') and env.has_key('CPPPATH')):
diff --git a/games/intensityengine/files/patch-src-thirdparty-v8-tools-utils.py b/games/intensityengine/files/patch-src-thirdparty-v8-tools-utils.py
deleted file mode 100644
index 0346dfb42e3e..000000000000
--- a/games/intensityengine/files/patch-src-thirdparty-v8-tools-utils.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/thirdparty/v8/tools/utils.py.orig 2010-01-28 22:56:11.000000000 +0300
-+++ src/thirdparty/v8/tools/utils.py 2010-01-29 00:11:53.000000000 +0300
-@@ -67,6 +67,8 @@
- return 'arm'
- elif (not id) or (not re.match('(x|i[3-6])86', id) is None):
- return 'ia32'
-+ elif id == 'amd64':
-+ return 'x64'
- else:
- return None
-
diff --git a/games/intensityengine/pkg-descr b/games/intensityengine/pkg-descr
deleted file mode 100644
index d00d68456143..000000000000
--- a/games/intensityengine/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-The Intensity Engine is the open source project that forms the basis
-of Syntensity, and consists of a client, server, and master (metadata)
-server - everything you need to run your own games or even your own
-virtual world.
-
-WWW: http://www.syntensity.com/
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
deleted file mode 100644
index 7e57c595f546..000000000000
--- a/games/windstille/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
-# $FreeBSD$
-
-PORTNAME= windstille
-PORTVERSION= 0.3.0
-PORTREVISION= 15
-CATEGORIES= games
-MASTER_SITES= BERLIOS CENKES
-
-MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Classic 2D jump-n-shoot game
-
-LIB_DEPENDS= physfs:${PORTSDIR}/devel/physfs \
- ogg:${PORTSDIR}/audio/libogg \
- vorbis:${PORTSDIR}/audio/libvorbis \
- png15:${PORTSDIR}/graphics/png \
- squirrel:${PORTSDIR}/lang/squirrel \
- freetype:${PORTSDIR}/print/freetype2
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-
-USE_BZIP2= yes
-USE_SCONS= yes
-USE_OPENAL= al
-USE_GL= glew
-USE_SDL= sdl image
-USES= bison
-
-DEPRECATED= Unplayable, development ceased
-EXPIRATION_DATE=2013-11-12
-
-NO_STAGE= yes
-post-extract:
- @${RM} -rf ${WRKSRC}/lib ${WRKSRC}/data/music/*
-
-post-patch:
- @cd ${WRKSRC}/src/ && ${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' \
- particles/deform_drawer.cpp windstille_main.cpp objects/shockwave.cpp
- @${REINPLACE_CMD} -e "s|glew|GLEW|;/LIBS/s|'squirrel'|'squirrel', 'sqstdlib'|"\
- ${WRKSRC}/src/SConscript
- @${REINPLACE_CMD} -e 's|PHYSFS_getBaseDir()|""|' ${WRKSRC}/src/windstille_main.cpp
- @${REINPLACE_CMD} -e 's|bison|${LOCALBASE}/bin/&|' ${WRKSRC}/tools/SConscript
- @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|; s|freetype-config|${LOCALBASE}/bin/&|' \
- ${WRKSRC}/SConstruct ${WRKSRC}/src/SConscript
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/windstille ${PREFIX}/bin/
- ${INSTALL} -d ${DATADIR}/
- @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}/
-
-.include <bsd.port.mk>
diff --git a/games/windstille/distinfo b/games/windstille/distinfo
deleted file mode 100644
index 00f9ceea5a3f..000000000000
--- a/games/windstille/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (windstille-0.3.0.tar.bz2) = e1cdef80ace70a6be7beceb60e7c2d2f81860eb4262e5df88f8ecda9aee1f7e4
-SIZE (windstille-0.3.0.tar.bz2) = 11926694
diff --git a/games/windstille/files/patch-SConstruct b/games/windstille/files/patch-SConstruct
deleted file mode 100644
index 9ffcdcdf605c..000000000000
--- a/games/windstille/files/patch-SConstruct
+++ /dev/null
@@ -1,15 +0,0 @@
---- SConstruct.orig Thu Jun 14 15:59:31 2007
-+++ SConstruct Thu Jun 14 16:03:28 2007
-@@ -99,7 +99,11 @@
- return output
-
-
--conf_env = Environment()
-+conf_env = Environment(**ARGUMENTS)
-+conf_env.Replace(CCFLAGS = conf_env['CCFLAGS'].split())
-+conf_env.Replace(CXXFLAGS = conf_env['CXXFLAGS'].split())
-+conf_env.Replace(CPPPATH = conf_env['CPPPATH'].split())
-+conf_env.Replace(LIBPATH = conf_env['LIBPATH'].split())
- conf = Configure(conf_env, custom_tests = { 'Check32bit' : Check32bit })
- if conf.Check32bit() == "64bit":
- conf.env.Append(CXXFLAGS="-D_SQ64")
diff --git a/games/windstille/files/patch-src-SConstruct b/games/windstille/files/patch-src-SConstruct
deleted file mode 100644
index 9bf34e0fe32c..000000000000
--- a/games/windstille/files/patch-src-SConstruct
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/SConscript.orig Wed Jun 13 07:04:35 2007
-+++ src/SConscript Thu Jun 14 15:51:17 2007
-@@ -26,11 +26,10 @@
-
- Import('conf_env')
-
--env = Environment(CC = 'gcc',
-- CXX = 'g++',
-- CXXFLAGS = ['-O0', '-Wall', '-Werror', '-g', '-DDEBUG'] + conf_env['CXXFLAGS'])
--
--env.Append(CXXFLAGS = conf_env['CXXFLAGS'])
-+env = conf_env.Copy()
-+env.Append(LIBS = ['GL', 'GLU', 'squirrel', 'physfs', 'SDL_image', 'openal', 'glew', 'ogg', 'vorbis', 'vorbisfile', 'png', 'iconv'])
-+env.Append(LIBPATH = ['../lib/'] )
-+env.Append(CPPPATH = ['.', '..', '../lib/SQUIRREL2/include/', '../lib/glew'])
-
- # env.Copy(LIBS = ['a', 'b'])
-
-@@ -184,9 +183,6 @@
- 'sprite3d/sprite3d.cpp',
- 'tinygettext/gettext.cpp',
- 'tinygettext/tinygettext.cpp'
--],
--LIBS = ['GL', 'GLU', 'squirrel', 'physfs', 'SDL_image', 'openal', 'glew', 'ogg', 'vorbis', 'vorbisfile', 'png'] + env['LIBS'],
--LIBPATH = ['../lib/'],
--CPPPATH = env['CPPPATH'] + ['.', '..', '../lib/SQUIRREL2/include/', '../lib/glew'])
-+])
-
- # EOF #
diff --git a/games/windstille/files/patch-src-display-surface__manager.cpp b/games/windstille/files/patch-src-display-surface__manager.cpp
deleted file mode 100644
index 0f098a0b6d10..000000000000
--- a/games/windstille/files/patch-src-display-surface__manager.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/display/surface_manager.cpp.orig 2006-04-25 08:08:56.000000000 +0400
-+++ src/display/surface_manager.cpp 2013-09-12 04:51:36.056226058 +0400
-@@ -13,9 +13,10 @@
- #include "texture.hpp"
- #include "surface.hpp"
- #include "texture_manager.hpp"
-+
- #include "physfs/physfs_sdl.hpp"
-
--SurfaceManager::SurfaceManager* surface_manager = 0;
-+SurfaceManager* surface_manager = 0;
-
- SurfaceManager::SurfaceManager()
- {
diff --git a/games/windstille/files/patch-src-display-texture__manager.cpp b/games/windstille/files/patch-src-display-texture__manager.cpp
deleted file mode 100644
index 0f82c2074c91..000000000000
--- a/games/windstille/files/patch-src-display-texture__manager.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/display/texture_manager.cpp.orig 2006-03-11 16:50:05.000000000 +0300
-+++ src/display/texture_manager.cpp 2013-09-12 04:43:09.595227271 +0400
-@@ -13,7 +13,7 @@
- #include "texture.hpp"
- #include "physfs/physfs_sdl.hpp"
-
--TextureManager::TextureManager* texture_manager = 0;
-+TextureManager* texture_manager = 0;
-
- TextureManager::TextureManager()
- {
diff --git a/games/windstille/files/patch-src-script__manager.cpp b/games/windstille/files/patch-src-script__manager.cpp
deleted file mode 100644
index 24149d6b8dc8..000000000000
--- a/games/windstille/files/patch-src-script__manager.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/script_manager.cpp.orig 2007-06-12 21:32:05.000000000 +0400
-+++ src/script_manager.cpp 2009-07-28 23:45:51.000000000 +0400
-@@ -130,7 +130,7 @@
- {
- squirrel_vm.waiting_for_events = WakeupData(NO_EVENT);
- try {
-- if(sq_wakeupvm(squirrel_vm.vm, false, false, true) < 0) {
-+ if(sq_wakeupvm(squirrel_vm.vm, false, false, true, false) < 0) {
- throw SquirrelError(squirrel_vm.vm, "Couldn't resume script");
- }
- } catch(std::exception& e) {
diff --git a/games/windstille/files/patch-src-tinygettext-tinygettext.cpp b/games/windstille/files/patch-src-tinygettext-tinygettext.cpp
deleted file mode 100644
index db289b32adca..000000000000
--- a/games/windstille/files/patch-src-tinygettext-tinygettext.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tinygettext/tinygettext.cpp.orig Sat Jul 2 19:58:07 2005
-+++ src/tinygettext/tinygettext.cpp Thu Jun 14 16:12:51 2007
-@@ -50,7 +50,7 @@
- strcpy(in_orig, text.c_str());
-
- char* out = out_orig;
-- ICONV_CONST char* in = in_orig;
-+ const char* in = in_orig;
- size_t out_len_temp = out_len; // iconv is counting down the bytes it has
- // written from this...
-
diff --git a/games/windstille/files/patch-tools-SConscript b/games/windstille/files/patch-tools-SConscript
deleted file mode 100644
index 6730fd0caab3..000000000000
--- a/games/windstille/files/patch-tools-SConscript
+++ /dev/null
@@ -1,20 +0,0 @@
---- tools/SConscript.orig Thu Jun 22 19:15:05 2006
-+++ tools/SConscript Fri Jun 15 00:09:36 2007
-@@ -2,9 +2,14 @@
-
- import glob
-
--env = Environment(CPPPATH=['../..'],
-- CXXFILESUFFIX = ".cpp",
-- YACCFLAGS=['-d', '--no-lines'])
-+Import('conf_env')
-+
-+env = conf_env.Copy()
-+env.Append(CPPPATH=['../..'])
-+env.Replace(CXXFILESUFFIX = ".cpp")
-+env.Replace(YACCFLAGS = ['-d', '--no-lines'])
-+env.Replace(YACC = 'bison')
-+
- miniswig = env.Program('miniswig/miniswig',
- ['miniswig/parser.yy',
- 'miniswig/lexer.ll',
diff --git a/games/windstille/pkg-descr b/games/windstille/pkg-descr
deleted file mode 100644
index 0a5777d62292..000000000000
--- a/games/windstille/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-In Windstille the player will be placed in a foreign alien world
-and has to find its way back into safety. Special focus will be on
-getting the foreign world and the players character itself believable.
-Exploration will be more needed than plain shoot action, even so
-the players-character will be equipped with a multifunctional
-war-suit, so he will be far from defenseless. The game will have
-slow placed explore and seak sequences as well as more rough section
-that will feature fast shoot and jump action. The game world should
-be presented in a consistent state, enemies once destroyed should
-not respawn automatically. The player is free to go forward and
-backward in the world as long as the level design allows it.
-
-WWW: http://windstille.berlios.de
diff --git a/games/windstille/pkg-plist b/games/windstille/pkg-plist
deleted file mode 100644
index 0f69c769964b..000000000000
--- a/games/windstille/pkg-plist
+++ /dev/null
@@ -1,294 +0,0 @@
-bin/windstille
-%%DATADIR%%/Jamfile
-%%DATADIR%%/addcolor.scm
-%%DATADIR%%/controller/gamepad.scm
-%%DATADIR%%/controller/gamepad2.scm
-%%DATADIR%%/controller/keyboard.scm
-%%DATADIR%%/coroutine.rb
-%%DATADIR%%/fonts/COPYRIGHT.TXT
-%%DATADIR%%/fonts/Vera.ttf
-%%DATADIR%%/fonts/VeraMoBd.ttf
-%%DATADIR%%/fonts/VeraMono.ttf
-%%DATADIR%%/game.rb
-%%DATADIR%%/game.scm
-%%DATADIR%%/helper.scm
-%%DATADIR%%/images/.cvsignore
-%%DATADIR%%/images/404.png
-%%DATADIR%%/images/arrow.png
-%%DATADIR%%/images/arrow.sprite
-%%DATADIR%%/images/black.png
-%%DATADIR%%/images/bomb.png
-%%DATADIR%%/images/bomb1.png
-%%DATADIR%%/images/bombhighlight.png
-%%DATADIR%%/images/bomblight.png
-%%DATADIR%%/images/caustic/01.png
-%%DATADIR%%/images/caustic/02.png
-%%DATADIR%%/images/caustic/03.png
-%%DATADIR%%/images/caustic/04.png
-%%DATADIR%%/images/caustic/05.png
-%%DATADIR%%/images/caustic/06.png
-%%DATADIR%%/images/caustic/07.png
-%%DATADIR%%/images/caustic/08.png
-%%DATADIR%%/images/caustic/09.png
-%%DATADIR%%/images/caustic/10.png
-%%DATADIR%%/images/caustic/11.png
-%%DATADIR%%/images/caustic/12.png
-%%DATADIR%%/images/caustic/13.png
-%%DATADIR%%/images/caustic/14.png
-%%DATADIR%%/images/caustic/15.png
-%%DATADIR%%/images/caustic/16.png
-%%DATADIR%%/images/caustic/17.png
-%%DATADIR%%/images/caustic/18.png
-%%DATADIR%%/images/caustic/19.png
-%%DATADIR%%/images/caustic/20.png
-%%DATADIR%%/images/caustic/21.png
-%%DATADIR%%/images/caustic/22.png
-%%DATADIR%%/images/caustic/23.png
-%%DATADIR%%/images/caustic/24.png
-%%DATADIR%%/images/caustic/25.png
-%%DATADIR%%/images/caustic/26.png
-%%DATADIR%%/images/caustic/27.png
-%%DATADIR%%/images/caustic/28.png
-%%DATADIR%%/images/caustic/29.png
-%%DATADIR%%/images/caustic/30.png
-%%DATADIR%%/images/caustic/31.png
-%%DATADIR%%/images/caustic/32.png
-%%DATADIR%%/images/colltest.png
-%%DATADIR%%/images/colltest2.png
-%%DATADIR%%/images/controldialog.png
-%%DATADIR%%/images/energy_bar.png
-%%DATADIR%%/images/exit.png
-%%DATADIR%%/images/explolight.png
-%%DATADIR%%/images/explosion.png
-%%DATADIR%%/images/flashlighthighlight.png
-%%DATADIR%%/images/flashlighthighlight.sprite
-%%DATADIR%%/images/flashlightlight.png
-%%DATADIR%%/images/flashlightlight.sprite
-%%DATADIR%%/images/greychess.png
-%%DATADIR%%/images/groundset.png
-%%DATADIR%%/images/groundset2.png
-%%DATADIR%%/images/hedgehog.png
-%%DATADIR%%/images/hedgehog1.png
-%%DATADIR%%/images/hedgehog_die1.png
-%%DATADIR%%/images/hedgehog_die2.png
-%%DATADIR%%/images/hedgehog_die3.png
-%%DATADIR%%/images/hedgehog_die4.png
-%%DATADIR%%/images/hedgehog_die5.png
-%%DATADIR%%/images/hedgehog_highlight.png
-%%DATADIR%%/images/hedgehog_light.png
-%%DATADIR%%/images/industrialset.png
-%%DATADIR%%/images/inventory/flashlight.png
-%%DATADIR%%/images/inventory/granate.png
-%%DATADIR%%/images/inventory/keycard.png
-%%DATADIR%%/images/inventory/pda.png
-%%DATADIR%%/images/inventory/slot.png
-%%DATADIR%%/images/inventory/slot.sprite
-%%DATADIR%%/images/inventory/slothighlight.png
-%%DATADIR%%/images/inventory/slothighlight.sprite
-%%DATADIR%%/images/inventory/stone.png
-%%DATADIR%%/images/laserpointer.png
-%%DATADIR%%/images/laserpointer.sprite
-%%DATADIR%%/images/laserpointer_light.png
-%%DATADIR%%/images/laserpointer_light.sprite
-%%DATADIR%%/images/light.png
-%%DATADIR%%/images/light1.png
-%%DATADIR%%/images/light2.png
-%%DATADIR%%/images/light3.png
-%%DATADIR%%/images/light3.sprite
-%%DATADIR%%/images/logo.png
-%%DATADIR%%/images/logo_black.png
-%%DATADIR%%/images/logo_large.png
-%%DATADIR%%/images/menu_background.jpg
-%%DATADIR%%/images/nightvision.png
-%%DATADIR%%/images/noise.png
-%%DATADIR%%/images/noise2.png
-%%DATADIR%%/images/noise3.png
-%%DATADIR%%/images/objects/apartmentlamp.png
-%%DATADIR%%/images/objects/apartmentlamp.sprite
-%%DATADIR%%/images/objects/apartmentlamp_highlight.png
-%%DATADIR%%/images/objects/apartmentlamp_highlight.sprite
-%%DATADIR%%/images/objects/apartmentlamp_light.png
-%%DATADIR%%/images/objects/apartmentlamp_light.sprite
-%%DATADIR%%/images/objects/bar.png
-%%DATADIR%%/images/objects/box.png
-%%DATADIR%%/images/objects/box.sprite
-%%DATADIR%%/images/objects/cabinet.png
-%%DATADIR%%/images/objects/elevatordoor.png
-%%DATADIR%%/images/objects/elevatordoor_left.png
-%%DATADIR%%/images/objects/elevatordoor_right.png
-%%DATADIR%%/images/objects/northernstar.svg
-%%DATADIR%%/images/objects/northernstarjoinnow.png
-%%DATADIR%%/images/objects/painting1.png
-%%DATADIR%%/images/objects/painting1.sprite
-%%DATADIR%%/images/objects/painting2.png
-%%DATADIR%%/images/objects/painting2.sprite
-%%DATADIR%%/images/objects/painting3.png
-%%DATADIR%%/images/objects/painting3.sprite
-%%DATADIR%%/images/objects/painting4.png
-%%DATADIR%%/images/objects/plant.png
-%%DATADIR%%/images/objects/showerdoors.png
-%%DATADIR%%/images/objects/vrdoor-color.png
-%%DATADIR%%/images/objects/vrdoor-color.sprite
-%%DATADIR%%/images/objects/vrdoor-highlight.png
-%%DATADIR%%/images/objects/vrdoor-highlight.sprite
-%%DATADIR%%/images/particles/deform.png
-%%DATADIR%%/images/particles/deform2.png
-%%DATADIR%%/images/particles/fire_light.png
-%%DATADIR%%/images/particles/smoke.png
-%%DATADIR%%/images/particles/smoke2.png
-%%DATADIR%%/images/particles/snow.png
-%%DATADIR%%/images/particles/snow.xcf
-%%DATADIR%%/images/particles/snow2.png
-%%DATADIR%%/images/planet.jpg
-%%DATADIR%%/images/planet.sprite
-%%DATADIR%%/images/portrait.png
-%%DATADIR%%/images/portraits/barrobot.png
-%%DATADIR%%/images/portraits/bob.png
-%%DATADIR%%/images/portraits/jane.png
-%%DATADIR%%/images/portraits/monster.png
-%%DATADIR%%/images/portraits/powersuit.png
-%%DATADIR%%/images/portraits/sophie.png
-%%DATADIR%%/images/portraits/worker.png
-%%DATADIR%%/images/portraits/yagor.png
-%%DATADIR%%/images/spider_mine.png
-%%DATADIR%%/images/spider_mine.sprite
-%%DATADIR%%/images/streetlamp-highlight.png
-%%DATADIR%%/images/streetlamp-highlight.sprite
-%%DATADIR%%/images/streetlamp-light.png
-%%DATADIR%%/images/streetlamp-light.sprite
-%%DATADIR%%/images/streetlamp.png
-%%DATADIR%%/images/streetlamp.sprite
-%%DATADIR%%/images/textures/water.png
-%%DATADIR%%/images/tiles/apartment-background.png
-%%DATADIR%%/images/tiles/apartment-foreground.png
-%%DATADIR%%/images/tiles/bluestone.png
-%%DATADIR%%/images/tiles/forestground.png
-%%DATADIR%%/images/tiles/groundset.png
-%%DATADIR%%/images/tiles/industrial.png
-%%DATADIR%%/images/tiles/notile.png
-%%DATADIR%%/images/tiles/tile23.png
-%%DATADIR%%/images/tiles/tile40.png
-%%DATADIR%%/images/tiles/tile41.png
-%%DATADIR%%/images/tiles/tile42.png
-%%DATADIR%%/images/tiles/tile43.png
-%%DATADIR%%/images/tiles/tile44.png
-%%DATADIR%%/images/tiles/tile45.png
-%%DATADIR%%/images/tiles/tile46.png
-%%DATADIR%%/images/tiles/virtualreality-background.png
-%%DATADIR%%/images/tiles/virtualreality-foreground.png
-%%DATADIR%%/images/tiles/virtualreality-highlight.png
-%%DATADIR%%/images/titlescreen.png
-%%DATADIR%%/images/unknown.png
-%%DATADIR%%/images/verdana11_blue.png
-%%DATADIR%%/images/verdana32_blue.png
-%%DATADIR%%/images/verdana32_blueh.png
-%%DATADIR%%/images/verdana48_blue.png
-%%DATADIR%%/images/verdana48_blueh.png
-%%DATADIR%%/images/virtualreality-background.png
-%%DATADIR%%/images/virtualreality-highlight.png
-%%DATADIR%%/images/virtualreality.png
-%%DATADIR%%/images/wallpaper.png
-%%DATADIR%%/images/watersplash.png
-%%DATADIR%%/levels/apartment.wst
-%%DATADIR%%/levels/bluestone.wst
-%%DATADIR%%/levels/forest.wst
-%%DATADIR%%/levels/industrial.wst
-%%DATADIR%%/levels/intro.nut
-%%DATADIR%%/levels/intro.wst
-%%DATADIR%%/levels/newformat2.nut
-%%DATADIR%%/levels/newformat2.wst
-%%DATADIR%%/levels/virtualreality.wst
-%%DATADIR%%/locale/de.po
-%%DATADIR%%/models/characters/bob/bob.wsprite
-%%DATADIR%%/models/characters/bob/body.png
-%%DATADIR%%/models/characters/bob/head.png
-%%DATADIR%%/models/characters/jane/jane.wsprite
-%%DATADIR%%/models/characters/jane/suit2-texture.png
-%%DATADIR%%/models/characters/jane/texture1.png
-%%DATADIR%%/models/characters/monster/monster.wsprite
-%%DATADIR%%/models/characters/monster/monstertexture.png
-%%DATADIR%%/models/characters/powersuit/powersuit.wsprite
-%%DATADIR%%/models/characters/powersuit/powersuittexture.png
-%%DATADIR%%/models/characters/sophie/headtexture.png
-%%DATADIR%%/models/characters/sophie/sophie.wsprite
-%%DATADIR%%/models/characters/sophie/sophietexture.png
-%%DATADIR%%/models/characters/spider/spider.wsprite
-%%DATADIR%%/models/characters/spider/spidertexture.png
-%%DATADIR%%/models/characters/vrdummy/vrdummy.wsprite
-%%DATADIR%%/models/characters/vrdummy/vrdummytexture.png
-%%DATADIR%%/models/characters/yagor/clothtexture.png
-%%DATADIR%%/models/characters/yagor/facetexture.png
-%%DATADIR%%/models/characters/yagor/yagor.wsprite
-%%DATADIR%%/models/objects/barrobot/barrobotsprite.png
-%%DATADIR%%/models/objects/grenade/grenade.wsprite
-%%DATADIR%%/models/objects/grenade/grenadetexture.png
-%%DATADIR%%/models/objects/pistol/pistol.wsprite
-%%DATADIR%%/models/objects/pistol/pistoltexture.png
-%%DATADIR%%/models/vehicles/shuttle/shuttle.wsprite
-%%DATADIR%%/models/vehicles/train/texture.png
-%%DATADIR%%/models/vehicles/train/train.wsprite
-%%DATADIR%%/particlesystems/deform.particles
-%%DATADIR%%/particlesystems/fire.particles
-%%DATADIR%%/scripts/apartment/barrobot.nut
-%%DATADIR%%/scripts/apartment/init.nut
-%%DATADIR%%/scripts/apartment/yagor.nut
-%%DATADIR%%/scripts/init.nut
-%%DATADIR%%/scripts/init_script_vars.nut
-%%DATADIR%%/scripts/newformat2/bob.nut
-%%DATADIR%%/scripts/newformat2/frank.nut
-%%DATADIR%%/scripts/windstille.nut
-%%DATADIR%%/shader/blacknwhite.frag
-%%DATADIR%%/shader/particledeform.frag
-%%DATADIR%%/shader/shockwave.frag
-%%DATADIR%%/shader/shockwave2.frag
-%%DATADIR%%/shader/simple.frag
-%%DATADIR%%/shader/wooble.frag
-%%DATADIR%%/sounds/README
-%%DATADIR%%/sounds/elevator.ogg
-%%DATADIR%%/sounds/fizzle.wav
-%%DATADIR%%/sounds/menu_change.wav
-%%DATADIR%%/sounds/menu_click.wav
-%%DATADIR%%/sounds/speech/vr_intro.ogg
-%%DATADIR%%/sounds/steps_dirt.ogg
-%%DATADIR%%/tiles.scm
-%%DATADIR%%/windstille.scm
-%%DATADIR%%/windstille.scr
-@dirrm %%DATADIR%%/sounds/speech
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/shader
-@dirrm %%DATADIR%%/scripts/newformat2
-@dirrm %%DATADIR%%/scripts/apartment
-@dirrm %%DATADIR%%/scripts
-@dirrm %%DATADIR%%/particlesystems
-@dirrm %%DATADIR%%/music
-@dirrm %%DATADIR%%/models/weapons
-@dirrm %%DATADIR%%/models/vehicles/train
-@dirrm %%DATADIR%%/models/vehicles/shuttle
-@dirrm %%DATADIR%%/models/vehicles
-@dirrm %%DATADIR%%/models/objects/pistol
-@dirrm %%DATADIR%%/models/objects/grenade
-@dirrm %%DATADIR%%/models/objects/barrobot
-@dirrm %%DATADIR%%/models/objects
-@dirrm %%DATADIR%%/models/characters/yagor
-@dirrm %%DATADIR%%/models/characters/vrdummy
-@dirrm %%DATADIR%%/models/characters/spider
-@dirrm %%DATADIR%%/models/characters/sophie
-@dirrm %%DATADIR%%/models/characters/powersuit
-@dirrm %%DATADIR%%/models/characters/monster
-@dirrm %%DATADIR%%/models/characters/jane
-@dirrm %%DATADIR%%/models/characters/bob
-@dirrm %%DATADIR%%/models/characters
-@dirrm %%DATADIR%%/models
-@dirrm %%DATADIR%%/locale
-@dirrm %%DATADIR%%/levels
-@dirrm %%DATADIR%%/images/tiles
-@dirrm %%DATADIR%%/images/textures
-@dirrm %%DATADIR%%/images/portraits
-@dirrm %%DATADIR%%/images/particles
-@dirrm %%DATADIR%%/images/objects
-@dirrm %%DATADIR%%/images/inventory
-@dirrm %%DATADIR%%/images/caustic
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/fonts
-@dirrm %%DATADIR%%/controller
-@dirrm %%DATADIR%%