aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2010-12-17 04:01:53 +0000
committerMark Linimon <linimon@FreeBSD.org>2010-12-17 04:01:53 +0000
commit0b7016a80a4b658910b3b54f4e2f2b07c56ddb9c (patch)
treee30d10c50160d6ced64273b7dd50db31401d1f9d
parentc3cb1a5ebfe1fd6edb35d1806a5ef41204bd0f97 (diff)
Notes
-rw-r--r--textproc/gxditview/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/textproc/gxditview/Makefile b/textproc/gxditview/Makefile
index 6b319085f9b9..2bb626608b78 100644
--- a/textproc/gxditview/Makefile
+++ b/textproc/gxditview/Makefile
@@ -17,31 +17,31 @@ COMMENT= An X11 based previewer for groff output
MAN1= gxditview.1
PLIST_FILES= bin/gxditview lib/X11/app-defaults/GXditview
-.if !exists(/usr/src/contrib/groff/src)
-IGNORE= requires /usr/src/contrib/groff/src to build
+.if !exists(${SRC_BASE}/contrib/groff/src)
+IGNORE= requires ${SRC_BASE}/contrib/groff/src to build
GXDVVERSION= 1.16
GXDVREVISION= .1
.else
-GXDVVERSION!= cat /usr/src/contrib/groff/VERSION
-GXDVREVISION!= sed -e 's/^0$$//' -e 's/^[1-9].*$$/.&/' /usr/src/contrib/groff/REVISION
+GXDVVERSION!= cat ${SRC_BASE}/contrib/groff/VERSION
+GXDVREVISION!= sed -e 's/^0$$//' -e 's/^[1-9].*$$/.&/' ${SRC_BASE}/contrib/groff/REVISION
.endif
-.if exists(/usr/src/contrib/groff/src/devices/xditview) && \
- exists(/usr/src/gnu/usr.bin/groff/src/devices/xditview)
+.if exists(${SRC_BASE}/contrib/groff/src/devices/xditview) && \
+ exists(${SRC_BASE}/gnu/usr.bin/groff/src/devices/xditview)
USE_XORG= x11 xproto xt xmu xaw
MANCOMPRESSED= maybe
-WRKSRC= /usr/src/gnu/usr.bin/groff/src/devices/xditview
+WRKSRC= ${SRC_BASE}/gnu/usr.bin/groff/src/devices/xditview
MAKE_ENV= MAKEOBJDIR=${WRKDIR}
pre-configure-script:
@${DO_NADA}
-.elif exists(/usr/src/contrib/groff/src/xditview)
+.elif exists(${SRC_BASE}/contrib/groff/src/xditview)
USE_IMAKE= yes
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKSRC}
- ${CP} -rp /usr/src/contrib/groff/src/xditview/* ${WRKSRC}
+ ${CP} -rp ${SRC_BASE}/contrib/groff/src/xditview/* ${WRKSRC}
.endif
.include <bsd.port.mk>