aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-03 16:01:32 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-03 16:01:32 +0000
commit17054745bfea63d9082287df7949eeb69f43364d (patch)
treea856806e420a34700e7dcf41567b827a80b61eae
parent4b90ede1a341795c41acbae71e6e19645caf617c (diff)
downloadports-17054745bfea63d9082287df7949eeb69f43364d.tar.gz
ports-17054745bfea63d9082287df7949eeb69f43364d.zip
Notes
-rw-r--r--security/sshit/Makefile5
-rw-r--r--security/sshit/distinfo6
-rw-r--r--security/sshit/files/patch-sshit.pl39
3 files changed, 5 insertions, 45 deletions
diff --git a/security/sshit/Makefile b/security/sshit/Makefile
index 1f39f039c518..a06263f3a049 100644
--- a/security/sshit/Makefile
+++ b/security/sshit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sshit
-PORTVERSION= 0.5
-PORTREVISION= 1
+PORTVERSION= 0.6
CATEGORIES= security
MASTER_SITES= http://anp.ath.cx/sshit/ \
${MASTER_SITE_LOCAL}
@@ -33,7 +32,7 @@ IGNORE= perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/sbin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf-dist
post-install:
diff --git a/security/sshit/distinfo b/security/sshit/distinfo
index 011dbbd2825a..0d2f04f78f1f 100644
--- a/security/sshit/distinfo
+++ b/security/sshit/distinfo
@@ -1,3 +1,3 @@
-MD5 (sshit-0.5.tar.gz) = 1b3f40e08a10919820eb5ecbfa3bc34b
-SHA256 (sshit-0.5.tar.gz) = eb65e94820fbfbd75d8227de9cd7f42b8b497c1bfac350fbb9d4ef51d85b442d
-SIZE (sshit-0.5.tar.gz) = 4065
+MD5 (sshit-0.6.tar.gz) = 9c71b88217bcf3164ec44be85674b666
+SHA256 (sshit-0.6.tar.gz) = 894ace091abc8f39024d2473e650b496002671bd726840afbd8d1bb01fe6b4f5
+SIZE (sshit-0.6.tar.gz) = 4404
diff --git a/security/sshit/files/patch-sshit.pl b/security/sshit/files/patch-sshit.pl
deleted file mode 100644
index 39db7a98ffcb..000000000000
--- a/security/sshit/files/patch-sshit.pl
+++ /dev/null
@@ -1,39 +0,0 @@
---- /usr/ports/security/sshit/work/sshit-0.5/sshit.pl Sat Dec 17 19:40:24 2005
-+++ sshit.pl Sat Apr 29 08:39:06 2006
-@@ -232,7 +232,7 @@
- create => 1,
- exclusive => 0,
- mode => 0644,
-- destroy => 0,
-+ destroy => 1,
- );
-
- $handle = tie %list, 'IPC::Shareable', 'sshi', { %options };
-@@ -266,7 +266,7 @@
- {
- system("$IPFW_CMD delete $list{$ip}{rulenr}");
- } elsif ($FIREWALL_TYPE =~ /^ipfw2$/i) {
-- system("$IPFW2_CMD table $IPFW_TABLE_NO delete $ip");
-+ system("$IPFW2_CMD table $IPFW2_TABLE_NO delete $ip");
- } elsif ($FIREWALL_TYPE =~ /^pf$/i) {
- system("$PFCTL_CMD -t $PF_TABLE -Tdelete $ip");
- }
-@@ -337,3 +337,18 @@
- }
- }
- }
-+foreach $ip (keys %list) {
-+ if($FIREWALL_TYPE =~ /^ipfw$/i)
-+ {
-+ system("$IPFW_CMD delete $list{$ip}{rulenr}");
-+ } elsif ($FIREWALL_TYPE =~ /^ipfw2$/i) {
-+ system("$IPFW2_CMD table $IPFW2_TABLE_NO delete $ip");
-+ } elsif ($FIREWALL_TYPE =~ /^pf$/i) {
-+ system("$PFCTL_CMD -t $PF_TABLE -Tdelete $ip");
-+ }
-+ syslog(LOG_ERR, "main removed block rule $list{$ip}{rulenr} for $ip (reset time of $RESET_IP seconds reached)\n");
-+ delete($list{$ip});
-+}
-+
-+# clear all SHM
-+IPC::Shareable->clean_up;