aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:43:47 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:43:47 +0000
commit2479fda868b77e795df986b855889fafdd3ba0b2 (patch)
tree4db2d03ea1e097fff4909e943542a45e7e4c3586
parent2da155a48ec7f44ae9851205494ce53f9a1ed65b (diff)
downloadports-2479fda868b77e795df986b855889fafdd3ba0b2.tar.gz
ports-2479fda868b77e795df986b855889fafdd3ba0b2.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-String-Checker/Makefile27
-rw-r--r--devel/p5-String-Checker/distinfo1
-rw-r--r--devel/p5-String-Checker/pkg-comment1
-rw-r--r--devel/p5-String-Checker/pkg-descr9
-rw-r--r--devel/p5-String-Checker/pkg-plist3
6 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d19fe7132ad1..4e5e8c8a9074 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -270,6 +270,7 @@
SUBDIR += p5-Sort-Versions
SUBDIR += p5-Storable
SUBDIR += p5-String-Approx
+ SUBDIR += p5-String-Checker
SUBDIR += p5-Term-ANSIColor
SUBDIR += p5-Term-Query
SUBDIR += p5-Term-ReadKey
diff --git a/devel/p5-String-Checker/Makefile b/devel/p5-String-Checker/Makefile
new file mode 100644
index 000000000000..328044fcd007
--- /dev/null
+++ b/devel/p5-String-Checker/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: String-Checker
+# Date created: Mon Jan 1 11:03:15 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Checker
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= String::Checker.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-String-Checker/distinfo b/devel/p5-String-Checker/distinfo
new file mode 100644
index 000000000000..d11905259b07
--- /dev/null
+++ b/devel/p5-String-Checker/distinfo
@@ -0,0 +1 @@
+MD5 (String-Checker-0.03.tar.gz) = d7187638b490464c209f6d132450f0cb
diff --git a/devel/p5-String-Checker/pkg-comment b/devel/p5-String-Checker/pkg-comment
new file mode 100644
index 000000000000..82cfc1eaf98e
--- /dev/null
+++ b/devel/p5-String-Checker/pkg-comment
@@ -0,0 +1 @@
+Perl module implementing an extensible string validation interface
diff --git a/devel/p5-String-Checker/pkg-descr b/devel/p5-String-Checker/pkg-descr
new file mode 100644
index 000000000000..c46c81927c3a
--- /dev/null
+++ b/devel/p5-String-Checker/pkg-descr
@@ -0,0 +1,9 @@
+String::Checker - An extensible string validation module (allowing commonly
+used checks on strings to be called more concisely and consistently).
+Why is this useful? If you're only checking one string, it probably
+isn't. However, if you're checking a bunch of strings (say, for
+example, CGI input parameters) against a set of expectations, this
+comes in pretty handy. As a matter of fact, the CGI::ArgChecker
+module is a simple, CGI.pm aware wrapper for this library.
+
+--will
diff --git a/devel/p5-String-Checker/pkg-plist b/devel/p5-String-Checker/pkg-plist
new file mode 100644
index 000000000000..16a70e67d564
--- /dev/null
+++ b/devel/p5-String-Checker/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/String/Checker.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Checker/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Checker