aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-06-21 17:13:06 +0000
committerRene Ladan <rene@FreeBSD.org>2016-06-21 17:13:06 +0000
commit259c036bdaf3ca239d0d9e43208a49e694d949f0 (patch)
tree996e4bd9617337d5f2ab901c2ecf29cfccaaa95a
parent41886e4ac0121236cd685bb2aee9e498e16f353e (diff)
downloadports-259c036bdaf3ca239d0d9e43208a49e694d949f0.tar.gz
ports-259c036bdaf3ca239d0d9e43208a49e694d949f0.zip
MFH: r416869 r417184
www/chromium: fix build on 9.3-amd64 www/chromium: update to 51.0.2704.103 X-MFH-with: r416869 Security: http://vuxml.freebsd.org/freebsd/d59ebed4-34be-11e6-be25-3065ec8fd3ec.html Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2016Q2/; revision=417279
-rw-r--r--www/chromium/Makefile3
-rw-r--r--www/chromium/distinfo10
-rw-r--r--www/chromium/files/extra-patch-gcc137
-rw-r--r--www/chromium/files/patch-chrome_browser_ui_views_tabs_tab__strip.cc6
4 files changed, 145 insertions, 11 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 8b2751fa8cd7..88f1f154d4e5 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 51.0.2704.84
-PORTREVISION= 1
+PORTVERSION= 51.0.2704.103
CATEGORIES= www
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # default, but needed to get distinfo correct if TEST is on
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index ed8700a25269..8a5bd013e01a 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1465247626
-SHA256 (chromium-51.0.2704.84.tar.xz) = 33a3fe1cb8fa5be7b35aa8ae00c8b0a6dc90975bfa9aea9865180b57b0a4dc6a
-SIZE (chromium-51.0.2704.84.tar.xz) = 448556852
-SHA256 (chromium-51.0.2704.84-testdata.tar.xz) = f74796ad850f874df407dd624eeb3a887d6d4fff312c79d4269f370f179490a1
-SIZE (chromium-51.0.2704.84-testdata.tar.xz) = 121441480
+TIMESTAMP = 1466191227
+SHA256 (chromium-51.0.2704.103.tar.xz) = 76735b6dc4100e84c4dbcf5b2336bf8a2eb9cc6402c31e8865878a086971d72b
+SIZE (chromium-51.0.2704.103.tar.xz) = 448638748
+SHA256 (chromium-51.0.2704.103-testdata.tar.xz) = 787ae4a7c30c3fecb605d0d362370977264938d6c8b0fa6a50a06b556b96e541
+SIZE (chromium-51.0.2704.103-testdata.tar.xz) = 121442840
diff --git a/www/chromium/files/extra-patch-gcc b/www/chromium/files/extra-patch-gcc
index 9c7e17f07dee..016b111aeca1 100644
--- a/www/chromium/files/extra-patch-gcc
+++ b/www/chromium/files/extra-patch-gcc
@@ -159,7 +159,25 @@
#include <stdlib.h>
--- ui/gfx/color_utils.cc.orig 2016-04-06 20:35:19.306577518 +0200
+++ ui/gfx/color_utils.cc 2016-04-06 20:35:49.282575724 +0200
-@@ -235,9 +235,9 @@
+@@ -42,7 +42,7 @@
+ else if (hue * 3.0 < 2.0)
+ result = temp1 + (temp2 - temp1) * (2.0 / 3.0 - hue) * 6.0;
+
+- return static_cast<int>(std::round(result * 255));
++ return static_cast<int>(round(result * 255));
+ }
+
+ // Assumes sRGB.
+@@ -85,7 +85,7 @@
+ }
+
+ uint8_t GetLuma(SkColor color) {
+- return static_cast<uint8_t>(std::round((0.299 * SkColorGetR(color)) +
++ return static_cast<uint8_t>(round((0.299 * SkColorGetR(color)) +
+ (0.587 * SkColorGetG(color)) +
+ (0.114 * SkColorGetB(color))));
+ }
+@@ -223,9 +223,9 @@
b += (255.0 - b) * ((shift.l - 0.5) * 2.0);
}
return SkColorSetARGB(alpha,
@@ -172,6 +190,21 @@
}
void BuildLumaHistogram(const SkBitmap& bitmap, int histogram[256]) {
+@@ -275,10 +275,10 @@
+ double b = (SkColorGetB(foreground) * f_weight +
+ SkColorGetB(background) * b_weight) / 255.0;
+
+- return SkColorSetARGB(static_cast<int>(std::round(normalizer)),
+- static_cast<int>(std::round(r)),
+- static_cast<int>(std::round(g)),
+- static_cast<int>(std::round(b)));
++ return SkColorSetARGB(static_cast<int>(round(normalizer)),
++ static_cast<int>(round(r)),
++ static_cast<int>(round(g)),
++ static_cast<int>(round(b)));
+ }
+
+ bool IsDark(SkColor color) {
--- media/filters/audio_clock.cc.orig 2016-04-07 11:55:00.678817033 +0200
+++ media/filters/audio_clock.cc 2016-04-07 11:55:28.152814716 +0200
@@ -121,7 +121,7 @@
@@ -225,3 +258,105 @@
ui::MouseWheelEvent::kWheelDelta);
// Adjust the remainder such that any whole scrolls we have taken action
+--- base/process/memory.h.orig 2016-06-06 21:05:12.000000000 +0200
++++ base/process/memory.h 2016-06-12 20:04:24.000000000 +0200
+@@ -6,6 +6,7 @@
+ #define BASE_PROCESS_MEMORY_H_
+
+ #include <stddef.h>
++#include <stdlib.h>
+
+ #include "base/base_export.h"
+ #include "base/process/process_handle.h"
+--- media/audio/audio_output_device.cc.orig 2016-06-06 21:05:19.000000000 +0200
++++ media/audio/audio_output_device.cc 2016-06-12 20:31:58.000000000 +0200
+@@ -426,7 +426,7 @@
+ // frames, and ask client to render audio. Since |output_bus_| is wrapping
+ // the shared memory the Render() call is writing directly into the shared
+ // memory.
+- render_callback_->Render(output_bus_.get(), std::round(frames_delayed),
++ render_callback_->Render(output_bus_.get(), round(frames_delayed),
+ frames_skipped);
+ }
+
+--- media/audio/audio_output_stream_sink.cc.orig 2016-06-06 21:05:19.000000000 +0200
++++ media/audio/audio_output_stream_sink.cc 2016-06-12 20:35:05.000000000 +0200
+@@ -85,7 +85,7 @@
+ if (!active_render_callback_)
+ return 0;
+
+- uint32_t frames_delayed = std::round(static_cast<double>(total_bytes_delay) /
++ uint32_t frames_delayed = round(static_cast<double>(total_bytes_delay) /
+ active_params_.GetBytesPerFrame());
+
+ return active_render_callback_->Render(dest, frames_delayed, frames_skipped);
+--- media/base/audio_renderer_mixer_input.cc.orig 2016-06-06 21:05:19.000000000 +0200
++++ media/base/audio_renderer_mixer_input.cc 2016-06-12 20:50:35.000000000 +0200
+@@ -164,7 +164,7 @@
+ // TODO(chcunningham): Delete this conversion and change ProvideInput to more
+ // precisely describe delay as a count of frames delayed instead of TimeDelta.
+ // See http://crbug.com/587522.
+- uint32_t frames_delayed = std::round(buffer_delay.InMicroseconds() /
++ uint32_t frames_delayed = round(buffer_delay.InMicroseconds() /
+ params_.GetMicrosecondsPerFrame());
+
+ int frames_filled = callback_->Render(audio_bus, frames_delayed, 0);
+--- media/base/audio_renderer_mixer.cc.orig 2016-06-06 21:05:19.000000000 +0200
++++ media/base/audio_renderer_mixer.cc 2016-06-12 20:52:34.000000000 +0200
+@@ -138,7 +138,7 @@
+ // expect a count of frames delayed instead of TimeDelta (less precise).
+ // See http://crbug.com/587522.
+ base::TimeDelta audio_delay = base::TimeDelta::FromMicroseconds(
+- std::round(frames_delayed * output_params_.GetMicrosecondsPerFrame()));
++ round(frames_delayed * output_params_.GetMicrosecondsPerFrame()));
+
+ master_converter_.ConvertWithDelay(audio_delay, audio_bus);
+ return audio_bus->frames();
+--- third_party/WebKit/Source/modules/battery/battery_status.h.orig 2016-06-06 21:05:36.000000000 +0200
++++ third_party/WebKit/Source/modules/battery/battery_status.h 2016-06-13 20:21:31.000000000 +0200
+@@ -46,7 +46,7 @@
+ // of reducing the possibility of fingerprinting and triggers less level
+ // change events on platforms where the granularity is high.
+ ASSERT(level >= 0 && level <= 1);
+- return std::round(level * 100) / 100.f;
++ return round(level * 100) / 100.f;
+ }
+
+ bool charging_;
+--- chrome/common/channel_info_posix.cc.orig 2016-06-06 21:05:14.000000000 +0200
++++ chrome/common/channel_info_posix.cc 2016-06-13 21:36:53.000000000 +0200
+@@ -8,6 +8,8 @@
+ #include "build/build_config.h"
+ #include "components/version_info/version_info.h"
+
++#include <stdlib.h>
++
+ namespace chrome {
+
+ namespace {
+--- chrome/browser/ui/views/tabs/tab_strip.cc.orig 2016-06-06 21:05:14.000000000 +0200
++++ chrome/browser/ui/views/tabs/tab_strip.cc 2016-06-13 22:03:03.000000000 +0200
+@@ -417,11 +417,11 @@
+ const SkColor stroke_color = tab_strip_->GetToolbarTopSeparatorColor();
+ const float alpha = SkColorGetA(stroke_color);
+ const SkAlpha shadow_alpha =
+- base::saturated_cast<SkAlpha>(std::round(2.1875f * alpha));
++ base::saturated_cast<SkAlpha>(round(2.1875f * alpha));
+ paint.setLooper(
+ CreateShadowDrawLooper(SkColorSetA(stroke_color, shadow_alpha)));
+ const SkAlpha path_alpha = static_cast<SkAlpha>(
+- std::round((pressed ? 0.875f : 0.609375f) * alpha));
++ round((pressed ? 0.875f : 0.609375f) * alpha));
+ paint.setColor(SkColorSetA(stroke_color, path_alpha));
+ canvas->DrawPath(stroke, paint);
+ } else {
+@@ -568,7 +568,7 @@
+ }
+ const SkColor stroke_color = tab_strip_->GetToolbarTopSeparatorColor();
+ const SkAlpha alpha = static_cast<SkAlpha>(
+- std::round(SkColorGetA(stroke_color) * 0.59375f));
++ round(SkColorGetA(stroke_color) * 0.59375f));
+ paint.setLooper(
+ CreateShadowDrawLooper(SkColorSetA(stroke_color, alpha)));
+ canvas->DrawPath(fill, paint);
+
diff --git a/www/chromium/files/patch-chrome_browser_ui_views_tabs_tab__strip.cc b/www/chromium/files/patch-chrome_browser_ui_views_tabs_tab__strip.cc
index d073704a674c..585931ae3236 100644
--- a/www/chromium/files/patch-chrome_browser_ui_views_tabs_tab__strip.cc
+++ b/www/chromium/files/patch-chrome_browser_ui_views_tabs_tab__strip.cc
@@ -1,6 +1,6 @@
---- chrome/browser/ui/views/tabs/tab_strip.cc.orig 2016-05-11 19:02:16 UTC
-+++ chrome/browser/ui/views/tabs/tab_strip.cc
-@@ -333,7 +333,7 @@ NewTabButton::NewTabButton(TabStrip* tab
+--- chrome/browser/ui/views/tabs/tab_strip.cc.orig 2016-06-06 21:05:14.000000000 +0200
++++ chrome/browser/ui/views/tabs/tab_strip.cc 2016-06-13 22:03:03.000000000 +0200
+@@ -331,7 +331,7 @@
: views::ImageButton(listener),
tab_strip_(tab_strip),
destroyed_(NULL) {