aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2016-06-13 15:43:53 +0000
committerJason Helfman <jgh@FreeBSD.org>2016-06-13 15:43:53 +0000
commit2ccdb9b2a033154fa87e6cedfbb8f8c02cf10cc5 (patch)
tree5bbe24525d56030e57f856c8faa6e8891793a4d0
parent8f8af74a04eda98cd58e47012aec1160371724a2 (diff)
downloadports-2ccdb9b2a033154fa87e6cedfbb8f8c02cf10cc5.tar.gz
ports-2ccdb9b2a033154fa87e6cedfbb8f8c02cf10cc5.zip
MFH: r416638 r416686
- add/enable xinerama support (default) - fix for MESAGL /usr/local/include/FTGL/ftgl.h:32:10: fatal error: 'ft2build.h' file not found Reported by: dhw Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2016Q2/; revision=416847
-rw-r--r--x11/xlockmore/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11/xlockmore/Makefile b/x11/xlockmore/Makefile
index 5b47dc570761..e4cb730d403a 100644
--- a/x11/xlockmore/Makefile
+++ b/x11/xlockmore/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xlockmore
PORTVERSION= 5.46
+PORTREVISION= 1
CATEGORIES?= x11
MASTER_SITES= http://www.tux.org/~bagleyd/xlock/ \
LOCAL/jgh/x11/${PORTNAME}/
@@ -22,7 +23,9 @@ USE_XORG= x11 xaw ice
LIB_DEPENDS+= libfreetype.so:print/freetype2
OPTIONS_DEFINE= MESAGL MB SYSLOG DISABLE_ALLOW_ROOT NICE_ONLY BLANK_ONLY \
- KERBEROS4 BAD_PAM GTK2 TIME_BOMB CUSTOMIZATION MAGICK JP
+ KERBEROS4 BAD_PAM GTK2 TIME_BOMB CUSTOMIZATION MAGICK JP \
+ XINERAMA
+OPTIONS_DEFAULT= XINERAMA
OPTIONS_SUB= yes
MESAGL_DESC= Mesa 3D (for GL modes)
@@ -64,7 +67,7 @@ KRB5LIB= -L${KRB5_HOME}/lib
CONFIGURE_ARGS+= --with-mesa
MESALIB= -lpthread
USE_GL= yes
-CFLAGS+= -I${LOCALBASE}/include/FTGL
+CFLAGS+= -I${LOCALBASE}/include/FTGL -I${LOCALBASE}/include/freetype2
.else
CONFIGURE_ARGS+= --without-mesa --without-opengl
.endif
@@ -140,6 +143,10 @@ CONFIGURE_ENV+= XLOCKLIBS="${KRB5LIB} ${KRB4LIB} ${MESALIB}"
CONFIGURE_ARGS+= --disable-allow-root
.endif
+.if ${PORT_OPTIONS:MXINERAMA}
+CONFIGURE_ARGS+= --with-xinerama
+.endif
+
.if ${PORT_OPTIONS:MPAM} && empty(PORT_OPTIONS:MBAD_PAM)
pre-extract:
@${ECHO}