aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-11-19 23:41:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-11-19 23:41:55 +0000
commit2d68f126de221d6caed2c560840eae9b231eaaf0 (patch)
treea4e626dcfcfc7a91af456eb7e15fa4056a883f49
parent07b27888644efc66d4ed412de3c7ba9d7b2b54af (diff)
downloadports-2d68f126de221d6caed2c560840eae9b231eaaf0.tar.gz
ports-2d68f126de221d6caed2c560840eae9b231eaaf0.zip
Notes
-rw-r--r--accessibility/java-access-bridge/Makefile1
-rw-r--r--astro/gpsdrive/Makefile1
-rw-r--r--audio/gdam/Makefile1
-rw-r--r--audio/gsi/Makefile1
-rw-r--r--benchmarks/iozone/Makefile1
-rw-r--r--comms/hf/Makefile1
-rw-r--r--comms/hylafax/Makefile1
-rw-r--r--devel/gauche-sdl/Makefile1
-rw-r--r--devel/gcvs/Makefile1
-rw-r--r--devel/gindent/Makefile1
-rw-r--r--devel/gsoap/Makefile1
-rw-r--r--devel/hp48cc/Makefile1
-rw-r--r--devel/hs-hmake/Makefile1
-rw-r--r--devel/icu2/Makefile1
-rw-r--r--editors/gphpedit/Makefile1
-rw-r--r--emulators/generator-cbiere/Makefile1
-rw-r--r--emulators/generator/Makefile1
-rw-r--r--emulators/gngeo/Makefile1
-rw-r--r--emulators/gxemul/Makefile1
-rw-r--r--games/gnubg/Makefile1
-rw-r--r--games/gnushogi/Makefile1
-rw-r--r--games/gtkpool/Makefile1
-rw-r--r--games/holotz-castle/Makefile1
-rw-r--r--graphics/IPA/Makefile1
-rw-r--r--graphics/gauche-gl/Makefile1
-rw-r--r--graphics/iiview/Makefile1
-rw-r--r--japanese/FreeWnn-server/Makefile1
-rw-r--r--japanese/ipadic/Makefile1
-rw-r--r--japanese/libslang/Makefile1
-rw-r--r--japanese/mh/Makefile1
-rw-r--r--japanese/migemo/Makefile1
-rw-r--r--japanese/prime/Makefile1
-rw-r--r--x11/gambas2-gb-qt-kde/Makefile2
33 files changed, 34 insertions, 0 deletions
diff --git a/accessibility/java-access-bridge/Makefile b/accessibility/java-access-bridge/Makefile
index 662282f99ef9..b3b5caa70241 100644
--- a/accessibility/java-access-bridge/Makefile
+++ b/accessibility/java-access-bridge/Makefile
@@ -25,6 +25,7 @@ USE_JAVA= 1.4+
JAVA_OS= native
USE_GMAKE= yes
CONFIGURE_ARGS= --without-gcj-compile --with-jardir=${JAVAJARDIR}
+MAKE_JOBS_UNSAFE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${prefix}/share/jar|${JAVAJARDIR}|' \
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 0da694afe5c9..0e89cc39778d 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -21,6 +21,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gtk20
USE_AUTOTOOLS= libtool:22
+MAKE_JOBS_UNSAFE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
diff --git a/audio/gdam/Makefile b/audio/gdam/Makefile
index b104fa3e91d5..a10c02af8579 100644
--- a/audio/gdam/Makefile
+++ b/audio/gdam/Makefile
@@ -23,6 +23,7 @@ USE_GMAKE= yes
USE_GNOME= libglade
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
post-patch:
@${REINPLACE_CMD} -e 's|`$$XMMS_CONFIG --libs`|"`$$XMMS_CONFIG --libs` ${PTHREAD_LIBS}"|' ${WRKSRC}/configure
diff --git a/audio/gsi/Makefile b/audio/gsi/Makefile
index 2bc740467f1a..6987fd08e286 100644
--- a/audio/gsi/Makefile
+++ b/audio/gsi/Makefile
@@ -18,6 +18,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" MYFLAGS="${CFLAGS}" OPTIMIZE=""
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
MANCOMPRESSED= no
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 59a5dc1561c4..3acda16cbbf2 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -22,6 +22,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src/current
MAKEFILE= makefile
MAKE_ARGS= freebsd CFLAGS="${CFLAGS}"
ALL_TARGET=
+MAKE_JOBS_UNSAFE= yes
MAN1= iozone.1
PLIST_FILES= bin/iozone
diff --git a/comms/hf/Makefile b/comms/hf/Makefile
index a63095c3306d..563b16502bca 100644
--- a/comms/hf/Makefile
+++ b/comms/hf/Makefile
@@ -20,6 +20,7 @@ USE_GNOME= gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}
+MAKE_JOBS_UNSAFE= yes
MANLANG= "" "de.ISO8859-1"
MAN1= hf.1 hfterm.1 hfkernel.1
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 3e93ca1fe4b6..b88b70330e23 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -28,6 +28,7 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=-I/usr/include \
--with-DIR_HTML="${DOCSDIR}"
CFLAGS+= -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -Wall -L${LOCALBASE}/lib
+MAKE_JOBS_UNSAFE= yes
PORTDOCS= RELEASENOTES-4.3.txt RELEASENOTES-4.4.txt RELEASENOTES-6.0.txt
SUB_FILES= pkg-message
diff --git a/devel/gauche-sdl/Makefile b/devel/gauche-sdl/Makefile
index 723d52ec8f71..02c2fa388890 100644
--- a/devel/gauche-sdl/Makefile
+++ b/devel/gauche-sdl/Makefile
@@ -27,6 +27,7 @@ PORTFAKENAME= Gauche-sdl-${PORTVERSION}
USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
CFLAGS+= -fPIC
+MAKE_JOBS_UNSAFE= yes
pre-configure:
.for DIR in . image mixer ttf
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index 6017d43336bf..d3c8a81fdf24 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -30,6 +30,7 @@ MAN5= cvs.5
MAN8= cvsbug.8
INFO= cvs cvsclient
USE_AUTOTOOLS= automake:15:env autoconf:262:env
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/gindent/Makefile b/devel/gindent/Makefile
index 7a9ac824ba1a..14f437cd1929 100644
--- a/devel/gindent/Makefile
+++ b/devel/gindent/Makefile
@@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DBERKELEY_DEFAULTS=1" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --program-prefix=g
+MAKE_JOBS_UNSAFE= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/devel/gsoap/Makefile b/devel/gsoap/Makefile
index a0e4da664e93..574e6c980e48 100644
--- a/devel/gsoap/Makefile
+++ b/devel/gsoap/Makefile
@@ -16,6 +16,7 @@ COMMENT= Generator Tools for Coding SOAP/XML Web Services in C and C++
GNU_CONFIGURE= yes
USE_GNOME= gnomehack gnometarget
+MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-2.7
diff --git a/devel/hp48cc/Makefile b/devel/hp48cc/Makefile
index 1fb6fb9a3385..89a9f19883cb 100644
--- a/devel/hp48cc/Makefile
+++ b/devel/hp48cc/Makefile
@@ -17,6 +17,7 @@ COMMENT= C-like compiler that translates input code to the HP48 RPN language
USE_BISON= build
GNU_CONFIGURE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+MAKE_JOBS_UNSAFE= yes
MAN1= ${PORTNAME}.1
diff --git a/devel/hs-hmake/Makefile b/devel/hs-hmake/Makefile
index 89c1f0e9a0cc..13dcbdcb5e6f 100644
--- a/devel/hs-hmake/Makefile
+++ b/devel/hs-hmake/Makefile
@@ -25,6 +25,7 @@ LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --prefix=${PREFIX}
USE_GMAKE= YES
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/icu2/Makefile b/devel/icu2/Makefile
index 18e9c0f4ec69..6367b34e56a1 100644
--- a/devel/icu2/Makefile
+++ b/devel/icu2/Makefile
@@ -42,6 +42,7 @@ CONFIGURE_ENV+= THREADSCPPFLAGS="${PTHREAD_CFLAGS}" \
CONFIGURE_ENV+= CXXFLAGS="-O3"
CONFIGURE_ENV+= CFLAGS="-O3"
USE_GMAKE= yes
+MAKE_JOBS_UNSAFE= yes
MAN1+= gencnval.1
MAN1+= genrb.1
diff --git a/editors/gphpedit/Makefile b/editors/gphpedit/Makefile
index 7548481789d7..f12767040d5b 100644
--- a/editors/gphpedit/Makefile
+++ b/editors/gphpedit/Makefile
@@ -21,6 +21,7 @@ USE_GNOME= gnomeprefix gnomehack libgnomeui libgtkhtml
USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_UNSAFE= yes
.if !defined(WITHOUT_PHP)
USE_PHP= yes
diff --git a/emulators/generator-cbiere/Makefile b/emulators/generator-cbiere/Makefile
index 7ffcd89dc2c7..e2016a581e37 100644
--- a/emulators/generator-cbiere/Makefile
+++ b/emulators/generator-cbiere/Makefile
@@ -23,6 +23,7 @@ USE_BZIP2= yes
USE_SDL= sdl
USE_GMAKE= yes
USE_GNOME= gtk12
+MAKE_JOBS_UNSAFE= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
RAZE "Use RAZE z80 emulation (only for i386)" on \
diff --git a/emulators/generator/Makefile b/emulators/generator/Makefile
index d86f7608ddbc..402ff7a3ab06 100644
--- a/emulators/generator/Makefile
+++ b/emulators/generator/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS+=--with-gtk
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
+MAKE_JOBS_UNSAFE= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
RAZE "Use RAZE z80 emulation (only for i386)" on \
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index eb64448d2e4c..9bce7aa35c0e 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -22,6 +22,7 @@ USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name="" --disable-gp2x
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_JOBS_UNSAFE= yes
CPPFLAGS= ${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
LDFLAGS= `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 9482c1eb44ef..f298389cbad4 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -18,6 +18,7 @@ OPTIONS= X11 "X11 support" on
HAS_CONFIGURE= yes
ALL_TARGET= build
+MAKE_JOBS_UNSAFE= yes
MAN1= gxemul.1
PORTDOCS= *
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index a8248f6b7aa8..effe684321c9 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -40,6 +40,7 @@ USE_GMAKE= yes
USE_PYTHON= 2.0+
USE_AUTOTOOLS= libtool:22 automake:110
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/games/gnushogi/Makefile b/games/gnushogi/Makefile
index ff337cb771ac..d5f65ca23ed9 100644
--- a/games/gnushogi/Makefile
+++ b/games/gnushogi/Makefile
@@ -17,6 +17,7 @@ COMMENT= GNU version of Shogi
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-x --without-xshogi
+MAKE_JOBS_UNSAFE= yes
MAN6= gnushogi.6
INFO= gnushogi
diff --git a/games/gtkpool/Makefile b/games/gtkpool/Makefile
index 11d314752a63..888ae3dda68e 100644
--- a/games/gtkpool/Makefile
+++ b/games/gtkpool/Makefile
@@ -16,6 +16,7 @@ COMMENT= A 2D pool game using the GTK+ toolkit
GNU_CONFIGURE= yes
USE_GNOME= gtk12
+MAKE_JOBS_UNSAFE= yes
post-patch:
@${REINPLACE_CMD} -e 's,-O2 -O0 -Wall `gtk-config --cflags` -lgtk -lgdk -lglib -lm -lX11,${CXXFLAGS} `gtk-config --cflags` `gtk-config --libs`,' ${WRKSRC}/configure
diff --git a/games/holotz-castle/Makefile b/games/holotz-castle/Makefile
index 147bb78cdd05..4770af808d97 100644
--- a/games/holotz-castle/Makefile
+++ b/games/holotz-castle/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= ppl@nbnet.nb.ca
COMMENT= A platform game with high doses of mystery
MAKE_ARGS= HC_BASE=${PREFIX}/share/${PORTNAME}/ HC_BIN_DIR=${PREFIX}/bin/
+MAKE_JOBS_UNSAFE= yes
USE_GL= gl
USE_SDL= image mixer sdl ttf
diff --git a/graphics/IPA/Makefile b/graphics/IPA/Makefile
index 097b77890a0b..55fe39d3c82c 100644
--- a/graphics/IPA/Makefile
+++ b/graphics/IPA/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
INSTALL_TARGET= pure_install
+MAKE_JOBS_UNSAFE= yes
MAN1= iterm.1
MAN3= IPA.3 IPA::Geometry.3 IPA::Global.3 IPA::Local.3 IPA::Misc.3 \
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
index fd2bd9de09c1..42fc22ee1895 100644
--- a/graphics/gauche-gl/Makefile
+++ b/graphics/gauche-gl/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= glut
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
diff --git a/graphics/iiview/Makefile b/graphics/iiview/Makefile
index a3b6da2bc187..900685bdb856 100644
--- a/graphics/iiview/Makefile
+++ b/graphics/iiview/Makefile
@@ -21,6 +21,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libpng.a:${PORTSDIR}/graphics/png \
USE_XORG= xpm x11
PLIST_FILES= bin/iiview
+MAKE_JOBS_UNSAFE= yes
MAN1= iiview.1
MANCOMPRESSED= yes
diff --git a/japanese/FreeWnn-server/Makefile b/japanese/FreeWnn-server/Makefile
index 67bf18e2aace..1a630addea5f 100644
--- a/japanese/FreeWnn-server/Makefile
+++ b/japanese/FreeWnn-server/Makefile
@@ -30,6 +30,7 @@ INSTALL_TARGET= install install.man
SUB_FILES= pkg-install
SUB_LIST= RC_SUBR=${RC_SUBR}
PKGINSTALL= ${WRKDIR}/pkg-install
+MAKE_JOBS_UNSAFE= yes
WNNTYPE?= WNN
CONFIGURE_ARGS= --enable-libraries=no \
diff --git a/japanese/ipadic/Makefile b/japanese/ipadic/Makefile
index e23628dc85c5..e1302126b563 100644
--- a/japanese/ipadic/Makefile
+++ b/japanese/ipadic/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= chasen:${PORTSDIR}/japanese/chasen-base
CONFIGURE_ARGS= --with-dicdir=${PREFIX}/share/chasen/dic
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
post-install:
${INSTALL_DATA} ${WRKSRC}/chasenrc \
diff --git a/japanese/libslang/Makefile b/japanese/libslang/Makefile
index 8c11488bad6c..d95bc799c5d5 100644
--- a/japanese/libslang/Makefile
+++ b/japanese/libslang/Makefile
@@ -26,6 +26,7 @@ CONFIGURE_ARGS= --includedir=${PREFIX}/include/slang
ALL_TARGET= all elf
INSTALL_TARGET= install-elf
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
post-install:
${INSTALL_DATA} ${WRKSRC}/slang-j.doc ${PREFIX}/share/doc/slang
diff --git a/japanese/mh/Makefile b/japanese/mh/Makefile
index 12074a2a92c6..72ad2ac23f16 100644
--- a/japanese/mh/Makefile
+++ b/japanese/mh/Makefile
@@ -27,6 +27,7 @@ JP_VERSION= 3.05
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-batchmode \
--enable-apop=${PREFIX}/etc/pop.auth --enable-rpop
+MAKE_JOBS_UNSAFE= yes
MAN1= ali.1 anno.1 bbc.1 burst.1 comp.1 dist.1 folder.1 forw.1 inc.1 mark.1 \
mh-chart.1 mh.1 mhl.1 mhmail.1 mhn.1 mhook.1 mhparam.1 mhpath.1 \
diff --git a/japanese/migemo/Makefile b/japanese/migemo/Makefile
index 884d9c819235..5a47ccd8f605 100644
--- a/japanese/migemo/Makefile
+++ b/japanese/migemo/Makefile
@@ -32,6 +32,7 @@ RUN_DEPENDS+= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
${RUBY_SITELIBDIR}/bsearch.rb:${PORTSDIR}/devel/ruby-bsearch
CONFIGURE_ARGS+=--with-rubydir=${RUBY_SITELIBDIR}
+MAKE_JOBS_UNSAFE= yes
SKKDIC_FILE= SKK-JISYO.L-20060709
diff --git a/japanese/prime/Makefile b/japanese/prime/Makefile
index 3b53b46a1eb8..008ecc6c199e 100644
--- a/japanese/prime/Makefile
+++ b/japanese/prime/Makefile
@@ -27,6 +27,7 @@ USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rubydir=${RUBY_SITELIBDIR}
USE_AUTOTOOLS= automake:19 autoconf:262
+MAKE_JOBS_UNSAFE= yes
PLIST_SUB= LOCALBASE=${LOCALBASE}
diff --git a/x11/gambas2-gb-qt-kde/Makefile b/x11/gambas2-gb-qt-kde/Makefile
index ffadb231171a..6337e23cc073 100644
--- a/x11/gambas2-gb-qt-kde/Makefile
+++ b/x11/gambas2-gb-qt-kde/Makefile
@@ -12,4 +12,6 @@ COMMENT= The gambas KDE component
MASTERDIR= ${.CURDIR}/../../lang/gambas2-base
+MAKE_JOBS_UNSAFE= yes
+
.include "${MASTERDIR}/Makefile"