aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-06-20 19:14:29 +0000
committerMark Felder <feld@FreeBSD.org>2016-06-20 19:14:29 +0000
commit3ff87421c93b360de1cd815790ea93671d2e3dd5 (patch)
tree37ca9bfe03c1907cf5c3bcc0d3e565f9f21aba13
parent8de7baef3a94279880962e8db7a42df514be9849 (diff)
downloadports-3ff87421c93b360de1cd815790ea93671d2e3dd5.tar.gz
ports-3ff87421c93b360de1cd815790ea93671d2e3dd5.zip
MFH: r417174
textproc/libxslt: Update to 1.1.29 Changelog: https://git.gnome.org/browse/libxslt/commit/NEWS?id=9a1b3ddf6034aa2f6a30b4b7ea4bfc3c4037cd58 Absent from the Changelog are the CVEs Google discovered, CVE-2016-1683 and CVE-2016-1684. This library needs to be updated to ensure www/chromium is no longer vulnerable to these CVEs. Additionally the changelog notes a fix for CVE-2015-7995, but we solved that previously with a patch to the port. PR: 210298 Security: CVE-2016-1683 Security: CVE-2016-1684 Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2016Q2/; revision=417175
-rw-r--r--textproc/libxslt/Makefile4
-rw-r--r--textproc/libxslt/distinfo5
-rw-r--r--textproc/libxslt/files/patch-CVE-2015-799529
-rw-r--r--textproc/libxslt/files/patch-xsltproc_xsltproc.c24
-rw-r--r--textproc/libxslt/pkg-plist2
5 files changed, 6 insertions, 58 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index 7e0f9a33eb40..463b8ceb53d5 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= libxslt
-PORTVERSION= 1.1.28
-PORTREVISION?= 8
+PORTVERSION= 1.1.29
+PORTREVISION?= 0
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://xmlsoft.org/libxml2/ \
http://xmlsoft.org/sources/ \
diff --git a/textproc/libxslt/distinfo b/textproc/libxslt/distinfo
index 3afda2ff9af3..8c0f5099b69f 100644
--- a/textproc/libxslt/distinfo
+++ b/textproc/libxslt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome2/libxslt-1.1.28.tar.gz) = 5fc7151a57b89c03d7b825df5a0fae0a8d5f05674c0e7cf2937ecec4d54a028c
-SIZE (gnome2/libxslt-1.1.28.tar.gz) = 3435907
+TIMESTAMP = 1465983151
+SHA256 (gnome2/libxslt-1.1.29.tar.gz) = b5976e3857837e7617b29f2249ebb5eeac34e249208d31f1fbf7a6ba7a4090ce
+SIZE (gnome2/libxslt-1.1.29.tar.gz) = 3428524
diff --git a/textproc/libxslt/files/patch-CVE-2015-7995 b/textproc/libxslt/files/patch-CVE-2015-7995
deleted file mode 100644
index 9e83afc98b02..000000000000
--- a/textproc/libxslt/files/patch-CVE-2015-7995
+++ /dev/null
@@ -1,29 +0,0 @@
-From 7ca19df892ca22d9314e95d59ce2abdeff46b617 Mon Sep 17 00:00:00 2001
-From: Daniel Veillard <veillard@redhat.com>
-Date: Thu, 29 Oct 2015 19:33:23 +0800
-Subject: Fix for type confusion in preprocessing attributes
-
-CVE-2015-7995 http://www.openwall.com/lists/oss-security/2015/10/27/10
-We need to check that the parent node is an element before dereferencing
-its namespace
----
- libxslt/preproc.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/libxslt/preproc.c b/libxslt/preproc.c
-index 0eb80a0..7f69325 100644
---- libxslt/preproc.c
-+++ libxslt/preproc.c
-@@ -2249,7 +2249,8 @@ xsltStylePreCompute(xsltStylesheetPtr style, xmlNodePtr inst) {
- } else if (IS_XSLT_NAME(inst, "attribute")) {
- xmlNodePtr parent = inst->parent;
-
-- if ((parent == NULL) || (parent->ns == NULL) ||
-+ if ((parent == NULL) ||
-+ (parent->type != XML_ELEMENT_NODE) || (parent->ns == NULL) ||
- ((parent->ns != inst->ns) &&
- (!xmlStrEqual(parent->ns->href, inst->ns->href))) ||
- (!xmlStrEqual(parent->name, BAD_CAST "attribute-set"))) {
---
-cgit v0.11.2
-
diff --git a/textproc/libxslt/files/patch-xsltproc_xsltproc.c b/textproc/libxslt/files/patch-xsltproc_xsltproc.c
deleted file mode 100644
index 485d4213164a..000000000000
--- a/textproc/libxslt/files/patch-xsltproc_xsltproc.c
+++ /dev/null
@@ -1,24 +0,0 @@
-From 5af7ad745323004984287e48b42712e7305de35c Mon Sep 17 00:00:00 2001
-From: Per Hedeland <per@hedeland.org>
-Date: Fri, 13 Dec 2013 14:43:06 +0100
-Subject: Make --maxvars option work
-
-
-diff --git a/xsltproc/xsltproc.c b/xsltproc/xsltproc.c
-index b22df37..66d8cbb 100644
---- xsltproc/xsltproc.c
-+++ xsltproc/xsltproc.c
-@@ -803,6 +803,10 @@ main(int argc, char **argv)
- (!strcmp(argv[i], "--maxdepth"))) {
- i++;
- continue;
-+ } else if ((!strcmp(argv[i], "-maxvars")) ||
-+ (!strcmp(argv[i], "--maxvars"))) {
-+ i++;
-+ continue;
- } else if ((!strcmp(argv[i], "-maxparserdepth")) ||
- (!strcmp(argv[i], "--maxparserdepth"))) {
- i++;
---
-cgit v0.10.2
-
diff --git a/textproc/libxslt/pkg-plist b/textproc/libxslt/pkg-plist
index 9910d7c3d590..10a3a538a952 100644
--- a/textproc/libxslt/pkg-plist
+++ b/textproc/libxslt/pkg-plist
@@ -32,7 +32,7 @@ lib/libexslt.so.8
lib/libxslt.a
lib/libxslt.so
lib/libxslt.so.1
-lib/libxslt.so.1.1.28
+lib/libxslt.so.1.1.29
lib/libxslt.so.2
lib/xsltConf.sh
libdata/pkgconfig/libexslt.pc