aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2016-06-26 18:14:13 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2016-06-26 18:14:13 +0000
commit510ea0a5f18b9bfce7b426e7eeb7cca41003130f (patch)
tree00ede17d41eff2ee8c6a2e7aafdc8e3b1e8bc137
parent1b8a59171ac0cc7138b62b9fc24a959a0b28258b (diff)
downloadports-510ea0a5f18b9bfce7b426e7eeb7cca41003130f.tar.gz
ports-510ea0a5f18b9bfce7b426e7eeb7cca41003130f.zip
MFH: r417360
- Update tomcat-native to 1.2.7 release. - Update tomcat7 to 7.0.70 release. - Update tomcat8 to 8.0.36 release. PR: 209669 Submitted by: geoffroy desvernay <dgeo@centrale-marseille.fr> Approved by: ports-secteam (with hat) Security: CVE-2016-3092 Security: https://vuxml.FreeBSD.org/freebsd/cbceeb49-3bc7-11e6-8e82-002590263bf5.html
Notes
Notes: svn path=/branches/2016Q2/; revision=417597
-rw-r--r--www/tomcat-native/Makefile12
-rw-r--r--www/tomcat-native/distinfo5
-rw-r--r--www/tomcat7/Makefile2
-rw-r--r--www/tomcat7/distinfo5
-rw-r--r--www/tomcat7/pkg-plist7
-rw-r--r--www/tomcat8/Makefile2
-rw-r--r--www/tomcat8/distinfo5
-rw-r--r--www/tomcat8/pkg-plist4
8 files changed, 22 insertions, 20 deletions
diff --git a/www/tomcat-native/Makefile b/www/tomcat-native/Makefile
index cca6de82234c..2db4f52d9276 100644
--- a/www/tomcat-native/Makefile
+++ b/www/tomcat-native/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tomcat-native
-PORTVERSION= 1.2.2
+PORTVERSION= 1.2.7
CATEGORIES= www java
MASTER_SITES= APACHE/tomcat/tomcat-connectors/native/${PORTVERSION}/source
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -18,6 +18,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/native
USES= libtool
USE_OPENSSL= yes
+WITH_OPENSSL_PORT= yes
USE_JAVA= yes
USE_LDCONFIG= yes
JAVA_VERSION= 1.6+
@@ -29,12 +30,9 @@ CONFIGURE_ARGS= --with-apr=${LOCALBASE} \
PLIST_FILES= lib/libtcnative-1.a \
lib/libtcnative-1.so \
lib/libtcnative-1.so.0 \
- lib/libtcnative-1.so.0.2.2
-
-.include <bsd.port.options.mk>
+ lib/libtcnative-1.so.0.2.7
-.if ${OSVERSION} < 1000028
-WITH_OPENSSL_PORT= yes
-.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtcnative-1.so.0.2.7
.include <bsd.port.mk>
diff --git a/www/tomcat-native/distinfo b/www/tomcat-native/distinfo
index b2483aae8619..64624d37c936 100644
--- a/www/tomcat-native/distinfo
+++ b/www/tomcat-native/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tomcat-native-1.2.2-src.tar.gz) = 9bd4deb1a816efda8208bfb4f55ee1689571e1d05a5c1e84faf2ad1021a9cae6
-SIZE (tomcat-native-1.2.2-src.tar.gz) = 400183
+TIMESTAMP = 1466667598
+SHA256 (tomcat-native-1.2.7-src.tar.gz) = 19e87bc6ea7f763bf9e6515f8c31d8e9bb3e0c1132b36769cdf32c6702723d25
+SIZE (tomcat-native-1.2.7-src.tar.gz) = 390573
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index 8bab392401e5..3a777cf58f2c 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tomcat
-PORTVERSION= 7.0.68
+PORTVERSION= 7.0.70
CATEGORIES= www java
MASTER_SITES= APACHE/tomcat/tomcat-7/v${PORTVERSION}/bin
PKGNAMESUFFIX= 7
diff --git a/www/tomcat7/distinfo b/www/tomcat7/distinfo
index ab40c31d501d..087fa453f81a 100644
--- a/www/tomcat7/distinfo
+++ b/www/tomcat7/distinfo
@@ -1,2 +1,3 @@
-SHA256 (apache-tomcat-7.0.68.tar.gz) = 2c1a02422f265607de733521e54f18613e9dd5efc2861914fe45a858227bb8e0
-SIZE (apache-tomcat-7.0.68.tar.gz) = 8900822
+TIMESTAMP = 1466667531
+SHA256 (apache-tomcat-7.0.70.tar.gz) = 13f33616a3352e4fce548e042adfdd824353d0b48a42e1606daace7916868c74
+SIZE (apache-tomcat-7.0.70.tar.gz) = 8924465
diff --git a/www/tomcat7/pkg-plist b/www/tomcat7/pkg-plist
index df4eb74ad809..c65137f3c79d 100644
--- a/www/tomcat7/pkg-plist
+++ b/www/tomcat7/pkg-plist
@@ -341,7 +341,8 @@
%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoAnnotation.class
%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoAnnotation.java
%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoEndpoint$1.class
-%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoEndpoint$EchoMessageHandler.class
+%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoEndpoint$EchoMessageHandlerBinary.class
+%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoEndpoint$EchoMessageHandlerText.class
%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoEndpoint.class
%%T%%/webapps/examples/WEB-INF/classes/websocket/echo/EchoEndpoint.java
%%T%%/webapps/examples/WEB-INF/classes/websocket/snake/Direction.class
@@ -626,5 +627,5 @@
@dir %%T%%/endorsed
@dir %%T%%/logs
@dir %%T%%/work
-@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%T%%/conf %D/%%T%%/logs %D/%%T%%/temp %D/%%T%%/webapps %D/%%T%%/work
-@unexec [ ! -d %D/%%T%% ] || echo If permanently deleting this package, %D/%%T%% must be removed manually
+@postexec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%T%%/conf %D/%%T%%/logs %D/%%T%%/temp %D/%%T%%/webapps %D/%%T%%/work
+@postunexec [ ! -d %D/%%T%% ] || echo If permanently deleting this package, %D/%%T%% must be removed manually
diff --git a/www/tomcat8/Makefile b/www/tomcat8/Makefile
index 563436bd47ed..f5c7eceee675 100644
--- a/www/tomcat8/Makefile
+++ b/www/tomcat8/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tomcat
-PORTVERSION= 8.0.30
+PORTVERSION= 8.0.36
CATEGORIES= www java
MASTER_SITES= APACHE/tomcat/tomcat-8/v${PORTVERSION}/bin
PKGNAMESUFFIX= 8
diff --git a/www/tomcat8/distinfo b/www/tomcat8/distinfo
index f3804c7bb3ec..ca98d37e4aeb 100644
--- a/www/tomcat8/distinfo
+++ b/www/tomcat8/distinfo
@@ -1,2 +1,3 @@
-SHA256 (apache-tomcat-8.0.30.tar.gz) = 2fc3dde305e08388a12bd2868063ab6829a1d70acd9affe3a8707bd9679e0059
-SIZE (apache-tomcat-8.0.30.tar.gz) = 9150593
+TIMESTAMP = 1466677342
+SHA256 (apache-tomcat-8.0.36.tar.gz) = 7963464d86faf8416b92fb2b04c70da9759c7c332e1700c1e9f581883b4db664
+SIZE (apache-tomcat-8.0.36.tar.gz) = 9277365
diff --git a/www/tomcat8/pkg-plist b/www/tomcat8/pkg-plist
index a819c888c87e..4f1a5220d1da 100644
--- a/www/tomcat8/pkg-plist
+++ b/www/tomcat8/pkg-plist
@@ -37,7 +37,7 @@
%%T%%/lib/catalina-storeconfig.jar
%%T%%/lib/catalina-tribes.jar
%%T%%/lib/catalina.jar
-%%T%%/lib/ecj-4.4.2.jar
+%%T%%/lib/ecj-4.5.jar
%%T%%/lib/el-api.jar
%%T%%/lib/jasper-el.jar
%%T%%/lib/jasper.jar
@@ -645,4 +645,4 @@
@dir %%T%%/work
@owner
@group
-@unexec [ ! -d %D/%%T%% ] || echo If permanently deleting this package, %D/%%T%% must be removed manually
+@postunexec [ ! -d %D/%%T%% ] || echo If permanently deleting this package, %D/%%T%% must be removed manually