aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-14 23:07:34 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-14 23:07:34 +0000
commit64d3a14f18cf29d325b3120ca1cc1e3b9b0e1170 (patch)
treec9ffea9384aa7e8b41d33adb42ab91b5c727bf7b
parent2b65c8f54ac66486cf12433f0f1b55b948a073dd (diff)
downloadports-64d3a14f18cf29d325b3120ca1cc1e3b9b0e1170.tar.gz
ports-64d3a14f18cf29d325b3120ca1cc1e3b9b0e1170.zip
MFH: r412619 r412619 r415831 r415882
Mainly: update to 9.9.9-P1 and 9.10.4-P1. There are bug fixes and small security issues that need addressing. Sponsored by: Absolight
Notes
Notes: svn path=/branches/2016Q2/; revision=416912
-rw-r--r--dns/bind910/Makefile21
-rw-r--r--dns/bind910/distinfo5
-rw-r--r--dns/bind99/Makefile21
-rw-r--r--dns/bind99/distinfo9
4 files changed, 32 insertions, 24 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index fc2bc61a544a..1c1c4c48aa87 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -29,7 +29,7 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.10.3-P4
+ISCVERSION= 9.10.4-P1
MAKE_JOBS_UNSAFE= yes
@@ -49,6 +49,7 @@ CONFIGURE_ARGS+= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
--with-readline=-ledit \
+ --with-dlopen=yes \
--sysconfdir=${ETCDIR}
.if defined(BIND_TOOLS_SLAVE)
CONFIGURE_ARGS+= --disable-shared
@@ -69,7 +70,7 @@ OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
-OPTIONS_DEFAULT+= RRL
+OPTIONS_DEFAULT+= RRL DLZ_FILESYSTEM
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS NEWSTATS GEOIP \
MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE
OPTIONS_GROUP= DLZ
@@ -219,15 +220,9 @@ SUB_LIST+= NOBASE="" BASE="@comment "
USE_RC_SUBR+= named
SUB_FILES+= named.conf
.endif # !defined(BIND_TOOLS_SLAVE)
-.if ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1}
-WITH_OPENSSL_PORT=yes
-.endif
.else
PLIST_SUB+= NOBASE="@comment " BASE=""
SUB_LIST+= NOBASE="@comment " BASE=""
-.if ${PORT_OPTIONS:MSSL}
-WITH_OPENSSL_PORT= yes
-.endif
.endif
PKGDEINSTALL= ${PKGINSTALL}
@@ -235,6 +230,14 @@ PKGDEINSTALL= ${PKGINSTALL}
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && defined(WITH_OPENSSL_BASE)
+BROKEN= OpenSSL from the base system does not support GOST, add \
+ WITH_OPENSSL_PORT=yes to your /etc/make.conf and rebuild everything \
+ that needs SSL.
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|readline/readline.h|editline/readline.h|; \
s|readline/history.h|histedit.h|' \
@@ -293,4 +296,4 @@ post-install:
.endif # BIND_TOOLS_SLAVE
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind910/distinfo b/dns/bind910/distinfo
index f39e2ea516ce..7ae67c21ac1a 100644
--- a/dns/bind910/distinfo
+++ b/dns/bind910/distinfo
@@ -1,2 +1,3 @@
-SHA256 (bind-9.10.3-P4.tar.gz) = 2ac044b5fbdf45fb45107af0df961b3b7cb5262a3bf1948ed3fe7a170dd13e3e
-SIZE (bind-9.10.3-P4.tar.gz) = 8529535
+TIMESTAMP = 1464252479
+SHA256 (bind-9.10.4-P1.tar.gz) = 7c3b7d1afe48a6bbead8f11f6971fb09eb57fa257dc32a088fcc20a0218131a2
+SIZE (bind-9.10.4-P1.tar.gz) = 9293605
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 4373bf8f267e..035b8acb4b21 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -15,7 +15,7 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.9.8-P4
+ISCVERSION= 9.9.9-P1
MAKE_JOBS_UNSAFE= yes
@@ -35,6 +35,7 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
--with-readline=-ledit \
+ --with-dlopen=yes \
--sysconfdir=${ETCDIR}
ETCDIR= ${PREFIX}/etc/namedb
@@ -42,7 +43,7 @@ CONFLICTS= bind9*-9.[45678].* bind9*-sdb-9.[45678].* bind-tools-9.*
SUB_FILES= pkg-message
-OPTIONS_DEFAULT= IPV6 SSL THREADS SIGCHASE IDN GSSAPI_NONE RRL
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE RRL DLZ_FILESYSTEM
OPTIONS_DEFINE= SSL IDN REPLACE_BASE LARGE_FILE FIXED_RRSET SIGCHASE \
IPV6 THREADS FILTER_AAAA GOST PYTHON START_LATE MINCACHE \
LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS RPZ_PATCH NEWSTATS \
@@ -179,21 +180,23 @@ PLIST_SUB+= NOBASE="" BASE="@comment "
SUB_LIST+= NOBASE="" BASE="@comment "
USE_RC_SUBR+= named
SUB_FILES+= named.conf
-.if ${PORT_OPTIONS:MGOST}
-WITH_OPENSSL_PORT=yes
-.endif
.else
PLIST_SUB+= NOBASE="@comment " BASE=""
SUB_LIST+= NOBASE="@comment " BASE=""
-.if ${PORT_OPTIONS:MSSL}
-WITH_OPENSSL_PORT= yes
-.endif
.endif
PKGDEINSTALL= ${PKGINSTALL}
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.if ( ${PORT_OPTIONS:MGOST} ) && defined(WITH_OPENSSL_BASE)
+BROKEN= OpenSSL from the base system does not support GOST, add \
+ WITH_OPENSSL_PORT=yes to your /etc/make.conf and rebuild everything \
+ that needs SSL.
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|readline/readline.h|editline/readline.h|; \
s|readline/history.h|histedit.h|' \
@@ -241,4 +244,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
${STAGEDIR}${ETCDIR}/rndc.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind99/distinfo b/dns/bind99/distinfo
index 4833e8612f89..b2874b3e2516 100644
--- a/dns/bind99/distinfo
+++ b/dns/bind99/distinfo
@@ -1,4 +1,5 @@
-SHA256 (bind-9.9.8-P4.tar.gz) = 5ed0b852e4d1dc90e10751c7fa70a9ee29a619bad61d97250eac8161009d89f2
-SIZE (bind-9.9.8-P4.tar.gz) = 7999697
-SHA256 (9.9.8-P4-rpz2+rl.14038.05.patch.xz) = 5415559171c03a9a02e31284552a4888911eeb692d57def8d631b7d0564dc5f0
-SIZE (9.9.8-P4-rpz2+rl.14038.05.patch.xz) = 39240
+TIMESTAMP = 1464252734
+SHA256 (bind-9.9.9-P1.tar.gz) = 9bcc76b8cbee2e64210e80fc6b57a8e8ff07780f994f87d5a2aa312cdfa24aa4
+SIZE (bind-9.9.9-P1.tar.gz) = 8758793
+SHA256 (9.9.9-P1-rpz2+rl.14038.05.patch.xz) = 230ab0dbf30e8cf956ea6557d00046618abe158cb2fc3c2204c021ace58e5588
+SIZE (9.9.9-P1-rpz2+rl.14038.05.patch.xz) = 39284